Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: iMac g3 with Rage 128 gives frame buffer error (2011)

  1. #1

    iMac g3 with Rage 128 gives frame buffer error (2011)

    This comes from the original thread:
    http://ubuntuforums.org/showthread.php?t=1096448

    rsavage user made me a question, and I don't know why overdrank user closed the forum thread.

    rsavage, yo can see the complete sheet for this computer here:
    http://wiki.lapipaplena.org/index.ph...350-ubuntu1104

    But I also copy the xorg.conf content:
    Code:
    # xorg.conf optimized for Apple iMac G3 350 (Summer 2000) with Ubuntu GNU/Linux 11.04
    # Display device: ATI Technologies Inc Rage 128 PR/PRO AGP 4x TMDS
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Device"
    	Identifier "ATI Technologies Inc Rage 128 PR/PRO AGP 4x TMDS"
    	# BusID	"PCI:0:16:0"
    	# Driver "ati"
    	Driver "r128"
    	Option "NoInt10" "true"
    	Option "CCEusecTimeout" "100000"
    	Option "UseFBDev" "false"
    	Option "XAANoOffscreenPixmaps"
    	Option "SWcursor" "true"
    	# Option "ForcePCIMode" "true"
    EndSection
    
    Section "Module"
    	Load "i2c"
    	# Load "bitmap"
    	Load "ddc"
    	Load "dri"
    	# Disable "dri"
    	Load "dri2"
    	Load "record"
    	Load "extmod"
    	Load "freetype"
    	# Load "dbe"
    	# Load "glx"
    	# Load "int10"
    	Load "type1"
    	# Load "vbe"
    EndSection
    
    Section "Extensions"
    	Option "Composite" "Enable"
    EndSection 
    
    Section "DRI"
    	Mode 0666
    EndSection
    
    Section "Monitor"
    	# Supports 1024x768@75, 800x600@94, 640x480@116
    	Identifier	"iMac"
    	VendorName	"iMac"
    	ModelName	"Monitor Model"
    	Option "DPMS"
    	HorizSync 58-62
    	VertRefresh 75-117
    	# ModeLine "1024x768" 78.75 1024 1044 1140 1328 768 781 784 820 +hsync +vsync
    	# ModeLine "800x600" 62.40 800 821 901 1040 600 609 612 644 +hsync +vsync
    	# Modeline "640x480" 49.90 640 657 721 832 480 481 484 514 +hsync +vsync
    EndSection
    
    Section "Screen"
    	Identifier "Default Screen"
    	Device "ATI Technologies Inc Rage 128 PR/PRO AGP 4x TMDS"
    	Monitor "iMac"
    	# Ubuntu 11.04 doesn't work in 16bit colour depth mode here
    	DefaultDepth 24
    	SubSection "Display"
    		Depth 1
    		Modes "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth 4
    		Modes "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth 8
    		Modes "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth 15
    		Modes "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth 16
    		Modes "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth 24
    		Modes "1024x768" "800x600" "640x480"
    		#Virtual 1024 768
    	EndSubSection
    EndSection
    I don't know how to check if the X-Window session is working with 2D or 3D acceleration. I tested "glxgears -info" and gave me up to 10fps, but I don't know if it's the maximum for that graphics chip.
    Narcis Garcia

  2. #2
    Join Date
    Jan 2011
    Beans
    1,013

    Re: iMac g3 with Rage 128 gives frame buffer error (2011)

    Hi Narcis Garcia,

    Thanks for getting back to me with this. I don't know why overdrank closed that other thread either! I did complain to the mods that it was an overuse of power, but they didn't reopen it!

    I did see your link that you posted later on another thread so thanks for that too! It's been on my list of things to do to reply to that thread. I've been very busy at the moment with limited amount of time to write on the forum and many threads I just haven't been able to answer.

    I haven't got a r128 card, but my interest is due to this guide that I wrote http://ubuntuforums.org/showpost.php...35&postcount=1 . I wanted to make sure I was advising people correctly. Somebody on askubuntu.com was trying to follow an early version of the guide and totally failed with the r128!

    The user 'axion' did post an interesting answer though http://askubuntu.com/questions/58488...on/62789#62789 .

    Compiling a kernel seems a bit extreme (and I'm not sure whether the answer by axion is 100% accurate), particularly after I read the post by 'walterav' on the MintPPC forum http://mintppc.org/forums/viewtopic....1&p=2673#p2673 . He says his method works on Ubuntu 11.04 too:

    .... Even switching virtual consoles "ttys" that have a lower resolution is working fine! I haven't tried the mintppc versions yet, but only pure debian 5 and ubuntu 11.04 mini. .....

    Second, the real problem is that with new kernel versions "offb" (openfirmware framebuffer) always gets loaded first. Therefor "aty128fb" will not load (memory reserved error etc), and is probably blacklisted, check syslog/dmesg and it will report something about framebuffer. This was fixed by adding "video=offb:off" to yaboot.conf in the append section, btw this file resides in the boot partition not in /etc/. When you restart you have no framebuffer at all and won't see a thing on your screen, unless you can login via ssh. So before you restart, uncomment aty128fb in /etc/modprobe/blacklist-framebuffer.conf. This will give you a framebuffer halfway past the bootstrap as soon as the modules get loaded. So don't panic if you see the Openfirmware/yaboot screen freezing when the system is booting, just wait and you have your picture back.

    The third thing that fixed this was using a "xorg.conf" I found on this website with only adding (Option "UseFBDev" "true"), because you gonna use the framebuffer "aty128fb" and selecting "r128" as the Driver. Therefor all the other maybe conflicting options "NoInt10" etc are not necessary, but these well found Options might be necessary as a workaround if you have no or conflicting framebuffers.
    .....
    I should point out he has got the thing about the yaboot.conf wrong. You should edit the file in /etc and then use the command ybin to copy it across to the boot partition. Alternatively, if you just want to test it you could use at the second yaboot prompt:
    Code:
    Linux video=offb:off
    It might be best to check first you haven't got anything like video=ofonly in your yaboot.conf as I don't know how that would react with the new yaboot parameter.

    Another thing he has got wrong is that you actually want to comment the line (by adding a #) in /etc/modprobe/blacklist-framebuffer.conf rather than uncommenting it like he says.

    If after a reboot things are successful, you could possibly load the aty128fb framebuffer earlier in the boot process by running the command "update-initramfs -u"?

    You could possibly test all these things at the second yaboot prompt by typing:

    Code:
    Linux video=offb:off modprobe aty128fb
    Option "UseFBDev" "true" is the default setting on PowerPC so you shouldn't have to state it in a xorg.conf.

    It would be interesting if any of these things make a difference to your experience of the r128. When you run "glxgears -info", if you don't see "Software Rasterizer" written then you have 3D working I think (but I am no expert on this). When you run "glxinfo" check that you have at the start of the output "direct rendering: Yes".

    Finally, it is great to see your enthusiasm for ubuntu and the iMac. Keep up the good work!

    rsavage

    EDIT: I've just seen your comment at the bottom of the askubuntu thread so you know most of this stuff already!!!
    Last edited by rsavage; December 13th, 2011 at 04:51 PM.

  3. #3
    Join Date
    Nov 2009
    Beans
    28

    Re: iMac g3 with Rage 128 gives frame buffer error (2011)

    ok so this is new to ubutnu and i am having a similar problem

    i tried to do the Linux video= fixes but when entering them in the Linux video=offbff caused the white screen to freeze up

  4. #4
    Join Date
    Jan 2011
    Beans
    1,013

    Re: iMac g3 with Rage 128 gives frame buffer error (2011)

    Okay let's focus on getting a working system by an xorg.conf......

    I'll use the xorg.0.log from the askubuntu page as a guide. I suspect you have something similar. The relevant snippet from the bottom is here:

    Code:
    [  1902.318] (**) R128(0): Using framebuffer device
    [  1902.318] (II) Loading sub module "fbdevhw"
    [  1902.318] (II) LoadModule: "fbdevhw"
    [  1902.319] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
    [  1902.325] (II) Module fbdevhw: vendor="X.Org Foundation"
    [  1902.325]    compiled for 1.10.1, module version = 0.0.2
    [  1902.326]    ABI class: X.Org Video Driver, version 10.0
    [  1902.326] (EE) Unable to find a valid framebuffer device
    [  1902.327] (EE) R128(0): Failed to open framebuffer device, consult warnings and/or errors above for possible reasons
        (you may have to look at the server log to see warnings)
    [  1902.327] (II) UnloadModule: "r128"
    [  1902.327] (II) Unloading r128
    [  1902.327] (II) UnloadModule: "fbdevhw"
    [  1902.327] (II) Unloading fbdevhw
    [  1902.327] (EE) Screen(s) found, but none have a usable configuration.
    [  1902.332] 
    Fatal server error:
    [  1902.332] no screens found
    [  1902.332]
    There is no shame in not understanding this as first glance. The people trying to help on the askubuntu page literally answer 1000s of problems so they are not novices to linux. However, none of them properly read the log, instead, they all focused on the last error message "EE) Screen(s) found, but none have a usable configuration".

    If you trace further back up you'll see there are other error messages, the first being "(EE) Unable to find a valid framebuffer device". It is trying to use a framebuffer device. We know this because it tells us "(**) R128(0): Using framebuffer device". This is in line with what the r128 manual says for PowerPC:

    Option "UseFBDev" "boolean"
    Enable or disable use of an OS-specific framebuffer device
    interface (which is not supported on all OSs). See fbdevhw(4)
    for further information. Default: on for PowerPC, off for other
    architectures.
    If we set this value to false in your xorg.conf it won't now look for a framebuffer and so you won't have the error.

    Now, what I am not sure about is the NoInt10. This is described in the "Screen" section of the manual, although it seems you can put it in the "Device" section too:

    Option "NoInt10" "boolean"
    Disables the Int10 module, a module that uses the int10 call to
    the BIOS of the graphics card to initialize it. Default: false.
    Whether you get another error relating to Int10 I can only speculate. A lot of people seem to set this to true so it is worth trying if you still have a problem.

    The users 'axion' and 'walterav' are trying to fix the framebuffer error in a different way. I suspect there is a better way than they both describe, but let's cross that bridge after you at least get a working system.

  5. #5
    Join Date
    Nov 2009
    Beans
    28

    Re: iMac g3 with Rage 128 gives frame buffer error (2011)

    couple of questions

    first how do i set useFBdev to false i am going to try putting false in the bool parantheses but i don't know if i need to uncomment the line

    second how can i send the output on my screen in an email or something to another computer so i can post it here (im in cli so its kind of hard)

    third i dont remember how to run that xorg file or whatever to get that screen with the no screen found but i did get that same screen

  6. #6
    Join Date
    Nov 2009
    Beans
    28

    Re: iMac g3 with Rage 128 gives frame buffer error (2011)

    oh also i dont see the noint10 in my xorg.conf file so i dont know what to do to edit that if the framebuffer fix doesn't work

  7. #7
    Join Date
    Nov 2009
    Beans
    28

    Re: iMac g3 with Rage 128 gives frame buffer error (2011)

    i tried the framebuffer=false option and the framebuffer was bypassed but it still ran to cli

    then i added the noint10 line since i couldn't find it so i thought that would be good except now it goes to a blank screen like its thinking but it isn't responding and i cant get into the cli anymore

  8. #8
    Join Date
    Jan 2011
    Beans
    1,013

    Re: iMac g3 with Rage 128 gives frame buffer error (2011)

    Quote Originally Posted by new to ubutnu View Post
    second how can i send the output on my screen in an email or something to another computer so i can post it here (im in cli so its kind of hard)
    No idea I'm afraid as I have never needed to look into it. You can use google probably better than me!

    All your other questions are answered in the lubuntu instructions. You are asking questions when I am sound asleep so if you want answers then you'll get a quicker answer by re-reading the instructions. To get back to the command line you can boot into single user mode. At the second yaboot prompt type:

    Linux single

    When you are logged in, I suggest you do the following:

    (I think this is the right file for your mac)

    wget http://mac.linux.be/files/xorg/imac5.txt
    sudo mv imac5.txt /etc/X11/xorg.conf

    Then open the file

    sudo nano /etc/X11/xorg.conf

    Change UseFBDev to false.

    Save, exit and reboot with the command "sudo reboot".

    This should hopefully work. If it doesn't try adding NoInt10 like in post #1 of this thread.

    I've been looking into what you need to do to get UseFBDev True working. There are some basic-ish instructions in the lubuntu instructions at the moment, but I'll refine them this afternoon when I listen to the football (if it is a dull match!).

  9. #9
    Join Date
    Nov 2009
    Beans
    28

    Re: iMac g3 with Rage 128 gives frame buffer error (2011)

    worked after noint10 this time so im happy also is there any cleaning up i need to do/can do to make startup time faster or is my computer so old it just wont go faster

    secondly how can i uninstall some files like bluetooth and wireless that i dont need since my computer is a desktop

    third thanks a ton

  10. #10
    Join Date
    Jan 2011
    Beans
    1,013

    Re: iMac g3 with Rage 128 gives frame buffer error (2011)

    Quote Originally Posted by new to ubutnu View Post
    worked after noint10 this time so im happy
    Excellent! I thought we were never going to get there! I think maybe you needed to add some modelines before? That xorg.conf does it a different way with the HorizSync and VertRefresh lines. Have you got all the resolutions you need as I notice 1024x768 is not listed in the file? Have you tried to change resolutions to check it is all working?

    secondly how can i uninstall some files like bluetooth and wireless that i dont need since my computer is a desktop
    Uninstall bluetooth with "sudo apt-get remove gnome-bluetooth" or use the application Synaptic. You can stop the Network Applet from starting by removing it from the startup list? Any other changes you'll have to ask on a different forum because I don't know the answer!

    also is there any cleaning up i need to do/can do to make startup time faster or is my computer so old it just wont go faster
    How fast is the boot up time at the moment?

    You should get a faster system if we can get UseFBDev to work when set to true. Sorry didn't get around to writing those instructions! Here is some....

    First lets check what speed you have at the moment.

    Close any running applications like Firefox so they don't affect the result.
    Code:
    sudo apt-get install mesa-utils
    glxinfo
    What does the direct rendering line at the top of the output say? Is it yes or no?

    Then run "glxgears -info"

    What does the OpenGL render string line say?
    Then what FPS do you get?

    Right now we've got to make some changes!!!! This is experimental!!!!

    sudo nano /etc/X11/xorg.conf

    Comment out the UseFBDev and NoInt10 lines by putting a # at the start.
    Code:
          # Option "UseFBDev" "False"
          # Option "NoInt10" "True"
    Save.

    Then open yaboot.conf with "sudo nano /etc/yaboot.conf" and remove "video=ofonly" if it is in the 'append' lines. Save and run the command "sudo ybin -v". Laugh at the funny message.

    Then run the command "sudo nano /etc/initramfs-tools/modules" and add
    Code:
    aty128fb
    on a new line. Save and then run the command "sudo update-initramfs -u".

    Reboot and see if it loads. If it doesn't try "Linux video=offb:off" at the second yaboot prompt. If you get to a cli login then you'll have to make more changes:

    Type the command "sudo nano /etc/modules" and add to the file on a new line
    Code:
    aty128fb
    Save and then run the command "sudo update-initramfs -u" again. Reboot and see if it loads. If it doesn't try "Linux video=offb:off" at the second yaboot prompt. If you get to a cli login then you'll have to make try even more changes:

    sudo nano /etc/modprobe/blacklist-framebuffer.conf

    Remove the # from in front of the "aty128fb" line.

    Save and re-run the "sudo update-initramfs -u" command.

    Reboot ("sudo reboot"). If that doesn't work then try try "Linux video=offb:off" again. If that doesn't work try uncommenting the NoInt10 line in the xorg.conf.

    If that doesn't work then reverse all the changes and re-run the "sudo update-initramfs -u" command.

    If you do get it working then redo all the tests with glxgears and glxinfo and see if things have changed.

    If you just keep getting a blank frozen screen and can't return to a cli or graphical login then you may have to boot using "old" at the second yaboot prompt. Reverse all the changes again but the update-intramfs command will be slightly different. Type "man update-intramfs" to see if you can work it out.
    Last edited by rsavage; December 11th, 2011 at 12:14 AM. Reason: Added yaboot.conf changes + extras + more

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •