Results 1 to 3 of 3

Thread: Windows Guest ignores CPU topology settings on Lucid host

  1. #1
    Join Date
    Sep 2005
    Beans
    47
    Distro
    Kubuntu

    Windows Guest ignores CPU topology settings on Lucid host

    I try to assign 8 host cores to Windows 2003 Server Standard guest. Because this OS version has a limit of 4 sockets, I have to change the CPU topology. My guest definition:
    Code:
      <vcpu>8</vcpu>
      <cpu match='minimum'>
        <model>core2duo</model>
        <topology sockets='4' cores='1' threads='2'/>
      </cpu>
    doesn't work as expected. I should have 4 CPUs in the Device Manager and 8 CPU charts in Task Manager, but I have the opposite. And no matter what numbers I set in the topology, the guest always detects 8 sockets. What am I doing wrong?

  2. #2
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    1,714
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Windows Guest ignores CPU topology settings on Lucid host

    If I do the same as you did, I get the same result as you. Note that my host is an Ubuntu 14.04 server.
    However, if I do this (and "virsh edit" forces some of this upon exit, so it cann't look exactly like what you did):
    Code:
      <vcpu placement='static'>8</vcpu>
      <os>
        <type arch='x86_64' machine='pc-i440fx-1.7'>hvm</type>
        <boot dev='hd'/>
      </os>
      <features>
        <acpi/>
        <apic/>
        <pae/>
      </features>
      <cpu mode='custom' match='minimum'>
        <model fallback='allow'>core2duo</model>
        <topology sockets='4' cores='2' threads='2'/>
      </cpu>
    Then I get what I think you wanted:
    Code:
    doug@desk-dev:~$ cat /proc/cpuinfo | grep "core id"
    core id         : 0
    core id         : 1
    core id         : 0
    core id         : 1
    core id         : 0
    core id         : 1
    core id         : 0
    core id         : 1
    doug@desk-dev:~$ cat /proc/cpuinfo | grep "cpu cores"
    cpu cores       : 2
    cpu cores       : 2
    cpu cores       : 2
    cpu cores       : 2
    cpu cores       : 2
    cpu cores       : 2
    cpu cores       : 2
    cpu cores       : 2
    doug@desk-dev:~$ cat /proc/cpuinfo | grep "physical id"
    physical id     : 0
    physical id     : 0
    physical id     : 1
    physical id     : 1
    physical id     : 2
    physical id     : 2
    physical id     : 3
    physical id     : 3
    My guest VM is an Ubuntu 15.04 desktop
    Last edited by Doug S; 6 Days Ago at 11:42 PM.
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  3. #3
    Join Date
    Sep 2005
    Beans
    47
    Distro
    Kubuntu

    Re: Windows Guest ignores CPU topology settings on Lucid host

    Quote Originally Posted by Doug S View Post
    If I do the same as you did, I get the same result as you. Note that my host is an Ubuntu 14.04 server.
    None of the settings were supported, so I upgraded to Precise, and now everything works as expected. Thank you.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •