Results 1 to 7 of 7

Thread: WUBI fails if it finds ISO with correct size but wrong content

  1. #1
    Join Date
    Apr 2005
    Beans
    139

    WUBI fails if it finds ISO with correct size but wrong content

    When I tried to run WUBI to install Ubuntu on a Windows XP system, it failed without any warning. I finally found the log file, and discovered that WUBI fails silently if it finds an ISO with the file size that it expects to find, but without the correct content.

    The only way to solve this was to run WUBI multiple times, and each time check the log file to find which ISO file it tried to load - and then rename the file to another extension (for example, .ISO--) so that WUBI would not try to load it. After renaming three such ISO files, WUBI eventually ran.

    Perhaps WUBI could at least post an error message explaining why it did not run. That would be better than failing silently.

  2. #2
    Join Date
    Nov 2009
    Location
    North Vancouver
    Beans
    Hidden!
    Distro
    Edubuntu 12.04 Precise Pangolin

    Re: WUBI fails if it finds ISO with correct size but wrong content


  3. #3
    Join Date
    Apr 2005
    Beans
    139

    Re: WUBI fails if it finds ISO with correct size but wrong content

    Done:

    https://bugs.launchpad.net/wubi/+bug/894164

    Thank you for the easy-to-use link!

  4. #4
    Join Date
    Nov 2009
    Location
    North Vancouver
    Beans
    Hidden!
    Distro
    Edubuntu 12.04 Precise Pangolin

    Re: WUBI fails if it finds ISO with correct size but wrong content

    Great! Don't forget to attach the wubi log file to the bug.

  5. #5
    Join Date
    Apr 2005
    Beans
    139

    Re: WUBI fails if it finds ISO with correct size but wrong content

    Argh. I probably destroyed the log file. I can reproduce it easily, however, and will add a log file later.

  6. #6
    Join Date
    Nov 2009
    Location
    North Vancouver
    Beans
    Hidden!
    Distro
    Edubuntu 12.04 Precise Pangolin

    Re: WUBI fails if it finds ISO with correct size but wrong content

    What you've added now looks good. It's enough for them to know how to reproduce the problem. Wubi is supposed to ignore incorrect ISO's and keep going, eventually download a new one if required. Even if it finds a valid Ubuntu ISO it checks inside for a /.disk/info file to confirm it's the correct release - so I suspect this is a new bug introduced in 11.10.

    PS if you do have the log file (or recreate it) just add it as an attachment. Sometimes there are bits that don't seem important. I don't think that's an issue in this case, but in general it's better.

  7. #7
    Join Date
    Apr 2005
    Beans
    139

    Re: WUBI fails if it finds ISO with correct size but wrong content

    Have now added a log file. Now that I look at it (as I explain in my bug-report post) I wonder if the problem has something to do with packed ISO files. But the maintainers will be able to figure it out from the log, I hope.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •