Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Authentication required for wireless network every time I logon

  1. #1
    Join Date
    Nov 2011
    Beans
    7

    Authentication required for wireless network every time I logon

    Hi,
    Just installed Ubuntu 11.10 for the first time and all looking good except for one small annoying problem.
    Everytime I logon or the laptop returns from suspend it seems to take a while to reconnect to the wireless network (any way of speeding this up?) and then I'm given a prompt saying 'Authentication required by wireless network' and there is a Password box which is already filled in with my wireless network password. All I have to do is click the 'Connect' button without typing anything in and then it connects. There isn't anything wrong with my wireless network as my work laptop with Windows7 connects fine.
    I've gone into Edit Connections and clicked 'Available to all users' etc but it doesn't make any difference.

    It seems like a fairly basic thing to have working, not sure why it isn't.

    Any ideas how to stop it prompting me?

    Thanks.

  2. #2
    Join Date
    Aug 2008
    Location
    Jawja
    Beans
    2,486
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Authentication required for wireless network every time I logon

    I assume you have also set it to connect automatically? That should be on the same window where you allow all users.

  3. #3
    Join Date
    Nov 2011
    Beans
    7

    Re: Authentication required for wireless network every time I logon

    Yes, the automatically connect is clicked.
    It does automatically try to connect but it just prompts me every time for the password even though the password is actually saved in the dialog box. It's a bit odd.
    Last edited by chesl73; November 23rd, 2011 at 11:36 AM.

  4. #4
    Join Date
    Jun 2011
    Beans
    3

    Re: Authentication required for wireless network every time I logon

    I just want to add that I see the same problem since I upgraded to Ubuntu 11.10.
    From my userid (with rooot authority) I need to enter the wireless password evyry time I login
    Another userid at the same system (with no root authority) does not see this problem.
    I am no linux expert but I have in this area not changed anything.
    I regularly run Update Manager and this made me upgrade to 11.10 and 11.10 works OK apart from this
    annoying feature.
    Mats Mohlin Sweden

  5. #5
    Join Date
    Oct 2009
    Beans
    2

    Re: Authentication required for wireless network every time I logon

    Same problem here with 11.10 on an HP dm1 (Ralink 5390 wireless if I remember right), Draytek router and WPA. After a cold start, it occasionally connects right away but usually throws up the Authentication required box (with the password already correctly set) once or twice. There's a long delay each time. Eventually it connects correctly.

    However, if the machine is suspended (even during one of the long delays), the wireless always connects immediately on resumption.

    Methinks it's a timing problem related to the delay before the keyring is unlocked after cold-start along with bugs in the driver where things aren't properly initialised before each connection retry. I do have "Available to all users" checked but don't have a second user on the machine to try out.

  6. #6
    Join Date
    Aug 2010
    Beans
    7

    Re: Authentication required for wireless network every time I logon

    I'm having the same problem since upgrading to 11.10 from 10.04. Stupidly, I also replaced my wireless adapter at the same time (my old D-Link DW130 never worked) so I've introduced a second variable, but I'm sure it's an issue of the OS rather than the device as I didn't install any drivers.

    I've done a bit of hunting around and found this:

    http://askubuntu.com/questions/85781...p-key-is-saved

    The answer is fairly unhelpful, especially to a not particularly technical person such as I, but can anyone tell me if it is at least on the right lines? If the issue is with Gnome Keyring, will disabling that service cause issues elsewhere? The authentication bug is annoying (I came down this morning to find about 30 of those pop ups requesting the key needed clearing), but it doesn't seem to be actually disabling the wireless service.

  7. #7
    Join Date
    Oct 2005
    Location
    Paris, France
    Beans
    6
    Distro
    Ubuntu Breezy 5.10

    Re: Authentication required for wireless network every time I logon

    Maybe this thread indicates a solution:
    http://ubuntuforums.org/showthread.php?t=1424085

    If you don't want to follow the link - what it says is that there is an option, when editing a wireless profile connection, called "Available to all users" that you can activate. Activating this option might solve the annoying problem of having at each login a window asking to push the OK button.

  8. #8
    Join Date
    Jan 2012
    Beans
    55

    Re: Authentication required for wireless network every time I logon

    I have tried the options discussed here but no luck. This problem just popped up for me- my Lenovo has been a dream with Ubuntu 11.10 until today. Is this a bug in the O/S? There are other threads about it but nothing solves the problem.

  9. #9
    Join Date
    Jan 2012
    Beans
    55

    Re: Authentication required for wireless network every time I logon

    Anyone? Any ideas at all?

  10. #10
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,839
    Distro
    Ubuntu Development Release

    Re: Authentication required for wireless network every time I logon

    Quote Originally Posted by chesl73 View Post
    Hi,
    Just installed Ubuntu 11.10 for the first time and all looking good except for one small annoying problem.
    Everytime I logon or the laptop returns from suspend it seems to take a while to reconnect to the wireless network (any way of speeding this up?) and then I'm given a prompt saying 'Authentication required by wireless network' and there is a Password box which is already filled in with my wireless network password. All I have to do is click the 'Connect' button without typing anything in and then it connects. There isn't anything wrong with my wireless network as my work laptop with Windows7 connects fine.
    I've gone into Edit Connections and clicked 'Available to all users' etc but it doesn't make any difference.

    It seems like a fairly basic thing to have working, not sure why it isn't.

    Any ideas how to stop it prompting me?

    Thanks.
    Hi please give me the output of
    Code:
    iwconfig
    .

    Thank you .
    Google First your issue , if no solution then ask.

    రాజ శేఖర్ రెడ్డి

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •