Results 1 to 5 of 5

Thread: How do I set Nvidia HDMI audio as default audio output

  1. #1
    Join Date
    Jun 2014
    Beans
    4

    How do I set Nvidia HDMI audio as default audio output

    So I have my HTPC with Ubuntu 14.04 LTS and my default Intel 3400 GPU was not doing so great for video rendering so I threw in an MSI Nvidia 210 GPU because it had a low profile bracker for my HTPC and the video issues are all solved. Now I have this minor issue that every reboot it seems to not keep the HDMI for the Nvidia card as the default output. So I need to know how can I lock it as the default audio output?

  2. #2
    Join Date
    May 2008
    Location
    Toronto, Ontario, Canada
    Beans
    748
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How do I set Nvidia HDMI audio as default audio output

    I ran into a similar issue - I have Bose speakers driven through a USB port.
    There is an application, gnome-media, that I have installed from the repositories. It provides a GUI based way to set defaults for input and output. It seems to work very well.
    I've attached a screenshot.

    You may install this using the Software Center or in a Terminal: sudo apt-get install gnome-media.

    I hope this helps,
    Attached Images Attached Images
    "Always take the high road! That way, nothing will hit you when the brown, gooey stuff hits the fan."
    Additional setup for Ubuntu 14.04: https://wiki.ubuntu.com/fballem/Software%2014.04

  3. #3
    Join Date
    Jun 2014
    Beans
    4

    Re: How do I set Nvidia HDMI audio as default audio output

    Ok so it's installed how do I launch it on 14.04.1 LTS I can't find it

  4. #4
    Join Date
    May 2008
    Location
    Toronto, Ontario, Canada
    Beans
    748
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How do I set Nvidia HDMI audio as default audio output

    In the HUD, type multi. It will be identified as Multimedia Systems Selector.

    Sorry that I didn't mention it.
    "Always take the high road! That way, nothing will hit you when the brown, gooey stuff hits the fan."
    Additional setup for Ubuntu 14.04: https://wiki.ubuntu.com/fballem/Software%2014.04

  5. #5
    Join Date
    May 2008
    Location
    Toronto, Ontario, Canada
    Beans
    748
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How do I set Nvidia HDMI audio as default audio output

    Hi,

    I remembered that there is a setting in the gnome-media configuration file that you need to change.

    If the Gnome Media tool was installed, by default it will not be displayed. To correct this:

    1. copy the following command into a Terminal: gksudo gedit /usr/share/applications/gstreamer-properties.desktop
    2. this will open up the desktop file in an editor.
    3. locate the line for NoDisplay. By default, this is set to true.
    4. change the value to false.
    5. save the file, then close the editor.

    That should correct any remaining issues.

    Hope this helps,
    "Always take the high road! That way, nothing will hit you when the brown, gooey stuff hits the fan."
    Additional setup for Ubuntu 14.04: https://wiki.ubuntu.com/fballem/Software%2014.04

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •