Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Disable Nautilus on Startup in KDE

  1. #1
    Join Date
    Mar 2011
    Beans
    5

    Disable Nautilus on Startup in KDE

    Hi, I have been using Kubuntu (Ubuntu installed first) for a little while now, and recently when starting up a Nautilus window has been opening. I would like to use only Dolphin, not Nautilus. I haven't been able to disable it yet, and I'd like to know how to.

    I can't remember what I did to cause this, but it may have had something to with my messing with the Dolphin -> Dolphin Preferences -> Startup -> Home Folder -> Location. Currently, it is "file:///" sans quotes (I think at one point it was blank), and I am unable to clear and set the value.

    That may be what is causing it. Or it may be startup programs, although I haven't found anything for this.

    While I'm at it, I may as well ask how to disable Nautilus completely while I'm using KDE, as I only want to use Dolphin.

    Thank you very much for your help!

  2. #2
    Join Date
    Mar 2011
    Location
    Pizza Hut
    Beans
    1,212
    Distro
    Kubuntu 13.10 Saucy Salamander

    Re: Disable Nautilus on Startup in KDE

    What do you see here:
    System Settings -> Startup and Shutdown -> Autostart

    If you see Nautilus, disable it (untick the check box). As for disabling Nautilus completely, just make sure Dolphin is sat as the default file manager:
    System Settings -> Default Applications -> File Manager
    Ubuntu user #35115 - Linux user #555707 - My Ubuntu Wik page
    Join the Ubuntu Forums' IRC room (#ubuntuforums on irc.freenode.net)!

  3. #3
    Join Date
    Mar 2011
    Beans
    5

    Re: Disable Nautilus on Startup in KDE

    I checked both of those, and both were already set in the way you instructed.

    Can you think of anything else?

    EDIT: The only thing in Autostart is gtk2-default-theme.rc.sh

    EDIT2: I have discovered that the Nautilus window opens (on login) when using the KDE Plasma Workspace, and not when logging on to Ubuntu.
    Last edited by czarmurphy; November 20th, 2011 at 05:56 AM.

  4. #4
    Join Date
    Mar 2011
    Beans
    5

    Re: Disable Nautilus on Startup in KDE

    Anybody find anything?

  5. #5
    Join Date
    Nov 2010
    Location
    Bogota
    Beans
    84
    Distro
    Ubuntu Development Release

    Re: Disable Nautilus on Startup in KDE

    Did you check on the start up services?, System settings > startup and shutdown > Service manager
    Don't beg for things, do it yourself or else you won't get anything

  6. #6
    Join Date
    Nov 2008
    Location
    United States
    Beans
    2,090
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Disable Nautilus on Startup in KDE

    that is just a few of the annoyances.

    in my opinion, if it matters, i would decide what desktop you like best then run only that from a fresh install.

    personally, i been running kubuntu for years, i haven't did the session thing for a few years, and will never do it again.

    kubuntu is better experienced solo, even if you remove the ubuntu desktop or kde, it'll never be like it was.

    http://www.psychocats.net/ubuntu/kde

  7. #7
    Join Date
    Mar 2011
    Beans
    5

    Re: Disable Nautilus on Startup in KDE

    Thanks for the advice. I'll get started on this soon.

  8. #8
    Join Date
    Apr 2010
    Beans
    2

    Re: Disable Nautilus on Startup in KDE

    Your symptoms exactly describe what I was experiencing. My solution was to replace the 'Restore previous session' with 'Start with an empty session' check box found in System Settings - Startup and Shutdown - Session Management. I then reverted back to the default setting after re-logging into KDE and the offending window remained gone thereafter.

  9. #9
    Join Date
    Jun 2009
    Beans
    7

    Re: Disable Nautilus on Startup in KDE

    thnx steve!

    It worked for me too

  10. #10
    Join Date
    Mar 2012
    Beans
    1

    Re: Disable Nautilus on Startup in KDE

    I had exactly the same problem with a Nautilus window opening on every restart. To get rid of it I went to System Settings -> Startup and Shutdown -> Session Management. In the "On Login" section there is a field "Applications to be excluded from sessions" and I added "nautilus" to this. After a restart the Nautilus window didn't return.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •