Results 1 to 10 of 10

Thread: Gnome keyring/Nvidia drivers

  1. #1
    Join Date
    Mar 2010
    Location
    Buenos Aires, Argentina
    Beans
    52
    Distro
    Kubuntu 11.04 Natty Narwhal

    Cool Gnome keyring/Nvidia drivers

    Hello there! I have turned an old box into an entertainment system using Lubuntu (11.10) through a HDMI output to my TV.

    My first question is regarding services. I have disabled all non-essential services and the only ones left are the Gnome Keyring services:

    Gnome Keyring: SSH Agent
    Gnome Keyring: GPG Agent
    Gnome Keyring: Secret Service

    What would happen if I were to disable these services? Which ones do I NEED. They take up a reasonably large chunk of my CPU and RAM capacity which I would like to see freed-up.

    My second question is regarding the proprietary Nvidia drivers. I installed the driver and saw a boost in performance for emulation and HD video playback, but despite running under the 1280x720 resolution I need, the borders of the screen were out of the monitor (this doesn't happen in the open source drivers). This basically made the machine pretty unusable since the small LXDE menus were out of view, as were full screen window controls, so I have now reverted to the open source drivers. Any way to fix this under proprietary drivers? I searched the forums and google many times, couldn't find anything that worked.

    I will post any additional information needed

    Thanks!

  2. #2
    Join Date
    Dec 2005
    Beans
    697

    Re: Gnome keyring/Nvidia drivers

    Gnome keyring saves your password through a session, for example you run gksu nautilus, enter your password, close nautilus and if you run gksu nautilus again without logging out first you don't need to enter your password the second time. It can be removed without issues.

    The Nvidia problem makes no sense to me, did you adjust resolution with gksu nvidia-settings? Did you try different refresh rates too?

  3. #3
    Join Date
    Jul 2011
    Location
    Lubuntu One Stop Group
    Beans
    Hidden!
    Distro
    Lubuntu

    Re: Gnome keyring/Nvidia drivers

    Sounds like you're in Linux driver hell just like me.

    http://www.ypass.net/blog/2009/07/dv...hdtv/#comments

    read the comments.

    I know that solution works, because it fixed the exact same problem for me. I skipped to the comment about changing the settings on the tv. Turns out my HDMI monitor was in 'Video' mode.

    About the keyring daemons... I could give you my best guess, but how would that help?
    Let me tell you not to worry about the CPU/ RAM they are using.

  4. #4
    Join Date
    Mar 2010
    Location
    Buenos Aires, Argentina
    Beans
    52
    Distro
    Kubuntu 11.04 Natty Narwhal

    Re: Gnome keyring/Nvidia drivers

    Thanks hhh, I disabled those services with no impact on my system. It boots faster now and there's more of my precious 1gb of RAM to go round

    marinara, unfortunately my TV doesn't have those options (cheap flatscreen I picked up, only gives me the option of 4:3 and 16:9, no other video options) and there is no xorg.conf in Lubuntu, which is why when I tried some other solutions before, they didn't work. If I can find a way of making those changes to xorg, I will but just don't know how to.

  5. #5
    Join Date
    Jul 2011
    Location
    Lubuntu One Stop Group
    Beans
    Hidden!
    Distro
    Lubuntu

    Re: Gnome keyring/Nvidia drivers

    yeah, i'm in the same boat. Everything I read is config xorg this, config xorg that.
    but I don't know the first damn thing about config xorg

  6. #6
    Join Date
    Mar 2010
    Location
    Buenos Aires, Argentina
    Beans
    52
    Distro
    Kubuntu 11.04 Natty Narwhal

    Re: Gnome keyring/Nvidia drivers

    Yeah, it's made even harder by the fact that Lubuntu is not a hugely popular distro. I had problems with ATI drivers on an Ubuntu machine a couple of years ago and solved them by typing a few commands in from the forums... But with Lubuntu it's much harder to find anything useful.

  7. #7
    Join Date
    Jul 2011
    Location
    Lubuntu One Stop Group
    Beans
    Hidden!
    Distro
    Lubuntu

    Re: Gnome keyring/Nvidia drivers

    what kills me is that it was working before you installed Nvidia drivers. So there's probably a fix that doesn't involve the LCD

  8. #8
    Join Date
    Dec 2005
    Beans
    697

    Re: Gnome keyring/Nvidia drivers

    http://www.ypass.net/blog/2010/04/nv...atest-drivers/

    Run nvidia-settings (Alt+F2 for the "Run" dialog, the "gksu nvidia-settings" without the quotes).

    If you don't have nvidia-settings, install it via a terminal...
    Code:
    sudo apt-get install nvidia-settings
    -edit- Hmm, I don't know, though. I have the latest Nvidia drivers and I don't see those settings in nvidia-settings. It might be that my card is old (an integrated GeForce 6150LE).
    Last edited by hhh; November 19th, 2011 at 06:15 PM.

  9. #9
    Join Date
    Mar 2010
    Location
    Buenos Aires, Argentina
    Beans
    52
    Distro
    Kubuntu 11.04 Natty Narwhal

    Re: Gnome keyring/Nvidia drivers

    I'm going to try and play with the Nvidia settings again. If it fails and I get a command line screen (happened before) how do I reset to default (open source drivers, standard config)? Just in case...

  10. #10
    Join Date
    Mar 2010
    Location
    Buenos Aires, Argentina
    Beans
    52
    Distro
    Kubuntu 11.04 Natty Narwhal

    Re: Gnome keyring/Nvidia drivers

    OK, increased the resolution to 1920x1080 in Nvidia settings from the native resolution of 1280x720 (under which the open source drivers worked), then in GPU Scaling, I changed it to Aspect Ratio Scaled.

    Then on my TV, there is a setting called "point to point", which normally centres the image and makes it very small, but in this case fills the screen perfectly. Only problem is, when I use an emulator in full screen, I have to switch to 16:9, but doesn't really bother me. Also now runs on 1080p rather than 720p, which is cool.

    Had to increase all the font sizes because they were unreadable and Plymouth looks like crap, but it usually does with proprietary drivers.

    The only thing left was the sound, which under ALSA didn't work after installing the drivers (I'm assuming because the sound now wanted to be played through HDMI). Installed pulseaudio and changed the profile to "Digital Stereo (HDMI) nr 2 Output" in the list of options, that was the only one that gave sound.

    Hopefully that will help anyone having similar problems, other threads seem to be outdated. I will now mark the thread as solved since the issues have been resolved! Thank you

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •