We use a CUPS print server in our research lab. I've been having an issue with printing PDFs from Windows XP/Acrobat to a Lucid (10.04) CUPS server. I've confirmed that it's a bug in poppler which affects Lucid, and the version of poppler that is installed on Lucid.

My question is, can I work around this bug by installing a different version of CUPS/poppler? I've already checked and there doesn't seem to be an appropriate PPA. I've told students in our lab to use Foxit and some of them have worked around it by converting the PDF to a word document. But it would be nice if there were an easy way to change to a version of CUPS/poppler that actually works short of compiling from source.