Results 1 to 4 of 4

Thread: Getmail - username with special character

  1. #1
    Join Date
    May 2008
    Location
    Center of England
    Beans
    219
    Distro
    Ubuntu 10.04 Lucid Lynx

    Getmail - username with special character

    I am trying to set up Getmail to retrieve emails from a server. Unfortunately my ISP creates individual e-mail boxes based on the main user (smiths) and box name (john), so:
    Code:
    smith+john
    When I setup Getmail rc file for john like:
    Code:
    [retriever]
    type = SimplePOP3Retriever
    server = mail.plus.net
    username = smiths+john
    password = aBetterPassword
    
    [destination]
    type = Maildir
    path = /var/mail/john@smiths.com/Maildir/
    
    [options]
    delete = false
    read_all = false
    Getmail creates a mail box for smiths.

    Anyone know if there is a way to get round this problem? k
    Last edited by kamaji792; November 14th, 2011 at 01:51 PM.
    vim Java PHP Perl and C a long time ago :/
    ssh_user to ssh in then su to sudo_user. They have to guess 'name' and 'password' X 2 - sudo is good

  2. #2
    Join Date
    Oct 2008
    Location
    Stuttgart, Germany
    Beans
    441
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Getmail - username with special character

    have you tried "smiths+john" or smiths\+john ?

  3. #3
    Join Date
    May 2008
    Location
    Center of England
    Beans
    219
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Getmail - username with special character

    I think I have solved my problem.

    Just a little bit of background. I am using Getmail to feed a Dovecote mail server. Effectively doing a POP3 to IMAP conversion.

    I was following this how-to https://help.ubuntu.com/community/POP3Aggregator

    It was not Getmail that was creating the mail box it was Dovecote.

    This is the first time I have done anything like this and I am still coming to grips with it.

    What my rc file should have looked like was:
    Code:
    [retriever]
    type = SimplePOP3Retriever
    server = mail.plus.net
    username = smiths+john
    password = aBetterPassword
    
    [destination]
    type = Maildir
    path = /var/mail/smiths/Maildir/
    
    [options]
    delete = false
    read_all = false
    The only line that changes is path = /var/mail/smiths/Maildir/.

    I believe Dovecote has a problem with account names that are not URL friendly (though + => %2B may work).
    vim Java PHP Perl and C a long time ago :/
    ssh_user to ssh in then su to sudo_user. They have to guess 'name' and 'password' X 2 - sudo is good

  4. #4
    Join Date
    Sep 2011
    Location
    London
    Beans
    383

    Re: Getmail - username with special character

    Hi Kamaji

    ...Unfortunately my ISP creates individual e-mail boxes based on the main user (smiths) and box name (john), so:
    Code:
    smith+john
    ...
    Just in passing you might note that '+' is a very common for subaddressing, where user+thing@domain gets delivered to user@domain. Google's gmail, for example, uses '+' for this, and it's a very useful though not widely-known part of email addressing. The part to the left of '@' is considered local to the receiving system, and it's allowed to do surprising things with it. Subaddressing is formalised in RFC 5233, while addresses in general are covered in RFC 5322.

    Hope that's some interest!

    Kind regards,
    Jonathan.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •