Results 1 to 6 of 6

Thread: How to get wireless card led to blink on activity

  1. #1
    Join Date
    Dec 2010
    Beans
    6
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Question How to get wireless card led to blink on activity

    Hi,
    I installed Ubuntu 11.10 on my laptop a couple of days ago. What I noticed is that my wireless card LED (it's a atheros card, driver is ath9k) isn't blinking anymore on network activity. it did when I used windows on this machine (the blink frequency depended on the bandwidth, from slower to faster) and it kinda worked with Ubuntu 10.10 (though it would blink at the same speed, no matter what bandwidth speed). Now, with Ubuntu 11.10 it just stays on when the card is enable, it stays off when I power it off. I need it to blink, cause it gives me indication of the network speed, so I can see if the download speed is at its max speed or not.
    I've searched everywhere, but I only found tips on how to disable the LED blink, rather than enable it.
    can anyone help me please? thanks

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,947
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How to get wireless card led to blink on activity

    Please try this:
    Code:
    sudo rmmod -f ath9k
    sudo modprobe ath9k blink=1
    If it works, we can write a file and make it permanent.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Dec 2010
    Beans
    6
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Wink Re: How to get wireless card led to blink on activity

    it worked like a charm, man! thanks a lot. so, what's the next thing to do? i mean, to make it permanent. thanks for the help, i appreciate it.

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,947
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How to get wireless card led to blink on activity

    Sorry I missed your reply. Here you go:
    Code:
    sudo gedit /etc/modprobe.d/ath9k.conf
    Add one line:
    Code:
    options ath9k blink=1
    Proofread, save and close gedit. You should be all set.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Dec 2010
    Beans
    6
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Wink Re: How to get wireless card led to blink on activity

    Thanks a lot. It worked!

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,947
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How to get wireless card led to blink on activity

    Please use Thread Tools at the top to Mark Solved.

    Caution to the searchers: blink=1 is a parameter in some but not all drivers. Check your driver with modinfo:
    Code:
    modinfo ath9k
    filename:       /lib/modules/3.0.0-12-generic-pae/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko
    license:        Dual BSD/GPL
    description:    Support for Atheros 802.11n wireless LAN cards.
    author:         Atheros Communications
    srcversion:     7D3316A936D7C60FE66D883
    alias:          platform:ar934x_wmac
    alias:          platform:ath9k
    alias:          pci:v0000168Cd00000032sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00000030sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd0000002Esv*sd*bc*sc*i*
    alias:          pci:v0000168Cd0000002Dsv*sd*bc*sc*i*
    alias:          pci:v0000168Cd0000002Csv*sd*bc*sc*i*
    alias:          pci:v0000168Cd0000002Bsv*sd*bc*sc*i*
    alias:          pci:v0000168Cd0000002Asv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00000029sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00000027sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00000024sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00000023sv*sd*bc*sc*i*
    depends:        ath9k_hw,mac80211,cfg80211,ath9k_common,ath
    vermagic:       3.0.0-12-generic-pae SMP mod_unload modversions 686 
    parm:           debug:Debugging mask (uint)
    parm:           nohwcrypt:Disable hardware encryption (int)
    parm:           blink:Enable LED blink on activity (int)
    parm:           btcoex_enable:Enable wifi-BT coexistence (int)
    If your wireless driver doesn't contain this or a similar parameter, this fix won't work for you.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •