Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: apt-get update/upgrade issues.

  1. #11
    Join Date
    Jul 2011
    Beans
    3

    Re: apt-get update/upgrade issues.

    Quote Originally Posted by raja.genupula View Post
    first do this and dont go for upgrade now , paste here

    Code:
    sudo apt-get install -f
    I did sudo apt-get install -f and I got the following:

    Correcting dependencies... failed.
    The following packages have unmet dependencies:
    libglib2.0-0 : Breaks: libglib2.0-0:i386 (!= 2.31.0+git20111027.9782598b-0ubuntu1~11.10~ricotz0) but 2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0 is installed
    libglib2.0-0:i386 : Breaks: libglib2.0-0 (!= 2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0) but 2.31.0+git20111027.9782598b-0ubuntu1~11.10~ricotz0 is installed
    libglib2.0-bin : Depends: libglib2.0-0 (= 2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0) but 2.31.0+git20111027.9782598b-0ubuntu1~11.10~ricotz0 is installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    E: Unable to correct dependencies

  2. #12
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,827
    Distro
    Ubuntu Development Release

    Re: apt-get update/upgrade issues.

    Hi man
    I have seen some similar old threads with your problem but i need to confirm again .Have you installed Ubuntu or upgraded ? If upgraded then in what way you did ? I mean directly from 10.10 to 11.10 or some thing else ?

    I need this details man.
    Raja

    రాజ శేఖర్ రెడ్డి

  3. #13
    Join Date
    Jul 2011
    Beans
    3

    Re: apt-get update/upgrade issues.

    I upgraded. I installed 11.04 and then upgraded to 11.10. I then installed gnome-shell which I think is what is causing the problem I have had 11.10 since from its official release day and installed gnome shell awhile ago. I didn't have any problems until about a week ago. If it means I have to remove gnome-shell to get this to go away I will. Just not sure what to do. Hope this info helps.

  4. #14
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,827
    Distro
    Ubuntu Development Release

    Re: apt-get update/upgrade issues.

    Hi man issue looking some what complex but i will try man .
    open your synaptic and look for this pkg libglib2.0-0 and any broken pkg's and try to install that pkg and all its dependencies from there .

    all the best.
    Raja

    రాజ శేఖర్ రెడ్డి

  5. #15
    Join Date
    Nov 2009
    Location
    Lake Wales Florida
    Beans
    607
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: apt-get update/upgrade issues.

    Quote Originally Posted by kstac13 View Post
    I upgraded. I installed 11.04 and then upgraded to 11.10. I then installed gnome-shell which I think is what is causing the problem I have had 11.10 since from its official release day and installed gnome shell awhile ago. I didn't have any problems until about a week ago. If it means I have to remove gnome-shell to get this to go away I will. Just not sure what to do. Hope this info helps.
    You need to get rid of ricotz PPA and re-install gnome shell from the package manager. Also if you have the gnome3/team/gnome3 PPA installed it should be removed or disabled. Both of these are development and will cause things to break.For gnome-tweak and the extensions use the web8 PPA.
    AMD FX-6200 - MSI 4.1Ghz- Nvidia GTX550Ti -12/GIG - 60GB-SSD/500 Sata - 12.04 - Gnome 3

  6. #16
    Join Date
    Aug 2011
    Beans
    1

    Re: apt-get update/upgrade issues.

    I know it's quit dirty, but just deleted the changelog file mentioned there from my system, them updated with -f, and works.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •