Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: apt-get update/upgrade issues.

  1. #1
    Join Date
    Dec 2010
    Beans
    18

    Angry apt-get update/upgrade issues.

    Hello All,

    I am still newbie for Ubuntu. Please let me know if you need more info for helping out.

    When I run

    sudo apt-get update
    sudo apt-get upgrade

    I started to see below error for last 2 days. It was working fine earlier.


    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
    libglib2.0-0 : Breaks: libglib2.0-0:i386 (!= 2.31.0+git20111107.f09e71af-0ubuntu1~11.10~ricotz0) but 2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0 is installed
    libglib2.0-0:i386 : Breaks: libglib2.0-0 (!= 2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0) but 2.31.0+git20111107.f09e71af-0ubuntu1~11.10~ricotz0 is installed
    libglib2.0-bin : Depends: libglib2.0-0 (= 2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0) but 2.31.0+git20111107.f09e71af-0ubuntu1~11.10~ricotz0 is installed
    E: Unmet dependencies. Try using -f.


    So I tried sudo apt-get -f install and it gives below error


    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
    libglib2.0-0
    The following packages will be upgraded:
    libglib2.0-0
    1 upgraded, 0 newly installed, 0 to remove and 29 not upgraded.
    2 not fully installed or removed.
    Need to get 0 B/1,879 kB of archives.
    After this operation, 4,096 B of additional disk space will be used.
    Do you want to continue [Y/n]? Y
    (Reading database ... 188351 files and directories currently installed.)
    Preparing to replace libglib2.0-0 2.31.0+git20111107.f09e71af-0ubuntu1~11.10~ricotz0 (using .../libglib2.0-0_2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0_amd64.deb) ...
    Unpacking replacement libglib2.0-0 ...
    dpkg: error processing /var/cache/apt/archives/libglib2.0-0_2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0_amd64.deb (--unpack):
    './usr/share/doc/libglib2.0-0/ChangeLog.pre-2-2.gz' is different from the same file on the system
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Errors were encountered while processing:
    /var/cache/apt/archives/libglib2.0-0_2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    I didn't have much clue as how to fix this. Any Help is much appreciated.

    Thank you very much.

    -Nambi

  2. #2
    Join Date
    Dec 2008
    Beans
    5

    Re: apt-get update/upgrade issues.

    I get the same exact error. I think ricotz needs to fix his packages.

    Not sure how to fix this. Not sure its anything we can fix.

    Heres the error I get.
    E: /var/cache/apt/archives/libglib2.0-0_2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0_amd64.deb: './usr/share/doc/libglib2.0-0/ChangeLog.pre-2-2.gz' is different from the same file on the system

    Fixed it.
    run this command: sudo rm /usr/share/doc/libglib2.0-0/ChangeLog.pre-2-2.gz

    then redo the upgrade. it will succeed this time.
    Last edited by gravyplaya; November 12th, 2011 at 06:02 AM. Reason: found a fix

  3. #3
    Join Date
    Dec 2010
    Beans
    18

    Smile Re: apt-get update/upgrade issues.

    Awesome, Thank you gravyplaya!. That solved the issue.

    From what I saw it seems updating higher version causing issue? Hope it wont happen again.

  4. #4
    Join Date
    Oct 2008
    Beans
    328

    Re: apt-get update/upgrade issues.

    Quote Originally Posted by gravyplaya View Post
    I get the same exact error. I think ricotz needs to fix his packages.

    Not sure how to fix this. Not sure its anything we can fix.

    Heres the error I get.
    E: /var/cache/apt/archives/libglib2.0-0_2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0_amd64.deb: './usr/share/doc/libglib2.0-0/ChangeLog.pre-2-2.gz' is different from the same file on the system

    Fixed it.
    run this command: sudo rm /usr/share/doc/libglib2.0-0/ChangeLog.pre-2-2.gz

    then redo the upgrade. it will succeed this time.
    It did not work for me
    after deleting the above file.

    When I type ap-get upgrade I get:
    # apt-get upgradeReading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
    libglib2.0-bin : Depends: libglib2.0-0 (= 2.31.0+git20111113.fac9e8d2-0ubuntu1~11.10~ricotz0) but 2.31.0-0ubuntu1~oneiric1 is installed
    libglib2.0-dev : Depends: libglib2.0-0 (= 2.31.0+git20111113.fac9e8d2-0ubuntu1~11.10~ricotz0) but 2.31.0-0ubuntu1~oneiric1 is installed
    E: Unmet dependencies. Try using -f.
    I tried the -f option as well. It did not help.

  5. #5
    Join Date
    Dec 2010
    Beans
    18

    Re: apt-get update/upgrade issues.

    I didn't understand whether its correct to do but I do had same issue once again yesterday then. Again I did the the same which seems to help.

    sudo rm /usr/share/doc/libglib2.0-0/ChangeLog.pre-2-2.gz

    I am sorry it didn't work for you, may be somebody else could chime in. I'll change Solved status, so some experts can peek in.

    Regards,
    Nambi

  6. #6
    Join Date
    Sep 2009
    Beans
    3

    Re: apt-get update/upgrade issues.

    It helped to me to remove the file, but I had to run
    sudo apt-get -f install
    before I ran
    sudo apt-get upgrade

  7. #7
    Join Date
    Oct 2008
    Beans
    328

    Re: apt-get update/upgrade issues.

    Quote Originally Posted by mortenbrekk View Post
    It helped to me to remove the file, but I had to run
    sudo apt-get -f install
    before I ran
    sudo apt-get upgrade
    I tried it exactly like that, I got the same error. I would like to mention that since this upgrade I am not able to use gnome 3.

  8. #8
    Join Date
    Oct 2005
    Location
    Dublin, Ireland
    Beans
    4
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: apt-get update/upgrade issues.

    Worked fine for me (thanks!).
    * Removed file
    * Ran apt-get install -f
    * Ran apt-get upgrade

  9. #9
    Join Date
    Jul 2011
    Beans
    3

    Re: apt-get update/upgrade issues.

    I am having the same issue.
    #Removed the file.
    #Ran apt-get install -f
    #Ran apt-get upgrade

    Still getting an error.

    The following packages have unmet dependencies:
    libglib2.0-0 : Breaks: libglib2.0-0:i386 (!= 2.31.0+git20111027.9782598b-0ubuntu1~11.10~ricotz0) but 2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0 is installed
    libglib2.0-0:i386 : Breaks: libglib2.0-0 (!= 2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0) but 2.31.0+git20111027.9782598b-0ubuntu1~11.10~ricotz0 is installed
    libglib2.0-bin : Depends: libglib2.0-0 (= 2.31.0+git20111109.759c0e93-0ubuntu1~11.10~ricotz0) but 2.31.0+git20111027.9782598b-0ubuntu1~11.10~ricotz0 is installed
    E: Unmet dependencies. Try using -f.

  10. #10
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,840
    Distro
    Ubuntu Development Release

    Re: apt-get update/upgrade issues.

    first do this and dont go for upgrade now , paste here

    Code:
    sudo apt-get install -f
    Google First your issue , if no solution then ask.

    రాజ శేఖర్ రెడ్డి

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •