Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: sound stop working

  1. #11
    Join Date
    Jul 2009
    Location
    CyberspacEastEngland
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: sound stop working

    where did you get system monitor?

    well on Oneiric it is under Applications/System Tools
    Linux is Latin for off-the-beaten-track [◄►] ● Is there Voodoo in the machine?
    ShanArt ● Mark as SolvedXmms

  2. #12
    Join Date
    Jul 2009
    Location
    CyberspacEastEngland
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: sound stop working

    Quote Originally Posted by MoreOrLess View Post
    You should probably set autospawn to no, either for all users in /etc/pulse/daemon.conf or for your user in ~/.pulse/daemon.conf (remember to remove the leading ';' if editing the /etc/ file).


    hi there can you explain a bit more??


    autospawn is not present in the file you describe
    /etc/pulse/daemon.conf

    Code:
    # This file is part of PulseAudio.
    #
    # PulseAudio is free software; you can redistribute it and/or modify
    # it under the terms of the GNU Lesser General Public License as published by
    # the Free Software Foundation; either version 2 of the License, or
    # (at your option) any later version.
    #
    # PulseAudio is distributed in the hope that it will be useful, but
    # WITHOUT ANY WARRANTY; without even the implied warranty of
    # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
    # General Public License for more details.
    #
    # You should have received a copy of the GNU Lesser General Public License
    # along with PulseAudio; if not, write to the Free Software
    # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
    # USA.
    
    ## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
    ## more information. Default values are commented out.  Use either ; or # for
    ## commenting.
    
    ; daemonize = no
    ; fail = yes
    ; allow-module-loading = yes
    ; allow-exit = yes
    ; use-pid-file = yes
    ; system-instance = no
    ; local-server-type = user
    ; enable-shm = yes
    ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
    ; lock-memory = no
    ; cpu-limit = no
    
    ; high-priority = yes
    ; nice-level = -11
    
    ; realtime-scheduling = yes
    ; realtime-priority = 5
    
    ; exit-idle-time = 20
    ; scache-idle-time = 20
    
    ; dl-search-path = (depends on architecture)
    
    ; load-default-script-file = yes
    ; default-script-file = /etc/pulse/default.pa
    
    ; log-target = auto
    ; log-level = notice
    ; log-meta = no
    ; log-time = no
    ; log-backtrace = 0
    
    resample-method = speex-float-1
    ; enable-remixing = yes
    ; enable-lfe-remixing = no
    
    flat-volumes = no
    
    ; rlimit-fsize = -1
    ; rlimit-data = -1
    ; rlimit-stack = -1
    ; rlimit-core = -1
    ; rlimit-as = -1
    ; rlimit-rss = -1
    ; rlimit-nproc = -1
    ; rlimit-nofile = 256
    ; rlimit-memlock = -1
    ; rlimit-locks = -1
    ; rlimit-sigpending = -1
    ; rlimit-msgqueue = -1
    ; rlimit-nice = 31
    ; rlimit-rtprio = 9
    ; rlimit-rttime = 1000000
    
    ; default-sample-format = s16le
    ; default-sample-rate = 44100
    ; default-sample-channels = 2
    ; default-channel-map = front-left,front-right
    
    default-fragments = 8
    default-fragment-size-msec = 10
    
    ; enable-deferred-volume = yes
    ; deferred-volume-safety-margin-usec = 8000
    ; deferred-volume-extra-delay-usec = 0

    Can anyone see anything in there that would explain sound not starting automatically on loadup ? it only does load up once out of three or four times


    thanx




    the second one
    ~/.pulse/daemon.conf
    is simply empty
    Linux is Latin for off-the-beaten-track [◄►] ● Is there Voodoo in the machine?
    ShanArt ● Mark as SolvedXmms

  3. #13
    Join Date
    Nov 2011
    Beans
    Hidden!

    Re: sound stop working

    It's client.conf, not daemonconf (sorry, doing it from memory since i don't use pulse).

  4. #14
    Join Date
    Jul 2009
    Location
    CyberspacEastEngland
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: sound stop working

    nothing there either blank page
    Linux is Latin for off-the-beaten-track [◄►] ● Is there Voodoo in the machine?
    ShanArt ● Mark as SolvedXmms

  5. #15
    Join Date
    Nov 2011
    Beans
    Hidden!

    Re: sound stop working

    /etc/pulse/client.conf

  6. #16
    Join Date
    Jul 2009
    Location
    CyberspacEastEngland
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: sound stop working

    ok moreorless found it


    will report on how it changes things

    Code:
    # This file is part of PulseAudio.
    #
    # PulseAudio is free software; you can redistribute it and/or modify
    # it under the terms of the GNU Lesser General Public License as published by
    # the Free Software Foundation; either version 2 of the License, or
    # (at your option) any later version.
    #
    # PulseAudio is distributed in the hope that it will be useful, but
    # WITHOUT ANY WARRANTY; without even the implied warranty of
    # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
    # General Public License for more details.
    #
    # You should have received a copy of the GNU Lesser General Public License
    # along with PulseAudio; if not, write to the Free Software
    # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
    # USA.
    
    ## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
    ## more information. Default values are commented out.  Use either ; or # for
    ## commenting.
    
    ; default-sink =
    ; default-source =
    ; default-server =
    ; default-dbus-server =
    
     autospawn = no
    ; daemon-binary = /usr/bin/pulseaudio
    ; extra-arguments = --log-target=syslog
    
    ; cookie-file =
    
    ; enable-shm = yes
    ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
    
    ; auto-connect-localhost = no
    ; auto-connect-display = no
    Linux is Latin for off-the-beaten-track [◄►] ● Is there Voodoo in the machine?
    ShanArt ● Mark as SolvedXmms

  7. #17
    Join Date
    Jul 2009
    Location
    CyberspacEastEngland
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: sound stop working

    does nothing better that i can see so set it back to what it was


    Could you explain what the change was supposed to do and how


    Thanx shan
    Linux is Latin for off-the-beaten-track [◄►] ● Is there Voodoo in the machine?
    ShanArt ● Mark as SolvedXmms

  8. #18
    Join Date
    Nov 2011
    Beans
    Hidden!

    Re: sound stop working

    OP was complaining about pulseaudio running after kill. It was just supposed to stop that..

  9. #19
    Join Date
    May 2008
    Location
    /dev/null
    Beans
    216
    Distro
    Ubuntu

    Re: sound stop working

    I compared results from working sound Ubuntu instance with NOT working sound Ubuntu instance on the same computer generated by:
    http://www.alsa-project.org/alsa-info.sh
    and found no problem.

    functional Ubuntu instance:
    http://www.alsa-project.org/db/?f=37...c0eeda226a074f

    NOT functional Ubuntu instance:
    http://www.alsa-project.org/db/?f=0d...0561d641b22883

    Could please somebody help me found where could be the problem ?

    thanks in advance.

  10. #20
    Join Date
    May 2008
    Location
    /dev/null
    Beans
    216
    Distro
    Ubuntu

    Re: sound stop working

    Hi,

    I would like to thank you to all of you who tried to help.
    Finally I have found the problem, which was in my default xfce desktop manager - where I switched on:
    Session and Startup -> Advanced -> Launch KDE services on startup.

    (my bad habits from windows to click on anything what looks interesting)

    cheers,
    M.

    P.S. If is there anybody who understand why it behaves like that (if there is some other KDE sound daemon conflicting current or whatever else it caused), please do not hesitate to share information.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •