Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Missing predefs.h

  1. #1
    Join Date
    Oct 2010
    Beans
    79

    Missing predefs.h

    I'm trying to build the ANSI C port for Unix v6. I'm cloned this git repo, git://pdos.csail.mit.edu/xv6/xv6.git

    When I run make I get the following error:
    Code:
    /usr/include/features.h:323:26: fatal error: bits/predefs.h: No such file or directory
    Does anyone know what could be causing it and how to fix it?

    Found a fix. I needed the proper libc includes for 32-bit builds. I'm running a 64-bit machine. So I just ran:

    sudo apt-get install libc6-dev-i386
    Last edited by Rodayo; November 10th, 2011 at 09:08 AM.

  2. #2
    Join Date
    Oct 2007
    Beans
    2

    Re: Missing predefs.h

    thanks, saved me time!

  3. #3
    Join Date
    Dec 2009
    Beans
    1

    Re: Missing predefs.h

    Thanks too, also saved me a lot of time !!!

  4. #4
    Join Date
    Mar 2011
    Beans
    1

    Re: Missing predefs.h

    Thank you! This also worked for me while I was installing OpenACC accelerator tools for PGI on my Ubuntu 12 64 bit machine. I already had my CUDA drivers squared away.

  5. #5
    Join Date
    Jul 2012
    Beans
    364
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Missing predefs.h


  6. #6
    Join Date
    Apr 2009
    Beans
    30
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Missing predefs.h

    I had the exact same error message while trying to install a flash workaround for dual monitor fullscreen issue, just saying for if somebody reach this page with the same problem, it solved and now it installs well. Thanks a lot!

  7. #7
    Join Date
    Jan 2008
    Beans
    4

    Re: Missing predefs.h

    Worked for me. Perfect! Thanks!

  8. #8
    Join Date
    Dec 2012
    Beans
    1

    Re: Missing predefs.h

    Thanks for the post!. I had the same problem. I was trying to use OPNET modeler and compile my project. With this solution it worked perfectly!.

  9. #9
    Join Date
    Jun 2013
    Beans
    1

    Re: Missing predefs.h

    It works for me. Thanks for the post!

  10. #10
    Join Date
    Oct 2008
    Location
    Chennai, India
    Beans
    11
    Distro
    Ubuntu

    Thumbs up Re: Missing predefs.h

    Quote Originally Posted by Rodayo View Post
    I'm trying to build the ANSI C port for Unix v6. I'm cloned this git repo, git://pdos.csail.mit.edu/xv6/xv6.git

    When I run make I get the following error:
    Code:
    /usr/include/features.h:323:26: fatal error: bits/predefs.h: No such file or directory
    Does anyone know what could be causing it and how to fix it?

    Found a fix. I needed the proper libc includes for 32-bit builds. I'm running a 64-bit machine. So I just ran:

    sudo apt-get install libc6-dev-i386
    Worked like magic!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •