Hello all,

I am running 10.04/lucid, Eclipse 3.5.2 and trying to get SVN properly integrated with it, but I'm having problems with JavaHL. If you can help me get it working properly that would be great!

Below is a detailed description of what I've done and what the errors are, and thanks in advance for your help!

Christo

----

  1. Installed eclipse: sudo apt-get install eclipse
  2. Followed instructions here to install Subclipse


At this point, SVN mostly works. For example, I can check out the subclipse project, connect to my own repositories, commit to them etc. However, Window > Preferences > Team > SVN generates the error message:

Failed to load JavaHL library.
These are the errors that were encountered:
no libsvnjavahl-1 in java.library.path
Incompatible JavaHL library loaded. 1.3.x or later required
Also, when I start Eclipse I get some error messages:



This same error message is repeated three times. I don't know which plugin it refers to or how to disable it?

The Subclipse page (http://subclipse.tigris.org/wiki/JavaHL) has some suggestions for this sort of problem, but unfortunately none of them work. The suggestions that it has are:

  • Adding "password-stores = " to [auth] section of ~/.subversion/config
  • Adding "-Djava.library.path=/usr/lib/jni" on new line after -vmargs in /usr/lib/eclipse/eclipse.ini
  • Running some tests of JavaHL to make sure it is installed correctly.


I've done the first two and have also tried the tests, which came back successful. This was the case whether I specified the library path for the tests or not:

  • java -Djava.library.path=/usr/lib/jni -jar javahltests.jar
  • java -jar javahltests.jar


I'm now at a bit of a loose end. If anyone has any suggestions for fixing or better understanding this problem that would be great.

Thanks!
Christo