Page 1 of 37 12311 ... LastLast
Results 1 to 10 of 368

Thread: Really slow wireless internet on ubuntu 11.10

  1. #1
    Join Date
    Mar 2011
    Beans
    3

    Really slow wireless internet on ubuntu 11.10

    Hello whoever this reads,

    A few days ago I installed Ubuntu 11.10 trough the wubi installer (I didn't feel well to partition my laptop so it seemed to be a good solution). However it seems that my internet connection is terrible slow:



    On windows I got a really fast internet connection and it is the same laptop, so the same hardware.

    I tried to fix it by googling my problem, but when I rebooted my computer this time, my internet connection was painfull slow (see above) and I lost track of every page.

    I don't know where to start, so I'm going to give some basic information:

    Code:
    bjarno@ubuntu: sudo iwconfig
    [sudo] password for bjarno:
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan0     IEEE 802.11bgn  ESSID:"xxxxxxxxxxxxx"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: xx:xx:xx:xx:xx:xx   
              Bit Rate=54 Mb/s   Tx-Power=14 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=44/70  Signal level=-66 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:1947  Invalid misc:335   Missed beacon:0
    If I need to enter more information please tell me...

    (sorry for any bad English structure, most of the time I'm talking in Dutch )

    Thanks,
    Bjarnovikus
    Last edited by bjarnovikus; November 7th, 2011 at 06:16 PM.

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,380
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Really slow wireless internet on ubuntu 11.10

    Hi, please post the results of:
    Code:
    lspci -nnk | grep -iA2 net
    Code:
    lsmod
    here by clicking on new reply and click # and paste the information between the brackets.
    Thank you

  3. #3
    Join Date
    Mar 2011
    Beans
    3

    Re: Really slow wireless internet on ubuntu 11.10

    lspci -nnk | grep -iA2 net gives me the following:

    Code:
    03:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
        Subsystem: AzureWave Device [1a3b:1089]
        Kernel driver in use: ath9k
    --
    04:00.0 Ethernet controller [0200]: Atheros Communications AR8131 Gigabit Ethernet [1969:1063] (rev c0)
        Subsystem: ASUSTeK Computer Inc. Device [1043:1820]
        Kernel driver in use: atl1c
    lsmod gives me the following:
    Code:
    Module                  Size  Used by
    nls_iso8859_1          12713  2 
    nls_cp437              16991  2 
    vfat                   17585  2 
    fat                    61475  1 vfat
    rfcomm                 47946  0 
    bnep                   18436  2 
    bluetooth             166112  10 rfcomm,bnep
    parport_pc             36962  0 
    ppdev                  17113  0 
    lp                     17799  0 
    parport                46562  3 parport_pc,ppdev,lp
    binfmt_misc            17540  1 
    vesafb                 13809  1 
    joydev                 17693  0 
    snd_hda_codec_hdmi     32040  1 
    snd_hda_codec_idt      70553  1 
    snd_hda_intel          33390  7 
    snd_hda_codec         104802  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
    snd_hwdep              13668  1 snd_hda_codec
    snd_pcm                96755  5 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    uvcvideo               72711  1 
    videodev               93004  2 uvcvideo
    v4l2_compat_ioctl32    17083  1 videodev
    snd_seq_midi           13324  0 
    psmouse                73882  0 
    snd_rawmidi            30547  1 snd_seq_midi
    snd_seq_midi_event     14899  1 snd_seq_midi
    arc4                   12529  2 
    serio_raw              13166  0 
    snd_seq                61896  2 snd_seq_midi,snd_seq_midi_event
    ath9k                 127538  0 
    fglrx                2929009  276 
    mac80211              310872  1 ath9k
    ath9k_common           13839  1 ath9k
    ath9k_hw              312866  2 ath9k,ath9k_common
    ath                    24067  2 ath9k,ath9k_hw
    snd_timer              29991  2 snd_pcm,snd_seq
    snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
    cfg80211              199587  3 ath9k,mac80211,ath
    video                  19412  0 
    snd                    68266  22 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    asus_laptop            19722  0 
    sparse_keymap          13890  1 asus_laptop
    mei                    41480  0 
    soundcore              12680  1 snd
    snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
    usb_storage            57901  2 
    uas                    18027  0 
    usbhid                 47198  0 
    hid                    95463  1 usbhid
    ahci                   26002  1 
    libahci                26861  1 ahci
    atl1c                  41643  0

  4. #4
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,380
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Really slow wireless internet on ubuntu 11.10

    Hi, you can try this please:
    Code:
    sudo ifconfig wlan0 down
    sudo rmmod -f ath9k
    sudo modprobe ath9k nohwcrypt=1
    sudo ifconfig wlan0 up
    Run the commands one at a time and do not restart your computer, if this works we will need to make it permanent.

    Also those wireless card's usually do not have good signal strength in linux so try not to get to far from your router.
    Thank you
    Last edited by Wild Man; November 7th, 2011 at 07:07 PM.

  5. #5
    Join Date
    Mar 2011
    Beans
    3

    Re: Really slow wireless internet on ubuntu 11.10

    Code:
    root@ubuntu:~# ifconfig wlan0 down
    root@ubuntu:~# rmmod -f ath9k
    root@ubuntu:~# sudo modprobe ath9k nohwcrypt=1
    WARNING: All config files need .conf: /etc/modprobe.d/bad_list, it will be ignored in a future release.
    root@ubuntu:~# ifconfig wlan0 up
    root@ubuntu:~#
    Executed the commands above and this was the result (one warning, is this a problem?). (I executed "sudo -s" for a root ).

    It worked, now my connection speed is A LOT faster.



    But what precisily did these commands do, I understand the first one and the last one but the other two are one mystery for me.

    How to make this permanent?

  6. #6
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,380
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Really slow wireless internet on ubuntu 11.10

    Hi, it added a parameter to your driver which switched encryption from hardware to software.

    Let's make it permanent:
    Code:
    gksudo gedit /etc/modprobe.d/ath9k.conf
    Add a single line:
    Code:
    options ath9k nohwcrypt=1
    Proofread carefully, save and close gedit then Reboot.

    Would you please go to the top of the page and mark this thread solved by clicking on thread tools. Thank you so much.

  7. #7
    Join Date
    Nov 2011
    Beans
    2

    Re: Really slow wireless internet on ubuntu 11.10

    Helped me out too, thanks!

  8. #8
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,380
    Distro
    Ubuntu 14.04 Trusty Tahr

  9. #9
    Join Date
    May 2005
    Beans
    7

    Re: Really slow wireless internet on ubuntu 11.10

    Hi, could this be a bug? I have the same situation in 2 laptops. One has an Intel WiFi Link 1000 and the other one an Intel 3945. Unloading/loading the module gives me something like factor 10 of improvement.
    Q: can I use this solution (hwcrypt) for the Intel HW too?
    thanks _Hans

  10. #10
    Join Date
    Dec 2011
    Beans
    27

    Re: Really slow wireless internet on ubuntu 11.10

    Quote Originally Posted by wildmanne39 View Post
    Hi, it added a parameter to your driver which switched encryption from hardware to software.

    Let's make it permanent:
    Code:
    gksudo gedit /etc/modprobe.d/ath9k.conf
    Add a single line:
    Code:
    options ath9k nohwcrypt=1
    Proofread carefully, save and close gedit then Reboot.

    Would you please go to the top of the page and mark this thread solved by clicking on thread tools. Thank you so much.
    Hi guys,
    I so hoped it would help me too, but my Terminal said it can not find ath9k file/directory on my Sony Vaio VGN-FW180D, when i wanted to apply wildmanne39's code. Could you please help me with this one. I am just new to Ubuntu. It is my first day. Many thanks in advance.
    Last edited by konstant100; December 18th, 2011 at 09:32 PM.

Page 1 of 37 12311 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •