Page 1 of 5 123 ... LastLast
Results 1 to 10 of 48

Thread: Changing brightness does not work in Ubuntu 11.10 after upgrading.

  1. #1
    Join Date
    Jan 2011
    Beans
    19

    Unhappy Changing brightness does not work in Ubuntu 11.10 after upgrading.

    Hello,
    I
    After upgrading to Ubuntu 11.10 in my Sony Vaio Laptop(VGN-CS) and using Unity as a desktop environment,increasing and decreasing brightness via fn+f5 and fn+f6 does not worked any more.
    I remember that i did not installed any NVIDIA driver in my laptop,
    but it seems that Ubunut itself installed it in new version after upgrading to 11.10.
    I also test http://ubuntuguide.net/change-screen...ntu-11-0410-10,but it does not work.
    I can not worked with my laptop any more because brightness of my
    screen is too high now.

    Khosro.
    Last edited by khosro; November 4th, 2011 at 03:42 PM.

  2. #2
    Join Date
    Nov 2010
    Location
    Foshan, China
    Beans
    437
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Changing brightness does not work in Ubuntu 11.10 after upgrading.

    If you open "Additional Drivers", does it say that the NVIDIA driver is currently activated ?

  3. #3
    Join Date
    Jan 2011
    Beans
    19

    Re: Changing brightness does not work in Ubuntu 11.10 after upgrading.

    Yes ,it is.
    I have attached a related screenshot picture.

    Khosro.
    Attached Images Attached Images

  4. #4
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,625
    Distro
    Ubuntu Development Release

    Re: Changing brightness does not work in Ubuntu 11.10 after upgrading.

    Hi

    What is the make and model of your latop and graphics card ?

    Open a terminal and type

    Code:
    ls /sys/class/backlight
    Copy and paste the results back here.

    Then type

    Code:
    lsmod | grep video
    and do the same thing.

    Lastly

    Code:
    cat /proc/cmdline
    Post back as well.

    Kind regards
    Join us on irc at #ubuntuforums. For web chat see here

    If you believe everything you read, you better not read. ~ Japanese Proverb

    Do not read newspapers on an empty stomach ~ Russian Proverb ~ BrunoLotse

  5. #5
    Join Date
    Jan 2011
    Beans
    19

    Re: Changing brightness does not work in Ubuntu 11.10 after upgrading.

    Hi matt_symes,
    My laptop is Sony Vaio VGN-CS and graphic cards is NVIDIA.

    The following is the commands and also output that you asked me to run :

    Code:
    khosro@khosro-laptop:~$ ls /sys/class/backlight
    sony
    
    khosro@khosro-laptop:~$ lsmod | grep video
    uvcvideo               72711  0 
    videodev               93004  1 uvcvideo
    v4l2_compat_ioctl32    17083  1 videodev
    video                  19412  0 
    
    khosro@khosro-laptop:~$ cat /proc/cmdline
    BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=0095c4f7-3bae-490d-be19-3f907855199c ro quiet splash vt.handoff=7
    Khosro.

  6. #6
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,625
    Distro
    Ubuntu Development Release

    Re: Changing brightness does not work in Ubuntu 11.10 after upgrading.

    Hi

    Open a terminal and type

    Code:
    sudo nano /etc/default/grub
    Enter your password. It will not be echoed to the screen.

    Look for the line that says

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

    and change it so it says

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
    Press ctrl + o to save and ctrl + x to exit.

    Then type

    Code:
    sudo update-grub
    Reboot your PC and check your function keys. Post back if it doesn't work.

    Edit: Just in case you missed it i have highlighted what you need to enter.

    Kind regards
    Last edited by matt_symes; November 4th, 2011 at 05:34 PM.
    Join us on irc at #ubuntuforums. For web chat see here

    If you believe everything you read, you better not read. ~ Japanese Proverb

    Do not read newspapers on an empty stomach ~ Russian Proverb ~ BrunoLotse

  7. #7
    Join Date
    Jan 2011
    Beans
    19

    Re: Changing brightness does not work in Ubuntu 11.10 after upgrading.

    matt_symes,
    I changed what you said,but unfortunately it does not work.
    The following is my grub

    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    #   info -f grub -n 'Simple configuration'
    
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    #GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=vendor"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

  8. #8
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,625
    Distro
    Ubuntu Development Release

    Re: Changing brightness does not work in Ubuntu 11.10 after upgrading.

    Hi

    Try

    Code:
    acpi_backlight=vendor
    and not

    Code:
    acpi_osi=vendor
    and then update grub again.

    Kind regards
    Join us on irc at #ubuntuforums. For web chat see here

    If you believe everything you read, you better not read. ~ Japanese Proverb

    Do not read newspapers on an empty stomach ~ Russian Proverb ~ BrunoLotse

  9. #9
    Join Date
    Jan 2011
    Beans
    19

    Re: Changing brightness does not work in Ubuntu 11.10 after upgrading.

    Still does not work.
    my grub :

    HTML Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    #   info -f grub -n 'Simple configuration'
    
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    #GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    #GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=vendor"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

  10. #10
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,625
    Distro
    Ubuntu Development Release

    Re: Changing brightness does not work in Ubuntu 11.10 after upgrading.

    Hi

    Lets check something out.

    Open a terminal and type

    Code:
    ls /sys/class/backlight/sony
    If you see a file in there called brightness then type

    Code:
    echo 5 | sudo tee /sys/class/backlight/sony/brightness
    Enter your password. It will not be echoed to the screen.

    If this lower the brightness the substituting 9 in the command above should set it back.

    If there is no brightness file then post the output of

    Code:
    ls /sys/class/backlight/sony
    Post back results.

    Kind regards
    Join us on irc at #ubuntuforums. For web chat see here

    If you believe everything you read, you better not read. ~ Japanese Proverb

    Do not read newspapers on an empty stomach ~ Russian Proverb ~ BrunoLotse

Page 1 of 5 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •