Results 1 to 5 of 5

Thread: Tecra M4 Wacom touchscreen

Hybrid View

  1. #1
    Join Date
    Nov 2006
    Beans
    41

    Tecra M4 Wacom touchscreen

    Hello

    Well the wacom works out of box like charm, but now I would like rotation of the screen.

    that works like charm:
    xrandr -o left
    After xsetwacom command the x dies no xorg log. I don't know what to do. :S
    xsetwacom set "stylus" Rotate CCW
    xsetwacom set "cursor" Rotate CCW

    xorg.conf:
    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 285.05.09  (buildmeister@swio-display-x86-rhel47-02.nvidia.com)  Fri Sep 23 19:18:19 PDT 2011
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Inputdevice     "stylus" "SendCoreEvents"
        Inputdevice     "eraser" "SendCoreEvents"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    
    Section "InputDevice"
     Driver          "wacom"
     Identifier      "stylus"
     Option          "Device" "/dev/ttyS0"
     Option          "Type" "stylus"
    # Option          "ForceDevice" "ISDV4"
     Option          "Rotate" "NONE"
    EndSection
    
    Section "InputDevice"
      Driver          "wacom"
      Identifier      "eraser"
      Option          "Device" "/dev/ttyS0"
      Option          "Type" "eraser"
    #  Option          "ForceDevice" "ISDV4"
      Option          "Rotate" "NONE"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        Option         "NoLogo" "1"
        Option         "RandRRotation" "true"
    #    Option         "Coolbits" "1"
    #    RegistryDwords "PerfLevelSrc=0x3333"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    Be free, use linux!

  2. #2
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Tecra M4 Wacom touchscreen

    Hi kaar3l,

    What release of Ubuntu are you using? Are you comfortable editing the xorg.conf? Know how to back up your current working one and can restore it from the command line?

  3. #3
    Join Date
    Nov 2006
    Beans
    41

    Re: Tecra M4 Wacom touchscreen

    Quote Originally Posted by Favux View Post
    Hi kaar3l,

    What release of Ubuntu are you using? Are you comfortable editing the xorg.conf? Know how to back up your current working one and can restore it from the command line?
    I'm using Lucid.

    Yes

    I solved this by installing Old serial tablet driver for lucid and maverick. http://ubuntuforums.org/showthread.php?t=1780154


    Now one more problem. How can I make right click? :S
    Be free, use linux!

  4. #4
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Tecra M4 Wacom touchscreen

    Hi kaar3l,

    Nice work. I thought I remembered that some of the older serial tablet PCs (maybe some of the Viewsonics too?) used the standard serial driver and not the newer ISDV4 version. Thank you for confirming that for me.

    Does your stylus have an eraser? How many side buttons does it have? One or two? Say it had one side button then you would use in your xorg.conf:
    Code:
    Section "InputDevice"
        Driver        "wacom"
        Identifier    "stylus"
        Option        "Device"         "/dev/ttyS0"
        Option        "Type"           "stylus"
        Option        "ForceDevice"    "Serial"
        Option        "Button2"        "3"
    EndSection
    Say could you do me a favor and run this command and post the output?
    Code:
    udevadm info -a -p $(udevadm info -q path -n /dev/ttyS0)

  5. #5
    Join Date
    Nov 2006
    Beans
    41

    Re: Tecra M4 Wacom touchscreen

    Command output:
    Code:
    Udevadm info starts with the device specified by the devpath and then
    walks up the chain of parent devices. It prints for every device
    found, all possible attributes in the udev rules key format.
    A rule to match, can be composed by the attributes of the device
    and the attributes from one single parent device.
    
      looking at device '/devices/pnp0/00:0b/tty/ttyS0':
        KERNEL=="ttyS0"
        SUBSYSTEM=="tty"
        DRIVER==""
    
      looking at parent device '/devices/pnp0/00:0b':
        KERNELS=="00:0b"
        SUBSYSTEMS=="pnp"
        DRIVERS=="serial"
        ATTRS{id}=="WACf004"
    
      looking at parent device '/devices/pnp0':
        KERNELS=="pnp0"
        SUBSYSTEMS==""
        DRIVERS==""
    I have one button on the stylus.
    The Option "Button2" "3" and xorg didn't work for my case.
    I used xinput --list to find id, for me it was 12.
    Then used:
    xsetwacom set 12 Button1 1
    xsetwacom set 12 Button2 3
    xsetwacom set 12 Button3 3
    and works like charm
    All the setup and my findings are documented here (its in Estonian, but commands are still in english ):
    http://viki.pingviin.org/Toshiba_Tecra_M4

    There is one problem, that after sleep the touchscreen doesn´t work. I don´t see any modules that are loaded and should be loaded after sleep. :/
    Last edited by kaar3l; November 6th, 2011 at 10:21 AM.
    Be free, use linux!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •