Page 2 of 11 FirstFirst 1234 ... LastLast
Results 11 to 20 of 110

Thread: Device not ready firmware missing

  1. #11
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,738
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Device not ready firmware missing

    Hi, it looks like you are missing the firmware we can try to get it working with this driver, and if we can not we will have to switch to the wl driver.

    Download the b43 zip file to a flash drive then drag and drop the file to your ubuntu desktop. Right-click it and select Extract Here. Open a terminal and do:
    Code:
    sudo mkdir /lib/firmware/b43
    sudo cp Desktop/b43/*  /lib/firmware/b43
    sudo rmmod -f b43
    sudo rmmod -f ssb
    sudo modprobe b43
    run the commands one line at a time.
    Thank you
    Last edited by Wild Man; February 10th, 2013 at 06:58 PM.

  2. #12
    Join Date
    Oct 2010
    Location
    Poor little country
    Beans
    25
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Device not ready firmware missing

    wildmanne39, thank you! It worked. If you ever come to Croatia, contact me. Six pack is yours. Cheers my mate!

  3. #13
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,738
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Device not ready firmware missing

    Hi, your welcome! would you please go to the top of the page and mark this thread solved by clicking on thread tools. Thank you so much.
    Enjoy

  4. #14
    Join Date
    Nov 2011
    Beans
    4

    Re: Device not ready firmware missing

    Thanks a lot!

    I had the same Firmware problem and it also worked on my Wireless Card ''Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)''

    Cheers!

  5. #15
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,738
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Device not ready firmware missing

    Hi rrubi, your welcome!
    Enjoy

  6. #16
    Join Date
    Dec 2011
    Beans
    1

    Re: Device not ready firmware missing

    Hi, Thanks a lot!
    I had the same issue..firmware missing..It worked like magic.

    cheers,

  7. #17
    Join Date
    Dec 2011
    Beans
    6

    Re: Device not ready firmware missing

    Hi im having the exact same problem but the firmware I should be looking for is not b43, instead is b57 and I cant find it anywhere.
    Hope this can help somehow:
    tnymch@Marcos-Studio-1458:~$ lspci
    00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
    00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
    00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
    00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
    00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
    00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
    00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
    00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
    00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
    00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
    00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
    00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
    02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
    05:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
    ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
    ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
    ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
    ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
    ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
    ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
    tnymch@Marcos-Studio-1458:~$
    Thanks!

  8. #18
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,738
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Device not ready firmware missing

    Hi, welcome to the forum! Please open a terminal ctrl+alt+t copy and paste the following commands into it one line at a time, then paste the results here:
    Code:
    cat /etc/lsb-release; uname -a
    lspci -nnk | grep -iA2 net
    iwconfig
    rfkill list all
    lsmod
    by clicking on new reply and click # and paste the information between the brackets.
    Thank you

  9. #19
    Join Date
    Dec 2011
    Beans
    6

    Re: Device not ready firmware missing

    Code:
    tnymch@Marcos-Studio-1458:~$ cat /etc/lsb-release; uname -a
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=11.10
    DISTRIB_CODENAME=oneiric
    DISTRIB_DESCRIPTION="Ubuntu 11.10"
    Linux Marcos-Studio-1458 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:27:26 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
    Code:
    tnymch@Marcos-Studio-1458:~$ lspci -nnk | grep -iA2 net
    02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe [14e4:1692] (rev 01)
        Subsystem: Dell Device [1028:0414]
        Kernel driver in use: tg3
    --
    05:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
        Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]
        Kernel driver in use: b43-pci-bridge
    Code:
    tnymch@Marcos-Studio-1458:~$ iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan0     IEEE 802.11bg  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:on
    Code:
    tnymch@Marcos-Studio-1458:~$ rfkill list all
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: dell-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    Code:
    tnymch@Marcos-Studio-1458:~$ lsmod
    Module                  Size  Used by
    nls_utf8               12557  1 
    isofs                  40253  1 
    parport_pc             36962  0 
    ppdev                  17113  0 
    rfcomm                 47946  0 
    bnep                   18436  2 
    bluetooth             166112  10 rfcomm,bnep
    joydev                 17693  0 
    binfmt_misc            17540  1 
    snd_hda_codec_hdmi     32040  1 
    snd_hda_codec_realtek   330769  1 
    dell_wmi               12681  0 
    sparse_keymap          13890  1 dell_wmi
    uvcvideo               72711  0 
    videodev               93004  1 uvcvideo
    v4l2_compat_ioctl32    17083  1 videodev
    dell_laptop            13831  0 
    dcdbas                 14490  1 dell_laptop
    arc4                   12529  2 
    snd_hda_intel          33390  2 
    snd_hda_codec         104802  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep              13668  1 snd_hda_codec
    snd_pcm                96755  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    snd_seq_midi           13324  0 
    snd_rawmidi            30547  1 snd_seq_midi
    b43                   341198  0 
    snd_seq_midi_event     14899  1 snd_seq_midi
    mac80211              462092  1 b43
    cfg80211              199587  2 b43,mac80211
    snd_seq                61896  2 snd_seq_midi,snd_seq_midi_event
    psmouse                73882  0 
    serio_raw              13166  0 
    intel_ips              18089  0 
    snd_timer              29991  2 snd_pcm,snd_seq
    snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
    snd                    68266  14 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    i915                  566711  7 
    soundcore              12680  1 snd
    snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
    drm_kms_helper         42558  1 i915
    drm                   236330  3 i915,drm_kms_helper
    mei                    41480  0 
    i2c_algo_bit           13423  1 i915
    wmi                    19256  1 dell_wmi
    video                  19412  1 i915
    lp                     17799  0 
    parport                46562  3 parport_pc,ppdev,lp
    ahci                   26002  3 
    libahci                26861  1 ahci
    ssb                    52752  1 b43
    tg3                   147729  0
    Thanks for the reply!

  10. #20
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,738
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Device not ready firmware missing

    Hi, let's check a few other things please post the results of:
    Code:
    nm-tool
    Code:
    sudo iwlist scan
    Code:
    sudo cat /var/log/syslog | grep -e b43 -e firmware -e wpa -etwork | tail -n55
    Disconnect your wired connection before you run the commands please.
    Thank you

Page 2 of 11 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •