This has been a pain for all those how have jumped from Ubuntu to Xubuntu, so here is how I managed to get system sounds in Xubuntu 11.10.

1st install the necessary apps:
Code:
sudo apt-get install dconf-tools ubuntu-sounds sox xfconf
Now the easy bit Login Sound.
Go to settings-settings manager-session & startup-application autostart-add.
For the Ubuntu login sound on the COMMAND Line add:
play /usr/share/sounds/ubuntu/stereo/desktop-login.ogg
You can point the command toward any sound file you like (it may have to be a .ogg file though - not tested anything else)
Add to NAME & DESCRIPTION whatever you like and click OK.

Now system sounds:
Go to system/dconf Editor/org/gnome/desktop/sound.
Make sure the Event Sounds & feedback sounds boxes are ticked.
Then change the theme name to "ubuntu" (without the quotes)
All your gtk apps should now have the same system sounds that the main Ubuntu version has.
Now go to settings-settings Editor-xsettings-net & you will see SoundThemeName, change the value to "ubuntu" (without the quotes)
All your xfce apps should now have sound also.
Finally reboot.