Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 32

Thread: blank icon added on notification area after resume since ugrade

  1. #21
    Join Date
    Oct 2009
    Location
    StartUbuntu
    Beans
    4,244
    Distro
    Ubuntu Gnome Development Release

    Re: blank icon added on notification area after resume since ugrade

    Quote Originally Posted by erchinoald View Post
    Has anyone found a fix for this, rather than the workarounds outlined above? Experiencing the same issue and it's quite annoying - Lubuntu 11.10 on a Samsung NC10. Cheers.
    Hi,

    Have you checked the reported bug(s) on Launchpad? Developers don't read/look at the forum but they do read and look at Launchpad

  2. #22
    Join Date
    Jul 2010
    Beans
    11

    Re: blank icon added on notification area after resume since ugrade

    Quote Originally Posted by amjjawad View Post
    Hi,

    Have you checked the reported bug(s) on Launchpad? Developers don't read/look at the forum but they do read and look at Launchpad
    Sorry, I've just looked now. This report appears to be where the action is: https://bugs.launchpad.net/ubuntu/+s...el/+bug/846878 ...but unfortunately there does not appear to be any solution yet. I'm not sure if at this stage it's worth adding anything to that or if I should just wait for it to be resolved?

  3. #23
    Join Date
    Oct 2009
    Location
    StartUbuntu
    Beans
    4,244
    Distro
    Ubuntu Gnome Development Release

    Re: blank icon added on notification area after resume since ugrade

    Quote Originally Posted by erchinoald View Post
    I'm not sure if at this stage it's worth adding anything to that or if I should just wait for it to be resolved?
    Anything like what?
    If you have something that will help to fix the issue then definitely go ahead and add that to the report, otherwise you need to wait

  4. #24
    Join Date
    Jul 2010
    Beans
    11

    Re: blank icon added on notification area after resume since ugrade

    Quote Originally Posted by amjjawad View Post
    Anything like what?
    If you have something that will help to fix the issue then definitely go ahead and add that to the report, otherwise you need to wait
    Anything such as 'I'm having the issue as well on an NC10'. So I suppose no, I shall continue to wait... Thanks.

    EDIT: I followed these instructions on the bug report as a workaround:

    As mentioned further up:

    Clean up the Panel
    lxpanelctl restart

    In xfce4-power-manager
    Set "System Tray Icon" to the "Never Show Icon"

    Then install the non default batter monitor

    sudo apt-get install xfce4-battery-plugin

    And add it to your panel
    ...however the new battery monitor doesn't work and just says that my battery is 100% all the time. But now I can't seem to get the original xfce4-power-manager back as I selected 'never show icon'. I presume I'm missing something basic, how can I get the regular (broken) one back?
    Last edited by erchinoald; December 17th, 2011 at 04:12 PM.

  5. #25
    Join Date
    Oct 2009
    Location
    StartUbuntu
    Beans
    4,244
    Distro
    Ubuntu Gnome Development Release

    Re: blank icon added on notification area after resume since ugrade

    Quote Originally Posted by erchinoald View Post
    Anything such as 'I'm having the issue as well on an NC10'. So I suppose no, I shall continue to wait... Thanks.
    If you are not the one who reported that bug but that bug affect you too then you can simple click on "This bug affects 6 people. Does this bug affect you?" and leave a comment if you like.

    EDIT: I followed these instructions on the bug report as a workaround...however the new battery monitor doesn't work and just says that my battery is 100% all the time. But now I can't seem to get the original xfce4-power-manager back as I selected 'never show icon'. I presume I'm missing something basic, how can I get the regular (broken) one back?
    I'm currently on Lubuntu 11.04 (doing some tests) and I need to restart but I have to leave the house and go to the clinic so will check it later. In the meantime, you can remove the applet from LXPanel and re-add it, logout or restart then check whether it's back or not.

  6. #26
    Join Date
    Oct 2009
    Location
    StartUbuntu
    Beans
    4,244
    Distro
    Ubuntu Gnome Development Release

    Re: blank icon added on notification area after resume since ugrade

    @erchinoald

    Check this thread from the beginning, I think the workaround is mentioned there somewhere. Sorry again but I must go!

  7. #27
    Join Date
    Jul 2010
    Beans
    11

    Re: blank icon added on notification area after resume since ugrade

    Thanks, I got back to it now - I just had to navigate to the settings screen via terminal.

    Frustratingly, all of this has caused me a new problem. Now whenever I return from suspend, I am asked to enter my password on a weird xscreensaver 5.14 login screen. It doesn't look like a normal login screen, and in any case I have screen locking switched off! Linux can be so trying for newcomers...

  8. #28
    Join Date
    Oct 2009
    Location
    StartUbuntu
    Beans
    4,244
    Distro
    Ubuntu Gnome Development Release

    Re: blank icon added on notification area after resume since ugrade

    Quote Originally Posted by erchinoald View Post
    Thanks, I got back to it now - I just had to navigate to the settings screen via terminal.
    Glad you managed that

    Frustratingly, all of this has caused me a new problem. Now whenever I return from suspend, I am asked to enter my password on a weird xscreensaver 5.14 login screen. It doesn't look like a normal login screen, and in any case I have screen locking switched off! Linux can be so trying for newcomers...
    I don't Suspend at all so I have no problems.

    Since you are newcomer, please read this: http://linux.oneandoneis2.org/LNW.htm

    It has nothing to do with your issue but it will enlighten your path

  9. #29
    Join Date
    Aug 2010
    Beans
    10

    Re: blank icon added on notification area after resume since ugrade

    Here is my work-around

    In a terminal shell, type:
    sudo mkdir -p /usr/local/bin
    gksudo gedit /usr/local/bin/lxpanel-reset.sh
    Now in that editor window, paste the following:
    #!/bin/sh

    # only kill panel on current X11 DISPLAY
    kill `ps e -Clxpanel | grep "DISPLAY=$DISPLAY" | awk '{print $1}'`

    # restart
    cd ; nohup lxpanel -p LXDE &
    Save the file end exit the editor. Back at the terminal shell prompt, type:
    sudo chmod a+rx /usr/local/bin/lxpanel-reset.sh
    Open a new shell, you should be able to type "lxpanel-reset.sh" and the lxpanel should restart on command.

    Now, we want a button on the toolbar to do this for us, so it's jsut a single click. So in a terminal shell, type:

    mkdir -p ~/.local/share/applications
    gedit ~/.local/share/applications/lxpanel-reset.desktop
    Now in that file, paste in the following
    [Desktop Entry]
    Categories=Utility;GTK;
    Comment=Kill lxpanel and restart with LXDE profile
    Exec=/usr/local/bin/lxpanel-reset.sh
    Icon=reload
    Name=LXPanel Restart
    NoDisplay=false
    StartupNotify=false
    Terminal=false
    Type=Application
    Save that, and now the "lxpanel reset" program shows up in the main LXDE menu under "Accessories". Logout and login to be sure.

    Now on the lxpanel, right click, goto "Panel Settings", click the "Panel Applets" tab, click "+ Add" , find and click "Application Launch Bar", click the "+ Add" button at the bottom, now back in "Panel Applets" the new Application Launch Bar is at the bottom of the list. Click on it, then click the "Edit" button on the side. A new window pops up (you might have to move the "panel preferences" window to the bottom of the screen to get at the new window).

    In the new window (Application Launch Bar) click the small triangle to expand that submenu list. Scroll down to "LXPanel Restart" and click it, then in the middle of that window click the "+ Add" button. Then click "Close" at the bottom.

    Now back in "panel preferences", you can click that "Application Launch Bar" (last entry in the "panel applets" list), and use the "Up" / "Down" buttons to position it.

    Now, if your system tray goes wonky, just click that lxpanel reset icon and it will reset it.

    I almost didn't use LXDE at all because of this issue, but I find clicking that button takes a fraction of a second, so doing that 10x a day is not a chore; i hardly notice it.

  10. #30
    Join Date
    Feb 2012
    Beans
    2

    Re: blank icon added on notification area after resume since ugrade

    A half-decent workaround I've found it to automatically restart your panel on resume. I added a script to /etc/pm/sleep.d called reset_panel:

    Code:
    #!/bin/bash
    case "$1" in
       suspend|hibernate)
          #do nothing
       ;;
       resume|thaw)
          sleep 5 && lxpanelctl restart
       ;;
       *)
          exit 1
       ;;
    esac
    exit 0
    You gotta add the 'sleep' part, I suspect 'cause the icon movement happens after this script executes.

    (I more or less copied a script I found in the same directory, called restore_brightness, which I think is a Toshiba thing)

    Using Lubuntu 11.10 on a Toshiba r835, very pleased so far. System has yet to crash, everything works out of the box. Lots of little tweaks to get Lubuntu juuuust how I like it, of course.

    EDIT: I had to refine this script a little, as described here: http://askubuntu.com/questions/10727...ume-in-lubuntu

    The improved script:
    Code:
    #!/bin/bash
    case "$1" in
       suspend|hibernate)
          #do nothing
       ;;
       resume|thaw)
          export DISPLAY=:0 #What does this do? Are there side effects?
          sleep 5 && lxpanelctl restart & #Delayed so the battery icon can finish wrecking shop.
       ;;
       *)
          exit 1
       ;;
    esac
    exit 0
    Last edited by Andrew York; February 25th, 2012 at 05:41 AM.

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •