Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Caps lock indicator applet for xubuntu 11.10 (xfce 4.8)?

  1. #1
    Join Date
    Jul 2011
    Location
    UK
    Beans
    56
    Distro
    Xubuntu 12.04 Precise Pangolin

    Red face Caps lock indicator applet for xubuntu 11.10 (xfce 4.8)?

    There isn't one

    pretty essential

    can't find out how to get one

    "lock-keys-applet" (gnome) I can't get

  2. #2
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,828
    Distro
    Ubuntu Development Release

    Re: Caps lock indicator applet for xubuntu 11.10 (xfce 4.8)?

    Raja

    రాజ శేఖర్ రెడ్డి

  3. #3
    Join Date
    Jul 2011
    Location
    UK
    Beans
    56
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Caps lock indicator applet for xubuntu 11.10 (xfce 4.8)?

    #1 doesn't work because i'm running 64 bit


    1. Install the missing dependencies. In a terminal : sudo apt-get install indicator-appmenu appmenu-gtk appmenu-qt
    2. Install the app menu : download this deb and open it with the software center
    3. Enable app menu for firefox and thunderbird. In a terminal : sudo apt-get install appmenu-gtk3 firefox-globalmenu thunderbird-globalmenu
    4. Right-click on an empty part of the top XFCE panel and choose Panel > Add New Items > App Menu plugin

    Source
    1. already installed
    2. doesn't install (only for i386)
    3. already installed
    4. because 2 doesn't install -- not available

    the "omgubuntu"

    have tried this before

    that doesn't work either this is xubuntu 11.10

    W: Failed to fetch ppa.launchpad.net/tsbarnes/indicator-keylock/ubuntu/dists/oneiric/main/source/Sources 404 Not Found

    W: Failed to fetch ppa.launchpad.net/tsbarnes/indicator-keylock/ubuntu/dists/oneiric/main/binary-amd64/Packages 404 Not Found

    W: Failed to fetchppa.launchpad.net/tsbarnes/indicator-keylock/ubuntu/dists/oneiric/main/binary-i386/Packages 404 Not Found

    HTTP:// redacted in the above to show url (indicator keylock not found)

    E: Some index files failed to download. They have been ignored, or old ones used instead.
    dan@brick:~$ sudo apt-get install indicator-keylock
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package indicator-keylock
    dan@brick:~$ sudo apt-get install indicator-keylock
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package indicator-keylock
    If I could get gnome panel applets to install I could install "lock-keys-applet"

    this is extremely basic ... a large percentage of machines don't come with a caps lock light
    Last edited by aspidistra; October 22nd, 2011 at 03:16 PM.

  4. #4
    Join Date
    Jul 2011
    Location
    UK
    Beans
    56
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Caps lock indicator applet for xubuntu 11.10 (xfce 4.8)?

    impossible ...

    there is an indicator

    doesn't work for 4.8 xfce

    there is a python hack to get round this

    I sense that people will be ditching xubuntu xfce as we speak because of such a basic omission
    Last edited by aspidistra; October 22nd, 2011 at 04:50 PM.

  5. #5
    Join Date
    Jul 2011
    Location
    UK
    Beans
    56
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Caps lock indicator applet for xubuntu 11.10 (xfce 4.8)?

    the python code for a custom applet to run once a second look for caps lock and display
    doesn't work right away

    I changed it a bit

    person who wrote it has put in the path name but hasn't got the png workign (picture, traffic light) for the applet
    no idea also - no time to bother

    could be changed to get the png working -- I have just put two asterisks up to alert caps lock on
    further addition would be for num lock symbol

    ugly - called every second (genmon applet) which is "custom python applet"

    but at least I have a caps lock indicator

    from http://blog.treellama.org/2011/01/genmon-numlockpy.html

    #!/usr/bin/python

    indicator="Caps Lock"
    text = ""
    on_icon="**"
    off_icon=""

    #on_icon = "/usr/share/pixmaps/pidgin/status/16/available.png"
    #off_icon = "/usr/share/pixmaps/pidgin/status/16/invisible.png"

    from ctypes import *

    def GetIndicatorState(name):
    state = c_bool(False)

    libX11 = CDLL("libX11.so")
    display = libX11.XOpenDisplay(0)
    atom = libX11.XInternAtom(display, name, c_bool(False))
    libX11.XkbGetNamedIndicator(display, atom, 0, byref(state), 0, 0)
    libX11.XCloseDisplay(display)

    return state.value

    if GetIndicatorState(indicator):
    print("" + on_icon + "")
    else:
    print("" + off_icon + "")
    Last edited by aspidistra; October 22nd, 2011 at 07:38 PM.

  6. #6
    Join Date
    Feb 2008
    Beans
    1,145
    Distro
    Xubuntu

    Re: Caps lock indicator applet for xubuntu 11.10 (xfce 4.8)?

    I would suggest using LXPanel, myself (if I had that problem). Meanwhile, this problem has made the wishlist.
    Help yourself: Ubuntu Docs - Ubuntu Packages

  7. #7
    Join Date
    Aug 2008
    Beans
    6

    Re: Caps lock indicator applet for xubuntu 11.10 (xfce 4.8)?

    Another way of doing it is installing:
    http://git.xfce.org/panel-plugins/xfce4-kbdleds-plugin/

    You need to compile it, the dependencies i lacked on a default xubunu oneiric ocelot 11.10, where intltool, libxfce4ui-1, xfce4-panel-dev, and xorg-dev

    they all install whit:
    Code:
    sudo apt-get install intltool libxfce4ui-1-dev xfce4-panel-dev xorg-dev
    uncompress the plugin to some folder, and on a terminal execute
    Code:
    ./config --prefix=/usr
    you need to change the prefix by hand, this is a bug from xfce4-panel. If you get some error its probably some other dependency its not fulfilled, ask around.


    then you run in the same folder:
    Code:
     make && sudo make install
    this will install the plugin and then you can add it to your panel :)
    Last edited by gridcube; October 22nd, 2011 at 06:38 PM.

  8. #8
    Join Date
    Feb 2008
    Beans
    1,145
    Distro
    Xubuntu

    Re: Caps lock indicator applet for xubuntu 11.10 (xfce 4.8)?

    Quote Originally Posted by gridcube View Post
    You need to compile it, the dependencies i lacked on a default xubunu oneiric ocelot 11.10, where intltool, libxfce4ui-1, xfce4-panel-dev, and xorg-dev
    Cool. See, already hard at work on it.

    You really need all of xorg-dev? I think I'd try xserver-xorg-dev if I could and avoid the monster pile you get from the other.
    Help yourself: Ubuntu Docs - Ubuntu Packages

  9. #9
    Join Date
    Jul 2011
    Location
    UK
    Beans
    56
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Caps lock indicator applet for xubuntu 11.10 (xfce 4.8)?

    Doesn't work GridCube

    Another way of doing it is installing:
    http://git.xfce.org/panel-plugins/xfce4-kbdleds-plugin/

    You need to compile it, the dependencies i lacked on a default xubunu oneiric ocelot 11.10, where intltool, libxfce4ui-1, xfce4-panel-dev, and xorg-dev

    they all install whit:
    Code:
    sudo apt-get install intltool libxfce4ui-1 xfce4-panel-dev xorg-dev
    libxfce4ui-1 is not available though apt

    "E: Unable to locate package libxfce4ui-1"

    I have canonical enabled (software source)
    Is this the one you said you got through synaptic (because I can't see it there either ... the compile requires that specific package) ... rhin0 from freenode here

    uncompress the plugin to some folder, and on a terminal execute
    Code:
    ./config --prefix=/usr
    ./configure --prefix=/usr works (not ./config)
    Last edited by aspidistra; October 22nd, 2011 at 06:15 PM.

  10. #10
    Join Date
    Aug 2008
    Beans
    6

    Re: Caps lock indicator applet for xubuntu 11.10 (xfce 4.8)?

    Quote Originally Posted by aspidistra View Post
    Doesn't work GridCube


    libxfce4ui-1 is not available though apt

    "E: Unable to locate package libxfce4ui-1"

    I have canonical enabled (software source)
    Is this the one you said you got through synaptic (because I can't see it there either ... the compile requires that specific package) ... rhin0 from freenode here


    ./configure --prefix=/usr works (not ./config)
    Yes, sorry, my mistake, its:


    libxfce4ui-1-dev

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •