Page 3 of 195 FirstFirst 123451353103 ... LastLast
Results 21 to 30 of 1950

Thread: Ubuntu and the asus zenbook (UX31)

  1. #21
    Join Date
    Nov 2011
    Beans
    130

    Re: Ubunutu and the asus zenbook (UX31)

    Quote Originally Posted by RR123RR View Post
    With this modification (according to the address I found in lsusb -v):

    Code:
    +EHCI_BUSES="0000:00:1d.0"
    -EHCI_BUSES="0000:00:1a.0 0000:00:1d.0"
    +XHCI_BUSES="0000:03:00.0"
    -XHCI_BUSES="0000:04:00.0"
    I get my ssh prompt back after resume instead of a total crash but I'm still not getting my screen back... any idea?
    I followed the instructions and used your addresses.
    I also did what Shakabra did.
    I have also installed the jupiter power management tool..

    My suspend and resume apparently works properly now - but only when plugged in. When on battery only the video goes wild on resume.

    I slightly patched the script to reapply disabling of tap-to-click.. so I have:

    in /etc/pm/sleep.d/20_zenbook_ux31
    Code:
    #!/bin/sh
    
    EHCI_BUSES="0000:00:1d.0"
    XHCI_BUSES="0000:03:00.0"
    
    case "${1}" in
        hibernate|suspend)
            # Switch USB buses off
            for bus in $EHCI_BUSES; do
                echo -n $bus | tee /sys/bus/pci/drivers/ehci_hcd/unbind
            done
            for bus in $XHCI_BUSES; do
                echo -n $bus | tee /sys/bus/pci/drivers/xhci_hcd/unbind
            done
            ;;
        resume|thaw)
            # Switch USB buses back on
            for bus in $EHCI_BUSES; do
                echo -n $bus | tee /sys/bus/pci/drivers/ehci_hcd/bind
            done
            for bus in $XHCI_BUSES; do
                echo -n $bus | tee /sys/bus/pci/drivers/xhci_hcd/bind
            done
            # Disable touch-to-tap on Zenbook touchpad
            echo -n 0x90 0x80 > /sys/devices/platform/i8042/serio4/setreg
            echo -n c > /sys/devices/platform/i8042/serio4/flags
            ;;
    esac
    and in /etc/pm/config.d/unload_module
    Code:
    SUSPEND_MODULES="xhci_hcd"
    And as mentioned, I have the jupiter power management tool running..

    When I shut the lid, it suspends and the power LED blinks in a similar way to how I recall it did under Windows7.. when I open the lid, I get the good ol' lock-screen prompt.

    Anyone able to reproduce this?

    EDIT: The video sometimes goes haywire when resuming with the power connected.. so there's still something odd going on
    Last edited by GodzillaMonster; November 6th, 2011 at 04:24 PM. Reason: updatishness

  2. #22
    Join Date
    Aug 2010
    Beans
    35
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubunutu and the asus zenbook (UX31)

    Quote Originally Posted by GodzillaMonster View Post
    When I shut the lid, it suspends and the power LED blinks in a similar way to how I recall it did under Windows7.. when I open the lid, I get the good ol' lock-screen prompt.

    Anyone able to reproduce this?

    EDIT: The video sometimes goes haywire when resuming with the power connected.. so there's still something odd going on
    I tried with and without the power plugged in, with suspend as the thing to do when the lid is closed in the control panel for both situations, and I get the same thing that I had before:
    I get my ssh back but not the screen and so I ctrl-alt-F1 and ctrl-alt-del to reboot...

    Strange that you actually got your screen back at least once, are you still able to get it back sometimes?
    Any other tweaks you've made?

  3. #23
    Join Date
    Nov 2011
    Beans
    130

    Re: Ubunutu and the asus zenbook (UX31)

    Quote Originally Posted by RR123RR View Post
    I tried with and without the power plugged in, with suspend as the thing to do when the lid is closed in the control panel for both situations, and I get the same thing that I had before:
    I get my ssh back but not the screen and so I ctrl-alt-F1 and ctrl-alt-del to reboot...

    Strange that you actually got your screen back at least once, are you still able to get it back sometimes?
    Any other tweaks you've made?
    I get my screen back all the time now.. that is to say, it no longer gives a black screen. I get one of two things - a perfect resume, or a resume where the screen is displaying the desktop but as if it was the wrong screen resolution or refresh rate - totally distorted. When it is distorted, sometimes closing the lid and reopening it will fix it.. other times I have to ssh to it to shut it down.

    I'm pretty sure I've not done too much other than those things mentioned - I only picked up this thing last Thursday (from Tokyo so it might be a slightly different SKU?).

    In summary I believe I:

    - Installed jupiter to manage the CPU modes
    - Added the unload of the USB3 module
    - Added the script I previously posted to remove serial modules when suspending

    Since then, I've been reviewing logs and decided we need to add apci_osi="Linux" to the grub menu, since there is a warning about it in dmesg's output.

    EDIT: Forgot to mention - I also updated the BIOS to version 206
    Last edited by GodzillaMonster; November 7th, 2011 at 07:46 AM.

  4. #24
    Join Date
    Aug 2010
    Beans
    35
    Distro
    Ubuntu 10.04 Lucid Lynx

    Question Re: Ubunutu and the asus zenbook (UX31)

    Quote Originally Posted by GodzillaMonster View Post
    - Installed jupiter to manage the CPU modes
    - Added the unload of the USB3 module
    - Added the script I previously posted to remove serial modules when suspending
    - I also updated the BIOS to version 206
    - acpi_osi="Linux" to the grub menu, since there is a warning about it in dmesg's output.
    So... let me see...
    - I have Jupiter and set it to power saver mode all the time.
    - I have the unload_module file you showed setuped and chmod 755 just in case...
    - same for the script except I'm not using the part to stop tap-to-click.
    - I also have BIOS 206
    - I just tried acpi_osi="Linux", are you talking about this line?
    Code:
    [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
    It went away and fixed the issue? (didn't go away here)

    Also do you have pcie_aspm=force in grub?

    Nothing seems to fix the screen here, I must be missing something.
    (I've attached my dmesg so you can see my boot options and error messages!)
    Attached Files Attached Files
    Last edited by RR123RR; November 7th, 2011 at 05:00 PM.

  5. #25
    Join Date
    Nov 2011
    Beans
    130

    Re: Ubunutu and the asus zenbook (UX31)

    Quote Originally Posted by RR123RR View Post
    So... let me see...
    - I have Jupiter and set it to power saver mode all the time.
    - I have the unload_module file you showed setuped and chmod 755 just in case...
    - same for the script except I'm not using the part to stop tap-to-click.
    - I also have BIOS 206
    - I just tried acpi_osi="Linux", are you talking about this line?
    Code:
    [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
    It went away and fixed the issue? (didn't go away here)

    Also do you have pcie_aspm=force in grub?

    Nothing seems to fix the screen here, I must be missing something.
    (I've attached my dmesg so you can see my boot options and error messages!)
    Hey RR,

    Note that your dmesg shows you've got "linux" and not "Linux" as your acpi_osi argument.. I have "Linux" and as a reward get:

    Code:
    [Firmware Bug]: ACPI: BIOS _OSI(Linux) query honored via cmdline
    in my dmesg.

    This boot option hasn't directly affected the suspend issue, so far as I can tell... but I will continue to test things.

    As I recall, it was the addition of the suspend script (chmod +x'd) that made the suspend behaviour change. Before that script, I had no fun.

    It would be curious if the tap-to-click function was causing this problem?

    I have no devices plugged in to any USB ports, btw.. you?

    I did a diff between your dmesg and my own and there's very little that is different - the extra option you have and the error caused by the spelling mistake are most notable.

    I'll continue to investigate!

    EDIT: btw - the unload_module file is not necessary - same results for me with or without it, which makes sense since the script does the same sort of thing.
    Last edited by GodzillaMonster; November 8th, 2011 at 12:57 PM.

  6. #26
    Join Date
    Nov 2011
    Beans
    130

    Re: Ubunutu and the asus zenbook (UX31)

    Hey all,

    I've installed a 3.1 kernel.

    In combination with the aforementioned USB3 unloader script I'm getting 100% sleep and resume reliability.

    I've closed and opened the lid 12 times so far and it's slept and woken properly (and on battery only)..

    I'll keep doing it whilst I work (on another machine) to see if it is stable

    EDIT: I've done it 20 or 30 times and it still resumes perfectly.. I'll stop now and concentrate on work - hopefully someone else can reproduce this success

    EDIT: Instructions for kernel update:
    Code:
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-oneiric/linux-headers-3.1.0-030100_3.1.0-030100.201110241006_all.deb
    sudo dpkg -i linux-headers-3.1.0-030100_3.1.0-030100.201110241006_all.deb
    
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-oneiric/linux-headers-3.1.0-030100-generic_3.1.0-030100.201110241006_amd64.deb
    sudo dpkg -i linux-headers-3.1.0-030100-generic_3.1.0-030100.201110241006_amd64.deb
    
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-oneiric/linux-image-3.1.0-030100-generic_3.1.0-030100.201110241006_amd64.deb
    sudo dpkg -i linux-image-3.1.0-030100-generic_3.1.0-030100.201110241006_amd64.deb
    Last edited by GodzillaMonster; November 8th, 2011 at 02:41 PM.

  7. #27
    Join Date
    Aug 2010
    Beans
    35
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubunutu and the asus zenbook (UX31)

    Well well, I don't know if something is different between our machines or what...
    (DH52 here)

    I fixed "Linux" and I get the same happy dmesg line that you pasted...
    I tried without my other option.
    I removed the useless unload_module.
    I tried kernel 3.1 but it didn't work either. (...and saw many crash/memory issue in dmesg)

    hehe, I must really be missing something weird here as I never got the screen back, not even once!

    I'm not too sure what to try next...! :/

  8. #28
    Join Date
    Nov 2011
    Beans
    130

    Re: Ubunutu and the asus zenbook (UX31)

    Quote Originally Posted by RR123RR View Post
    Well well, I don't know if something is different between our machines or what...
    (DH52 here)

    ...

    I'm not too sure what to try next...! :/
    Hmm.. hopefully someone else will also try so we can figure out who is the anomaly.

    Where does DH52 come from and where would I find it?

    Can you try setting the EFI Boot mode to enabled in the BIOS and retry?

    EDIT: And maybe repost dmesg with the memory errors?
    EDIT: And also for review, can you paste in your /etc/pm/sleep.d/20_zenbook_ux31 script ?
    FINAL EDIT: You are using the 64bit version of 11.10, yes?
    Last edited by GodzillaMonster; November 9th, 2011 at 11:29 AM.

  9. #29
    Join Date
    Apr 2008
    Location
    Hawaii
    Beans
    174
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Ubunutu and the asus zenbook (UX31)

    I used the sleep.d script, and upgraded to 3.1 kernel w/out Jupiter and it didn't work...

    ...at first.

    I rebooted and made sure the script was executable and suspend worked...

    ...at first.

    After one suspend/resume it stopped working and does the same thing as before.

    Jupiter didn't really help me at all, so I really don't want to install it again.

    Interestingly enough I just noticed that tap-to-click(henceforth known as ttc) is no longer disabled. So, it appears that the script is only being run once. Maybe?

    Lemme do some more digging...

  10. #30
    Join Date
    Nov 2011
    Beans
    130

    Re: Ubunutu and the asus zenbook (UX31)

    Well, at least someone's witnessed a successful resume.

    The script does indeed need to be executable.. can you review /var/log/pm-suspend.log to see if there are any errors there?

    I have the UEFI boot option set in the BIOS now - I'll disable it to see if it makes any difference.

    My ttc is definitely disabled after resume, btw - though I also disable it on boot in rc.local
    Last edited by GodzillaMonster; November 9th, 2011 at 04:57 PM.

Page 3 of 195 FirstFirst 123451353103 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •