Page 28 of 195 FirstFirst ... 1826272829303878128 ... LastLast
Results 271 to 280 of 1950

Thread: Ubuntu and the asus zenbook (UX31)

  1. #271
    Join Date
    Nov 2009
    Beans
    117
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Ubunutu and the asus zenbook (UX31)

    Does anyone have trouble with bad sound from the internal speakers on UX31? I think there's a lot of distortion even on quit low volumes, are the speakers just that crappy or is it drivers missing or is there anything wrong with my hardware? Thanks.

  2. #272
    Join Date
    Sep 2006
    Beans
    Hidden!

    Re: Ubunutu and the asus zenbook (UX31)

    Concerning the Graphic-Issues.

    This is Archlinux running 3.2.0-rc5 with reverted patch.
    Have a look at the lower left image area. This spans across the whole screen and is not the only issue? Any idea?

    Please notice the image attached.

    Other than that, how can I gather data to help fixing the "sudden powerOff" Issue?
    Attached Images Attached Images

  3. #273
    Join Date
    Dec 2011
    Beans
    5

    Re: Ubunutu and the asus zenbook (UX31)

    i915.semaphores=1 does not completely resolve the problem with random shutdowns. PC does seem a bit more stable though.

    One config that seemed stable to me was i915.modeset=0. But no 3D acceleration.

    Will update on the progress....

  4. #274
    Join Date
    Dec 2011
    Beans
    16

    Re: Ubunutu and the asus zenbook (UX31)

    Quote Originally Posted by Richy View Post
    Concerning the Graphic-Issues.
    This is Archlinux running 3.2.0-rc5 with reverted patch.
    Have a look at the lower left image area. This spans across the whole screen and is not the only issue? Any idea?
    I had some graphic issues where the i915 driver was not fully recognized. I had to put: i915.modeset=1 on the bootline to solve it.

    I could tell by doing an lsmod and no i915 module was shown.

  5. #275
    Join Date
    May 2006
    Location
    Vienna/Austria
    Beans
    Hidden!
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Re: Ubunutu and the asus zenbook (UX31)

    HTML Code:
    Zenbooks equipped with Elantech Touchpad work also out of the box. Multi-touch starts working with kernel 3.2, but left and right mouse click are not working with kernel 3.2.
    unfurtunatly i wrongly reported a fully working Elantech touchpad in a previous post. although multi-touch is really woring, left click and richt mouse click are not working which makes the touchpad hard to use.

    i've updated the wiki according to my experiences.

    so is this a kernel bug? i'd love to report it, but i have never filed a kernel bug. any advice on what information to include?

  6. #276
    Join Date
    Dec 2011
    Beans
    5

    Re: Ubunutu and the asus zenbook (UX31)

    My experiences concerning the Elantech touchpad:

    1. in Ubuntu default kernel 3.0 is only recognised as pointing device, no multitouch available. This is also true for latest 3.0.14. However both hard buttons work correctly.
    2. In series 3.1 kernels recognised as a touchpad device, multitouch available. Right click button does not work, but can be emulated through two-finger tap. Vertical and horizontal scroll work if enabled in configurations. The best support can be available through KDE configurator, there for instance a three-finger tap can be configured as middle-button.
    3. In series 3.2 touchpad support is identical to 3.1 described above.
    Last edited by tabuvudu; December 12th, 2011 at 05:04 AM.

  7. #277
    Join Date
    Nov 2011
    Beans
    44

    Re: Ubunutu and the asus zenbook (UX31)

    Zapiens: I get around 6W at its lowest when booting with:

    Code:
    i915.i915_enable_rc6=1 i915.semaphores=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1
    However, when I add

    Code:
    i915.modeset=1 pcie_aspm=force
    it can go as low as 4.7W. This is on 3.2.

  8. #278
    Join Date
    Dec 2011
    Beans
    16

    Re: Ubunutu and the asus zenbook (UX31)

    Thanks nomego, that did the trick:
    Code:
    # cat /proc/cmdline 
    BOOT_IMAGE=/boot/vmlinuz-3.2.0-rc5-ux31+ root=UUID=5c616756-6fd9-4462-9084-6b1f3823e3d5 ro quiet splash i915.modeset=1 pcie_aspm=force i915.i915_enable_rc6=1 i915.semaphores=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 vt.handoff=7
    Now I am happy with the consumption :

    Code:
    # cat /proc/acpi/battery/BAT0/state | grep rate
    present rate:            4599 mW

  9. #279
    Join Date
    Dec 2011
    Beans
    9

    Re: Ubunutu and the asus zenbook (UX31)

    Does anyone know where the reverting of dc22ee6fc18ce0f15424e753e8473c306ece95c1 (or better, a fix for the introduced bug) is in mainline kernel ?

    The kernel bugzilla still seems to be offline currently, so I don't really know where I can manifest my interest in getting that regression fixed or sending over log and such...

    Also, I'm currently testing my UX31 (128Go + Elantech touch pad) with 12.04 alpha1. So far, out of the box, the following don't work:
    - can't boot without adding nomodeset to the kernel command line (as expected)
    - multitouch works, somewhat (I wasn't able to enable the two-fingers scrolling in the gnome configuration applet where the touchpad tab is missing, but I may have missed some options).
    - usb-to-ethernet do'nt work (as expected)
    - no resuming after closing the lid

    I'm planning to open bugs (or bumping some old ones) in order to get as many things as possible to work out of the box with Precise.

  10. #280
    Join Date
    Nov 2011
    Beans
    44

    Re: Ubunutu and the asus zenbook (UX31)

    thcourbon: I'm in discussions with Keith P who actually have ordered a Zenbook for himself to take a look at that regression and an RC6 fix.
    I've tried his first patch but it didn't fix it completely.

    The resume issue is because of ehci_hcd needed to be unbound, the reply I got from LKML regarding this is a link to an Asus Laptop Suspend discussion at http://thread.gmane.org/gmane.linux.kernel/1222803

    You're very welcome to continue pushing that issue, you can see the bare minimum needed a page or two back (without unloading xhci_hcd and running xset).

    Also I've made a "Bugs and issues" section on the wiki with issues being worked on and solved, please update that section when you have anything to add!

Page 28 of 195 FirstFirst ... 1826272829303878128 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •