Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Cryptkeeper No Longer Launches After Upgrading to 11.10

  1. #11
    Join Date
    Jan 2011
    Beans
    2

    Re: Cryptkeeper No Longer Launches After Upgrading to 11.10

    That worked perfect for me. Thank you

  2. #12
    Join Date
    Nov 2009
    Location
    uk
    Beans
    3
    Distro
    Ubuntu 9.10 Karmic Koala

    Smile Re: Cryptkeeper No Longer Launches After Upgrading to 11.10

    Quote Originally Posted by hktvenattu View Post
    you have to do:
    gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"
    and then
    setsid unity

    Worked perfectly for me too

  3. #13
    Join Date
    Feb 2010
    Beans
    7

    Re: Cryptkeeper No Longer Launches After Upgrading to 11.10

    It worked for me when I did it, but everytime I restart ubuntu, I have to do it again... anyone know a more permanent fix, or a cryptkeeper alternative that works with Unity 2D?

  4. #14
    Join Date
    Mar 2012
    Beans
    1

    Re: Cryptkeeper No Longer Launches After Upgrading to 11.10

    Every time I enter the setsid unity command i get the following error

    Checking if settings need to be migrated ...no
    Checking if internal files need to be migrated ...no
    Backend : gconf
    Integration : true
    Profile : unity
    Adding plugins
    Skipping upgrade com.canonical.unity.unity.01.upgrade
    Skipping upgrade com.canonical.unity.unity.02.upgrade
    Initializing core options...done
    Initializing bailer options...done
    Initializing detection options...done
    compiz (core) - Fatal: No composite extension
    compiz (composite) - Error: initScreen failed
    compiz (core) - Error: Couldn't activate plugin 'composite'
    compiz (core) - Error: Plugin 'composite' not loaded.

    compiz (core) - Error: InitPlugin 'opengl' failed
    compiz (core) - Error: Couldn't activate plugin 'opengl'
    compiz (core) - Error: Plugin 'composite' not loaded.

    compiz (core) - Fatal: No composite extension
    compiz (core) - Fatal: No composite extension
    Segmentation fault


    Any help on this?
    I really need cryptkeeper to run...cant access a lot of my files at the moment

  5. #15
    Join Date
    Mar 2012
    Beans
    1

    Re: Cryptkeeper No Longer Launches After Upgrading to 11.10

    I've tried what you guys have written above, but it still doesn't show up for me in the System Tray :/

    Would really like to get it to work with 11.10!

    Any further ideas??

    After I've entered the "setsid unity" command this is the message I get in terminal;

    Code:
    denis@ubuntu:~$ setsid unity
    denis@ubuntu:~$ Checking if settings need to be migrated ...no
    Checking if internal files need to be migrated ...no
    Backend     : gconf
    Integration : true
    Profile     : unity
    Adding plugins
    Skipping upgrade com.canonical.unity.unity.01.upgrade
    Skipping upgrade com.canonical.unity.unity.02.upgrade
    Initializing core options...done
    Initializing bailer options...done
    Initializing detection options...done
    Initializing composite options...done
    Compiz (opengl) - Fatal: GLX_EXT_texture_from_pixmap is missing
    Compiz (opengl) - Fatal: Software rendering detected
    Compiz (bailer) - Info: Ensuring a shell for your session
    
    (metacity:8985): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
    denis@ubuntu:~$ Window manager warning: Received a NET_CURRENT_DESKTOP message from a broken (outdated) client who sent a 0 timestamp
    Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x4e00006 (Displays)
    Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
    Window manager warning: Received a NET_CURRENT_DESKTOP message from a broken (outdated) client who sent a 0 timestamp
    Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x3c00044 ([SOLVED] C)
    Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
    Window manager warning: Received a NET_CURRENT_DESKTOP message from a broken (outdated) client who sent a 0 timestamp
    Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x42004ef (denis@ubun)
    Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
    Last edited by kalabalik; March 16th, 2012 at 07:09 PM.

  6. #16
    Join Date
    Sep 2011
    Beans
    2

    Re: Cryptkeeper No Longer Launches After Upgrading to 11.10

    Hi

    I just learned, that there will be no whitelist anymore in 13.04

    http://www.omgubuntu.co.uk/2013/02/r...tray-whitelist
    https://bugs.launchpad.net/ayatana-design/+bug/974480

    Is there a tool similar to cryptkeeper, that will still work in 13.04?

    I'd prefer a program that is in the official repositories, because this is privacy relevant and I don't want to a PPA for this.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •