Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Language indicator flags on 11.10

  1. #11
    Join Date
    Oct 2009
    Location
    Saarbruecken, Germany
    Beans
    12
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Language indicator flags on 11.10

    Does someone know how to fix language indicator in Ubuntu 11.10 if I use GNOME Classic (gnome 2.32)?

    It shows only poor keyboard icon without any label of current language. I tried some ways to fix it, but unsuccessfully (add some icons into folder ./icon/flags, /desktop/gnome/peripherals/keyboard/indicator does not exist at all when running gconf-editor, .../indicator/showFlags = true does not work either).

    Thanks in advance!

  2. #12
    Join Date
    Jan 2009
    Beans
    199

    Re: Language indicator flags on 11.10

    Hi Koffeehaus,
    I've followed your advice and set the variable to true.
    However when I've restarted Ubuntu, I now have an icon with a red "crossed circle",
    rather than the keyboard with the name.
    In my home I have the .icon/flags folder and in there I've downloaded the following:
    http://launchpadlibrarian.net/71890024/flags2.tar.gz
    I also run the command:
    gconftool-2 --type bool --set /desktop/gnome/peripherals/keyboard/indicator/showFlags true
    (as it was said in the guide that GrouchyGaijin posted).

    I guess that now Ubuntu is trying to display the icon, but that is in the wrong location. Where should I save the icons to be displayed?

    If it is of any help I'm running Ubuntu 11.10 with Gnome 3 in session fallback mode.

    Thanks a lot in advance for the help guys!
    Cheers, -Luca

  3. #13
    Join Date
    Apr 2009
    Beans
    204

    Re: Language indicator flags on 11.10

    Quote Originally Posted by MblKiTA View Post
    Try to use dconf-editor and change to true the following setting org/gnome/libgnomekbd/indicator/show-flags

    And I'm sure that works well for 11.10.

    Currently, on 12.04, this branch/key does not exist.

    Also, there is no desktop/gnome/peripherals/keybboard/indicator in 12.04.

    I have 4 layouts enabled. I can switch between them just fine. I would like to enable the flags. The flags are currently in /usr/share/pixmaps, which is where they were when I made this work in Lucid, Karmic, Jaunty, Intrepid, Hardy...

    [what exactly was the point of moving away from Windows forcing new interfaces down our throats every couple years for no good reason?]

    Sorry. if anyone can help with this, it would be great.

    Thanks in advance
    http://folding.extremeoverclocking.c...avital&t=45104
    "I fear the day technology will surpass our human interaction. The world will have a generation of idiots."
    ― Albert Einstein

  4. #14
    Join Date
    Oct 2010
    Location
    Sweden
    Beans
    615
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Language indicator flags on 11.10

    Quote Originally Posted by r_avital View Post
    And I'm sure that works well for 11.10.

    Currently, on 12.04, this branch/key does not exist.

    Also, there is no desktop/gnome/peripherals/keybboard/indicator in 12.04.

    I have 4 layouts enabled. I can switch between them just fine. I would like to enable the flags. The flags are currently in /usr/share/pixmaps, which is where they were when I made this work in Lucid, Karmic, Jaunty, Intrepid, Hardy...

    [what exactly was the point of moving away from Windows forcing new interfaces down our throats every couple years for no good reason?]

    Sorry. if anyone can help with this, it would be great.

    Thanks in advance
    Look again. I was able to get the flags to show up using the dconf-editor



    Thank you,
    GG -----------
    GUI we don't need no stinking GUI: A collection of Bash scripts
    Mutt (email), cmus (music),Google Calendar and Google Tasks cli

  5. #15
    Join Date
    Apr 2009
    Beans
    204

    Re: Language indicator flags on 11.10

    Thank you Grouchy, I stand corrected
    http://folding.extremeoverclocking.c...avital&t=45104
    "I fear the day technology will surpass our human interaction. The world will have a generation of idiots."
    ― Albert Einstein

  6. #16
    Join Date
    Oct 2006
    Beans
    20

    Re: Language indicator flags on 11.10

    Since I has this issue also in 12.10 (where the flags folder has changed), I post this askubuntu link where it contains solutions for each version:
    http://askubuntu.com/questions/10223...oard-indicator

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •