Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: "Your GStreamer installation is missing a plug-in"

  1. #11
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: "Your GStreamer installation is missing a plug-in"

    I wouldn't be surprised if there is some packages missing from 11.10.

    11.10 seems to be missing working pulse audio for a lot of unhappy people..

    Run this from terminal to check all gstreamer pulugins:
    gst-inspect


    There is a package needed to automagically find/install missing plugins on demand..
    gnome-codec-install

    This package is likely to be useful:
    ubuntu-restricted-extras

  2. #12
    Join Date
    Jun 2007
    Beans
    13,015

    Re: "Your GStreamer installation is missing a plug-in"

    .m4a decoding support in gstreamer is generally supplied thru the ffmpeg plugin
    Code:
    sudo apt-get install gstreamer0.10-ffmpeg
    (multiverse gstreamer plugins are mainly for encoding supoort

  3. #13
    Join Date
    May 2010
    Beans
    37

    Re: "Your GStreamer installation is missing a plug-in"

    Quote Originally Posted by BicyclerBoy View Post
    There is a package needed to automagically find/install missing plugins on demand..
    gnome-codec-install
    Ha! Automagically, that made my day. But anywho, pulse audio, gnome-codec-install, the restricted extras and the ffmpeg plugins were all already installed.

  4. #14
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: "Your GStreamer installation is missing a plug-in"

    That's a highly technical computer term.

    I made a 11.10 install just to see what all the forum traffic is about..
    I noticed there is another package that finds missing codecs & suggests installation.
    I can't recall the name right now but it came up on a gstreamer search in synaptic package manager.


    There is a gstreamer package error in 11.04 with the mp3-fluedo-partner, so there could be an mistake in 11.10 packages.

  5. #15
    Join Date
    Jul 2009
    Beans
    31

    Re: "Your GStreamer installation is missing a plug-in"

    I'm having this problem as well! I've done all of the codec installs suggested on this thread and still can't get banshee or amarok to play my .m4a files. Anyone have ideas of what's going on here?

  6. #16
    Join Date
    Jul 2009
    Beans
    31

    Re: "Your GStreamer installation is missing a plug-in"

    Solved! After searching around a bit more, I found a solution on this thread. The solution is:

    I had the same problem. Here's what I did to fix it:
    open ~/.gstreamer-0.10
    remove or rename the registry.x86_64.bin
    Open your music player.
    it'll regenerate the registry file and correctly use the aac plugin.

  7. #17
    Join Date
    May 2010
    Beans
    37

    Re: "Your GStreamer installation is missing a plug-in"

    I wish I had read that sooner. I've already downgraded to 10.04 and upgraded back up to 11.10 making sure that everything worked before every upgrade. All that proved to be extremely tedious and now, unnecessary. =\

  8. #18
    Join Date
    Apr 2010
    Beans
    8

    Re: "Your GStreamer installation is missing a plug-in"

    this has not worked for me with exaile

  9. #19
    Join Date
    Sep 2005
    Beans
    4

    Re: "Your GStreamer installation is missing a plug-in"

    Quote Originally Posted by OakRaider4Life View Post
    Solved! After searching around a bit more, I found a solution on this thread. The solution is:

    I had the same problem. Here's what I did to fix it:
    open ~/.gstreamer-0.10
    remove or rename the registry.x86_64.bin
    Open your music player.
    it'll regenerate the registry file and correctly use the aac plugin.
    Thanks! This worked perfectly for me with exaile.

  10. #20
    Join Date
    Jan 2013
    Beans
    6

    Re: "Your GStreamer installation is missing a plug-in"

    Quote Originally Posted by OakRaider4Life View Post
    Solved! After searching around a bit more, I found a solution on this thread. The solution is:

    I had the same problem. Here's what I did to fix it:
    open ~/.gstreamer-0.10
    remove or rename the registry.x86_64.bin
    Open your music player.
    it'll regenerate the registry file and correctly use the aac plugin.
    For me, the file was named registry.i686.bin
    Meh, this still worked. Thanks.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •