Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Ubuntu 11.10 Open File with other "Custom" Application

  1. #1
    Join Date
    Jul 2011
    Beans
    2

    Ubuntu 11.10 Open File with other "Custom" Application

    OK, so whoever decided to remove the feature to use any application to open a file was a bonehead.

    I have a text file called ocean.ocn that I want to open with nedit.....this was easily changed until now. I can't seem to find an easy way to do this, any suggestions?

    I feel like I need to vent my frustration with ubuntu 11.10, making what used to be an easy task complicated. I have already had to spend several hours to get my computer back to where it was. If it wasn't for evolution supporting exchange sever 2010 I never would use this version. Am I the only one that thinks Maverick was awesome and simply improving the applications inside it was all that was needed?

    Thanks,
    Aaron
    Last edited by cookacounty; October 17th, 2011 at 03:31 PM. Reason: typo

  2. #2
    Join Date
    Jun 2007
    Beans
    13,070

    Re: Ubuntu 11.10 Open File with other "Custom" Application

    fairly easy - nedit's .desktop is missing something to allow it to be shown in the r. click context menu

    Code:
    gksudo gedit /usr/share/applications/nedit.desktop
    find the Exec= line & add a %f to end, leave a space between nedit & %f - ignore the untitled document 1 that also opens - close it without saving, do save the nedit.desktop
    Code:
    [Desktop Entry]
    Version=1.0
    Name=NEdit
    Exec=nedit %f
    Icon=Nedit
    Terminal=false
    Type=Application
    Categories=Motif;Utility;TextTools;
    GenericName=Text editor
    GenericName[en]=Text editor
    GenericName[nl]=Tekst verwerker
    Then you'll find it by right clicking on your file > open with > other applications
    After that it will be shown directly in the r. click menu

    If you wish to set nedit as default for all text files then use the right click > Properties > open with instead
    Attached Images Attached Images

  3. #3
    Join Date
    Nov 2008
    Location
    Padova, Italy
    Beans
    103
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 11.10 Open File with other "Custom" Application

    I have the same problem (on ubuntu 11.10 with XFCE) I appended %f to the exec line in the .desktop related file and that does not work. (not even after rebooting).
    And in the "open with another application" window beside the "Show other applications" button there is only a "find applications online" option (and not a button for manual search among the applications installed in the system (as there was in older versions of ubuntu).
    What can I do?

    Thanks!

  4. #4
    Join Date
    Oct 2007
    Beans
    10

    Re: Ubuntu 11.10 Open File with other "Custom" Application

    [QUOTE=mc4man;11357219]fairly easy - nedit's .desktop is missing something to allow it to be shown in the r. click context menu

    Code:
    gksudo gedit /usr/share/applications/nedit.desktop
    find the Exec= line & add a %f to end, leave a space between nedit & %f - ignore the untitled document 1 that also opens - close it without saving, do save the nedit.desktop...

    Well, I ran into the same problem, but with DOSBOX.
    I have an old special CAD software that runs on DOS, and until 11.10 I have just ticked DOSBOX in the "open with" dialog.
    I installed DOSBox and I can open the DOS window without problem, so the program works. But it doesn´t show up in the Openwith-list or Other programs-list.
    I opened the dosbox settings in usr/share/applications the way you suggest, but then the dosbox file is... totally empty! No line to add the %f to.
    So, please, is there anyone who can help me put DOSBOX in the "open with" or/and "other programs" list?

  5. #5
    Join Date
    Oct 2007
    Beans
    10

    Re: Ubuntu 11.10 Open File with other "Custom" Application

    Sorry, I was too quick...
    I didn´t write dosbox.desktop...
    When I did the code was there, I added the %f and saved the file.
    And now IT WORKS!!!
    THANKS A LOT!

    But I still consider this a bug. If I install a program, I probably want to use it... And if I like it, I probably want it to automatically open the corresponding files i click on. So... why are Gimp, E.book reader, K3b and a lot of other programs automatically added to the list, but not DOSBox?
    It was installed in exactly the same manner (using the Ubuntu sofware center). It is an annoying inconsistency that was not there before 11.10. Hope the Ubuntu team fixes this.
    However... Thanks again for your help!

  6. #6
    Join Date
    Jan 2011
    Beans
    3
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Angry Re: Ubuntu 11.10 Open File with other "Custom" Application

    I agree that this is an annoying change/lack.

    I liked that in the older versions you could choose your application with a command line box that includes browsing to the application.

    THANKS for the directions on editing the /usr/share/applications desktop files. At least this is one way to get them to show up in the list of applications. It worked like magic. Great tip.

    Now I can manually make sure the applications I need, do show up in the list.

    I'd suggest trying to see if there is a dosbox.desktop file in the directory /usr/share/applications. If you see the format of the others you might be able to make a template for dosbox, that is if there isn't something already there.

    1. cd to the directory /usr/share/applications
    2. use 'grep -i dosbox *' this will search for the name dosbox ignoring case.
    3. if it's not there make one from one of the smaller ones.
    4. I used sol.destop and copied it to my own fake app to test.
    5. Don't forget the %f, this shows that the application can be passed a file name, it has to be there to show up in the list.

    sudo cp sol.desktop fake.destop
    gksudo gedit fake.desktop

    fake.desktop
    Code:
    [Desktop Entry]
    Name=Fake Application Test
    Comment=Do some fake stuff
    Exec=/bin/bash %f
    Icon=gnome-aisleriot
    Terminal=true
    Type=Application
    Categories=GNOME;GTK;Game;CardGame;
    X-GNOME-Bugzilla-Bugzilla=GNOME
    X-GNOME-Bugzilla-Product=aisleriot
    X-GNOME-Bugzilla-Component=Zwischenlager
    X-GNOME-Bugzilla-Version=3.2.1
    StartupNotify=true
    X-HildonDesk-ShowInToolbar=true
    X-Osso-Service=org.gnome.Games.AisleRiot
    X-Osso-Type=application/x-executable
    X-Ubuntu-Gettext-Domain=aisleriot
    This worked for me. Fake application with the sol icon showed up in the list of applications.

    I set the Terminal=true here so I'd see some results. /bin/bash needs to be replaced with the real dosbox executable, and Terminal=false would probably be the choice.

    You'll have to find the icon you want.
    Last edited by gtgrover; November 4th, 2011 at 04:34 PM. Reason: More answers

  7. #7
    Join Date
    Nov 2011
    Beans
    1

    Re: Ubuntu 11.10 Open File with other "Custom" Application

    Waw, great job.... Something that was pretty fast to do now takes a lot of time and gets more complicated. That is exactly the way OS's should evolve....

    Sorry, but I am really not able to see the reason behind this kind of changes.... Many times I have the feeling that we are moving backwards. Can it be that some designers/developers are trying to make open source world "explode" from the inside?

    And for those who might defend this partial solutions, I may tell you that for a long time I had a very old computer that could not run hd videos, and the only way I could play my flipcam made videos (from a user friendly interface) was using a custom execution command that would open mplayer with lots of options like frameskipping and more

    I have the feeling of loosing freedom where I think I should have exactly the opposite one.

  8. #8
    Join Date
    Dec 2011
    Beans
    1

    Re: Ubuntu 11.10 Open File with other "Custom" Application

    I'm with you Aaron. Whoever removed the ability to manually enter the "open with" application should be sent to purgatory at Microsoft.

  9. #9
    Join Date
    Feb 2009
    Beans
    78

    Re: Ubuntu 11.10 Open File with other "Custom" Application

    Quote Originally Posted by khdetw View Post
    I'm with you Aaron. Whoever removed the ability to manually enter the "open with" application should be sent to purgatory at Microsoft.
    I just ran into the same issue and thought about checking/creating a bug entry at launchpad for this. I gave up after 30 minutes.

    Maybe i am stupid, but I cant think of any good reason to remove this feature.

  10. #10
    Join Date
    Sep 2008
    Beans
    3

    Re: Ubuntu 11.10 Open File with other "Custom" Application

    This answered my question as well! Thanks a lot. My custom .desktop for Sublime Text wasn't working, it was missing the %f on the Exec= line.

    For others, if you don't have root on the system you're working on: this works just as fine when you put the .desktop file in ~/.local/share/applications/.

    I also find it retarded that this function has been removed from the context-menu. I do, however, find the new 'find app on-line' option quite nice.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •