Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Can't Browse Network

  1. #1
    Join Date
    Sep 2008
    Location
    Denver, CO
    Beans
    239
    Distro
    Ubuntu 14.04 Trusty Tahr

    Can't Browse Network

    I upgraded to 11.10 64-bit on my desktop, but now I can no longer browse my network.

    I installed 11.10 32-bit on my server and shared some folders and can browse the network from it as well as copy files from my Windows 7 laptop to it. I was also able to browse and see the server from my laptop and copy files from it. When I Browse Network from my desktop, I can see the WORKGROUP folder, but can't open it. I get the error, "Unable to mount location Failed to retrieve share list from server". I've rebooted my desktop and tried again without success. I checked the Network, Network Connections, and Network Tools and everything looks ok. I can ping the server as well as the laptop.
    Last edited by HDTimeshifter; October 16th, 2011 at 01:38 PM.

  2. #2
    Join Date
    Dec 2008
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't Browse Network

    Quote Originally Posted by HDTimeshifter View Post
    I upgraded to 11.10 64-bit on my desktop, but now I can no longer browse my network.

    When I Browse Network from my desktop, I can see the WORKGROUP folder, but can't open it. I get the error, "Unable to mount location Failed to retrieve share list from server".

    I installed 11.10 32-bit on my server and shared some folders and can browse the network from it as well as copy files from my Windows 7 laptop to it.

    I was also able to browse and see the server from my laptop and copy files from it.

    ...
    I rearranged your thoughts for clarity. It looks like you just need to modify the /etc/samba/smb.conf as shown below. The one caveat is: When you substitute your machine's hostname for the NETBIOS name it should be less than 15 characters long.

    Add this to the [global] section of the /etc/samba/smb.conf

    Code:
    netbios name = <hostname>
    name resolve order = bcast host
    Then either restart the smbd and nmbd services or reboot the system.

    You should now be able to browse the network shares.

  3. #3
    Join Date
    Mar 2006
    Beans
    10

    Re: Can't Browse Network

    Thank you this has helped solve same issue I was having.

  4. #4
    Join Date
    Sep 2008
    Location
    Denver, CO
    Beans
    239
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't Browse Network

    Quote Originally Posted by capscrew View Post
    I rearranged your thoughts for clarity. It looks like you just need to modify the /etc/samba/smb.conf as shown below. The one caveat is: When you substitute your machine's hostname for the NETBIOS name it should be less than 15 characters long.

    Add this to the [global] section of the /etc/samba/smb.conf

    Code:
    netbios name = <hostname>
    name resolve order = bcast host
    Then either restart the smbd and nmbd services or reboot the system.

    You should now be able to browse the network shares.
    When I searched through smb.conf, I noticed the following:
    Code:
    # This will prevent nmbd to search for NetBIOS names through DNS.
       dns proxy = no
    Did the above cause the problem?

    Your solution worked, however. Thanks.

  5. #5
    Join Date
    Dec 2008
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't Browse Network

    Quote Originally Posted by HDTimeshifter View Post
    When I searched through smb.conf, I noticed the following:
    Code:
    # This will prevent nmbd to search for NetBIOS names through DNS.
       dns proxy = no
    Did the above cause the problem?

    Your solution worked, however. Thanks.
    That parameter only is in effect when the nmbd daemon is also functioning as a WINS server. By default this is not the case, so the setting is irrelevant.

    The following can be found here in the official Samba documentation.
    Code:
    dns proxy (G) 
    
    Specifies that nmbd(8) when acting as a WINS server and finding that a NetBIOS name has 
    not been registered, should treat the NetBIOS name word-for-word as a DNS name and do 
    a lookup with the DNS server for that name on behalf of the name-querying client.
    
    Note that the maximum length for a NetBIOS name is 15 characters, so the 
    DNS name (or DNS alias) can likewise only be 15 characters, maximum.
    Last edited by capscrew; October 17th, 2011 at 12:34 AM.

  6. #6
    Join Date
    Jan 2009
    Location
    Whitesboro, NY USA
    Beans
    9
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Can't Browse Network

    I have the same issue but adding the two lines including netbios=host name (replacing the host name with that of the 64 bit machine) did not solve the issue. The host name is exactly as that of the machine and is less than 15 characters. After restarting samba I select Browse Network, then Windows Network. I get an empty screen. Yet when I go to the 32 bit machines on the network, I do the same and can see and browse all of them. One has Ubuntu Studio 11.04 and the other Ubuntu 11.10 I compared smb.conf files and they are the same except for the host name and share name. I am obsessed, but can't seem to solve this issue. Could it be a bug in the 64 bit version of Ubuntu 11.10?

  7. #7
    Join Date
    Dec 2008
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't Browse Network

    Quote Originally Posted by JerryReed View Post
    I have the same issue but adding the two lines including netbios=host name (replacing the host name with that of the 64 bit machine) did not solve the issue.

    The host name is exactly as that of the machine and is less than 15 characters. After restarting samba I select Browse Network, then Windows Network. I get an empty screen. Yet when I go to the 32 bit machines on the network, I do the same and can see and browse all of them. One has Ubuntu Studio 11.04 and the other Ubuntu 11.10

    I compared smb.conf files and they are the same except for the host name and share name. I am obsessed, but can't seem to solve this issue. Could it be a bug in the 64 bit version of Ubuntu 11.10?
    In a word...no! The problem is somewhere else and we need to find it.

    From the 64 bit host post the output of this
    Code:
    smbtree
    From that same machine also post the output of this
    Code:
    testparm -s
    Last edited by capscrew; October 20th, 2011 at 03:14 AM.

  8. #8
    Join Date
    Oct 2007
    Beans
    122

    Re: Can't Browse Network

    I have the same issue. I tried few things but could not make it work. I will try the suggestions in this thread.
    This is what I tried:
    I have a second laptop with 10.10 (32 bit) which can access the network (and network shares) without any issues. So, I backed up my current samba config file and copied the one from 32 bit machine. It still did not work. I tired to find some logs to get the error messages but could not find any in /var/log or /var/samba.

    I will tweak the config file as suggested here and post results.

    Thanks,

  9. #9
    Join Date
    Oct 2007
    Beans
    122

    Re: Can't Browse Network

    This suggestion did not work for me.
    I run 64bit 11.10. Also "HOME" is the name of the server where my shares are defined.

    OutPut from smbtree:

    smit@ELITEBOOK:~$ smbtree
    Enter smit's password:
    WORKGROUP
    \\HOME HOME server (Samba, Ubuntu)
    cli_start_connection: failed to connect to HOME<20> (0.0.0.0). Error NT_STATUS_UNSUCCESSFUL
    \\ELITEBOOK ELITEBOOK server (Samba, Ubuntu)
    \\ELITEBOOK\IPC$ IPC Service (ELITEBOOK server (Samba, Ubuntu))
    \\ELITEBOOK\print$ Printer Drivers
    smit@ELITEBOOK:~$


    OutPut from testparm-s

    smit@ELITEBOOK:~$ testparm -s
    Load smb config files from /etc/samba/smb.conf
    rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
    Processing section "[printers]"
    Processing section "[print$]"
    Loaded services file OK.
    Server role: ROLE_STANDALONE
    [global]
    server string = %h server (Samba, Ubuntu)
    map to guest = Bad User
    obey pam restrictions = Yes
    pam password change = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    unix password sync = Yes
    syslog = 0
    log file = /var/log/samba/log.%m
    max log size = 1000
    name resolve order = lmhosts host wins bcast
    usershare allow guests = Yes
    panic action = /usr/share/samba/panic-action %d

    [printers]
    comment = All Printers
    path = /var/spool/samba
    create mask = 0700
    printable = Yes
    browseable = No

    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/printers
    smit@ELITEBOOK:~$

  10. #10
    Join Date
    Dec 2008
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't Browse Network

    Quote Originally Posted by BHEJU View Post
    This suggestion did not work for me.
    I run 64bit 11.10. Also "HOME" is the name of the server where my shares are defined.
    I don't see where you have added the following to the [global] section of the smb.conf file
    Code:
    netbios name = HOME
    name resolve order = bcast host
    I do see this though and its NOT what you want.
    Code:
    name resolve order = lmhosts host wins bcast

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •