Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Skype icon has disappeared after updating to 11.10

  1. #11
    Join Date
    Dec 2008
    Beans
    18

    Re: Skype icon has disappeared after updating to 11.10

    Quote Originally Posted by roobinatube View Post
    I have realised the easiest way to avoid the "gnome-panel --replace" issue, is make sure that skype starts after gnome-panel. I was having some issues because sometimes the skype icon would be present, others not. I figure this was because "gnome-panel --replace" was actually happening before skype started!

    So I found the most consistant thing to do is delete the startup entries for skype and "gnome-panel --replace", and add my own shell script.

    Code:
    gedit ~/.skype-start.sh
    Copy/paste this into the file:

    Code:
    #!/bin/bash
    
    sleep 10
    skype
    Then make it executable (or right click > properties >permissions > allow executing):
    Code:
    chmod +x ~/.skype-start.sh
    Then add this as a startup item. 10 seconds should be plenty on most systems to guarantee skype starts after everything else.
    Works perfectly. Thanks so much

  2. #12
    Join Date
    Nov 2006
    Beans
    73

    Re: Skype icon has disappeared after updating to 11.10

    I use 11.04 with classic gnome, but have the same problem, ie the skype icon does not appear in the panel, so I cannot even tell whether I am signed in or not.

    Is there a way to make the green tick icon appear in the top panel? How should I modify the proposed whitelisting command to work on Gnome classic?

    Thanks

  3. #13
    Join Date
    Jun 2008
    Beans
    74

    Re: Skype icon has disappeared after updating to 11.10

    I can see the icon after I turn it on manually.

    Is there a way for it to load at startup?

    I did find it in my startup....
    Last edited by Momof9Blessings; January 11th, 2012 at 01:59 AM.

  4. #14
    Join Date
    Jan 2009
    Beans
    64

    Re: Skype icon has disappeared after updating to 11.10

    these instructions are workign fine.. but i do not know how to "ad it to start up"

    I have made the file as per intsructions... but i can not even run it form the console... like when i do a ls -ls I can see ti and it is green... .



    But how do i add this to my startup items, maybe you cna only run it from there?

  5. #15
    Join Date
    Jun 2012
    Beans
    2

    Re: Jynks

    Try '~/.skype-start.sh' to run the script from the command line. You need to type the full path to the script (or an abbreviation, like ~ which means home directory) unless said script is in a directory in the PATH, or the shell will not be able to find it.

    To add the script to startup, go to 'Gear->Startup Applications', click Add, Browse for the script (or just put '~/.skype-start.sh' as the Command,) give it a Name and optionally a Comment, hit Add, and make sure the new entry is enabled. Note: the Gear is the icon at the top right of your Unity environment, the same one you click before you Shut Down your computer.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •