Results 1 to 8 of 8

Thread: World of Warcraft graphics problem on PlayOnLinux - Oneiric 11.10

  1. #1
    Join Date
    Jul 2010
    Beans
    6

    World of Warcraft graphics problem on PlayOnLinux - Oneiric 11.10

    Hello!
    I have an HP 430 and
    Code:
    lshw -c video
    command line said:

    Code:
    *-display               
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:42 memory:c0000000-c03fffff memory:b0000000-bfffffff ioport:4000(size=64)
    WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
    I'm running this at Ubuntu Oneiric Ocelot 11.10 and PlayOnLinux 4.0.12.

    -[When I'm logging in the graphic
    s are perfect]

    There's an image that could be helper.


  2. #2
    Join Date
    Sep 2011
    Beans
    64

    Re: World of Warcraft graphics problem on PlayOnLinux - Oneiric 11.10

    I havent had that problem myself but mines been the Framerates :/ Think It might be a Wine update or something. I really don't have any answer. Sorry mate. Just hope both our problems get sorted. I feel really dirty having to log into Windows

  3. #3
    Join Date
    May 2010
    Location
    Where God goes to rest:AL
    Beans
    575
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: World of Warcraft graphics problem on PlayOnLinux - Oneiric 11.10

    Having an Intel chip is...'problematic' at least.

    Either it won't work at all, or you can try this post.

    Sorry, but Intel + wine + Opengl = Bad Juju.

    Good luck.
    http://ubuntuforums.org/showthread.php?t=1799781
    Running wine/WoW on a AMD Athlon 64 X2 5200+(2.6GHz)w/4GB DDRII(667) and a NV9600GSO w/768MB DDRIII.

  4. #4
    Join Date
    Jul 2010
    Beans
    6

    Re: World of Warcraft graphics problem on PlayOnLinux - Oneiric 11.10

    I've solved this!

    First. Install mesa-utils if no installed:
    Code:
    sudo apt-get install mesa-utils
    to test fot OpenGL support.

    Second. Run a check to see if you have OpenGL support:
    Code:
    glxinfo|grep 'direct rendering'
    or
    Code:
    /usr/lib/unix/unity_support_test -p
    .

    Third. Run
    Code:
    glxgears
    to see how your video card renders and its FPS for the render.

    If it appears you have OpenGL support and all is good then add to the WoW launcher the -opengl parameter. For example
    Code:
    '.wine/drive_c/Program Files/World of Warcraft/Wow.exe' -openGL
    Good luck!

    IMPORTANT: If you get pixelated trees, you have to restart and Log In with Ubuntu-2d session.

    After doing all these instructions my problem is solved !

    Greetings.
    Last edited by Davh; October 15th, 2011 at 08:38 PM.

  5. #5
    Join Date
    May 2010
    Location
    Where God goes to rest:AL
    Beans
    575
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: World of Warcraft graphics problem on PlayOnLinux - Oneiric 11.10

    ALWAYS go with:
    • 2D (if using Unity), or No Effects (For Gnome)
    • Use the -opengl switch

    No matter WHAT videocard/chip you use.
    Running wine/WoW on a AMD Athlon 64 X2 5200+(2.6GHz)w/4GB DDRII(667) and a NV9600GSO w/768MB DDRIII.

  6. #6
    Join Date
    Sep 2011
    Beans
    64

    Re: World of Warcraft graphics problem on PlayOnLinux - Oneiric 11.10

    Quote Originally Posted by Davh View Post
    I've solved this!

    First. Install mesa-utils if no installed:
    Code:
    sudo apt-get install mesa-utils
    to test fot OpenGL support.

    Second. Run a check to see if you have OpenGL support:
    Code:
    glxinfo|grep 'direct rendering'
    or
    Code:
    /usr/lib/unix/unity_support_test -p
    .

    Third. Run
    Code:
    glxgears
    to see how your video card renders and its FPS for the render.

    If it appears you have OpenGL support and all is good then add to the WoW launcher the -opengl parameter. For example
    Code:
    '.wine/drive_c/Program Files/World of Warcraft/Wow.exe' -openGL
    Good luck!

    IMPORTANT: If you get pixelated trees, you have to restart and Log In with Ubuntu-2d session.

    After doing all these instructions my problem is solved !

    Greetings.
    My problem Is the openGL never saves into config.ini thus causing the Framerate Issue, everything I have tried however has broken the game so to speak. I'm on the 4th time downloading. Near on 100G downloaded so far

  7. #7
    Join Date
    May 2010
    Location
    Where God goes to rest:AL
    Beans
    575
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: World of Warcraft graphics problem on PlayOnLinux - Oneiric 11.10

    Quote Originally Posted by Langney View Post
    My problem Is the openGL never saves into config.ini thus causing the Framerate Issue, everything I have tried however has broken the game so to speak. I'm on the 4th time downloading. Near on 100G downloaded so far
    It is NOT 'openGL', it is '-opengl'

    Ex:
    Code:
    env WINEPREFIX="/home/<USER>/.wine" wine "C:\Program Files\World of Warcraft\Wow.exe" -opengl
    NOTE: <USER> is your username. This is assuming you installed WoW in the default wine location. The '-opengl' tag will run WoW in this mode, and WoW will insert the correct 'set gxAPI' option in World of Warcraft/WTF/Config.wtf (NOT config.ini). Also, I run 'Wow.exe' and not 'Launcher.exe' at this time, due to issues with Launcher.exe exiting and really launching WoW.

    And there is NO need to delete the entire WoW install. I, for example, have the actual WoW install folder elsewhere, and just have a link to the actual folder in ~/.wine/drive_c/Program Files.

    Ex:
    Code:
    /home/<USER>/.wine/drive_c/Program Files/<LINK TO REAL WOW FOLDER>
    That way, I can delete the .wine folder, and STILL have the HUGE WoW install intact. Then, I can just run 'winecfg', and make a new link to the WoW folder.
    Running wine/WoW on a AMD Athlon 64 X2 5200+(2.6GHz)w/4GB DDRII(667) and a NV9600GSO w/768MB DDRIII.

  8. #8
    Join Date
    Jun 2011
    Beans
    164
    Distro
    Kubuntu

    Re: World of Warcraft graphics problem on PlayOnLinux - Oneiric 11.10

    Edit the following file:
    {wow directory}/wtf/config.wtf

    add the line:
    SET gxApi "opengl"

    to the very top with gedit. save, exit, play game. I also play wow especially on Linux

    Game on my friend!

    https://help.ubuntu.com/community/WorldofWarcraft

    also google before posting.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •