Page 4 of 4 FirstFirst ... 234
Results 31 to 40 of 40

Thread: Unity Laggy Ubuntu 11.10

  1. #31
    Join Date
    Oct 2011
    Location
    hawaii
    Beans
    96
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Unity Laggy Ubuntu 11.10

    if you wanna run compiz in unity for 11.10 here it is:
    http://ubuntuforums.org/showthread.php?t=1864603

  2. #32
    Join Date
    Nov 2010
    Location
    Foshan, China
    Beans
    437
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unity Laggy Ubuntu 11.10

    Quote Originally Posted by Samos123 View Post
    @typhon_tip anybody care to give some more instructions for a noob ? would help me a lot. Like where is the compiz config? and what commands to run?

    Thanks a lot, i am using unity2d for now, which works and fast and responsive but would like to switch. I am using ati radeon 4200 HD for laptop.
    Sorry I arrived late

    I think bmw-uf above already replied for the compiz part. For the rest, I try to explain better what to do:

    - Install fglrx driver (stock driver is choppy...); to do this, just open "Additional Drivers" application and select "ATI/AMD proprietary FGLRX driver" (do not use post-updates/release), then click "activate" and wait for it to finish. EDIT: if it doesn't appear in the list, your hardware may not be supported.
    - Open "AMD Catalyst" (after reboot !)
    - Enable "tear free" desktop option (one will find it easily)
    - Open compiz config (command: ccsm)
    - OpenGL plugin, untick Sync to VBlank, Texture = BEST, Lighting effect ON (be careful here, to open the settings, click on the buttons and NOT on the tick/untick for the element, or entire desktop will disappear).
    - Composite plugin, Detect refresh rate unticked, set the refresh rate at double your video frequency (in my case 60 Hz, I set it to 120)
    - Close compiz
    - Log ogg
    - Log in again, it should be now smooth as silk and tear free


  3. #33
    Join Date
    Dec 2007
    Location
    Americana - Brazil
    Beans
    9
    Distro
    Ubuntu 10.04 Lucid Lynx

    Talking Re: Unity Laggy Ubuntu 11.10

    Quote Originally Posted by typhoon_tip View Post
    Try this simple fix, worked for me (I have the compiz idle effect too, but it's not related to the choppy I think... at least not that much !).

    - Install fglrx driver (stock driver is choppy...)
    - Open AMD Catalyst (after reboot !)
    - Enable "tear free" desktop option
    - Open compiz config
    - OpenGL plugin, untick Sync to VBlank, Texture = BEST, Lighting effect ON
    - Composite plugin, Detect refresh rate unticked, set the refresh rate at double your video frequency (in my case 60 Hz, I set it to 120)
    - Close compiz
    - Log ogg
    - Log in again, it should be now smooth as silk and tear free

    Please give me a feedback on this procedure, as it worked for me since 11.04 till 11.10, seems quite consolidated.

    Be careful not to touch anything else in those OpenGL and Composite plugins !
    This works perfectly! Thank you very much! These news should be spread!!

  4. #34
    Join Date
    Nov 2010
    Location
    Foshan, China
    Beans
    437
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unity Laggy Ubuntu 11.10

    Quote Originally Posted by hopugop View Post
    This works perfectly! Thank you very much! These news should be spread!!
    I saw some guy posted already something in an Ubuntu page, looks like we came to the exact same conclusion, but he posted much earlier (I think in April 2010), anyway the page is still there. I never look for it because I had the problem back since 10.04 and there was no guideline back then, so I just figured it out by trying dozens of settings.

  5. #35
    Join Date
    Mar 2010
    Beans
    7

    Re: Unity Laggy Ubuntu 11.10

    Quote Originally Posted by typhoon_tip View Post
    Sorry I arrived late

    I think bmw-uf above already replied for the compiz part. For the rest, I try to explain better what to do:

    - Install fglrx driver (stock driver is choppy...); to do this, just open "Additional Drivers" application and select "ATI/AMD proprietary FGLRX driver" (do not use post-updates/release), then click "activate" and wait for it to finish. EDIT: if it doesn't appear in the list, your hardware may not be supported.
    - Open "AMD Catalyst" (after reboot !)
    - Enable "tear free" desktop option (one will find it easily)
    - Open compiz config (command: ccsm)
    - OpenGL plugin, untick Sync to VBlank, Texture = BEST, Lighting effect ON (be careful here, to open the settings, click on the buttons and NOT on the tick/untick for the element, or entire desktop will disappear).
    - Composite plugin, Detect refresh rate unticked, set the refresh rate at double your video frequency (in my case 60 Hz, I set it to 120)
    - Close compiz
    - Log ogg
    - Log in again, it should be now smooth as silk and tear free

    thx buddy, feels much smoother, but only for while. When I drag the window faster this lag came again..

    I experience this problem on my Dell Inspiron M102z as in http://www.ubuntu.com/certification/...47:201101-6961 (mine powered by E450) ; Toshiba L645D-S4033 ; even my desktop (HD4650).

  6. #36
    Join Date
    Nov 2010
    Location
    Foshan, China
    Beans
    437
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unity Laggy Ubuntu 11.10

    Quote Originally Posted by novatax View Post
    thx buddy, feels much smoother, but only for while. When I drag the window faster this lag came again..

    I experience this problem on my Dell Inspiron M102z as in http://www.ubuntu.com/certification/...47:201101-6961 (mine powered by E450) ; Toshiba L645D-S4033 ; even my desktop (HD4650).
    Happens to me as well, laptops all have this "problem", because they use scaling technology of CPU and GPU (Intel). Normally at start, all laptops are in Automatic OnDemand mode. Setting to performance will bring drastic difference to GPU as well as CPU, but will drain the battery faster.

    We are lucky however, as we can set the mode ourselves. Try to do the following thing (attention, for Unity !):
    Code:
    sudo apt-add-repository ppa:artfwo/ppa
    sudo apt-get update
    sudo apt-get install indicator-cpufreq
    After finishing, if a new icon do not appear in top bar, logoff and login again. Click on the icon and set the mode to "Performance", you will notice a huge difference in graphic 2D acceleration performances overall.

  7. #37
    Join Date
    Nov 2008
    Beans
    30
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Unity Laggy Ubuntu 11.10

    @typhoon_tip

    WOW! That is a huge difference indeed. I want to thank you really much.

    I hope my battery wont drain, but it's not laggy anymore (using Intel HD).

    Still Compiz & Xorg has huge CPU speaks while moving a window, so that is still NOT solved, but this indicator is a start...

  8. #38
    Join Date
    Mar 2009
    Beans
    2

    Talking Re: Unity Laggy Ubuntu 11.10

    This resolved laggy Ubuntu desktop. Not a perfect solution, more of a tweak.. Thanks

    #NVidia

    ...Add latest drivers PPA, and upgrade:

    sudo apt-add-repository ppa:ubuntu-x-swat/x-updates

    sudo apt-get update && sudo apt-get install nvidia-current nvidia-settings

    (I tried Additional Drivers: "post-release updates" didn't work for me)

    #COMPIZ

    ...Added following Compiz PPA and upgrade:

    sudo apt-add-repository ppa:vanvugt/compiz

    sudo apt-get update && sudo apt-get upgrade

    ...Or add via a source manager:

    deb http://ppa.launchpad.net/vanvugt/compiz/ubuntu oneiric main

    deb-src http://ppa.launchpad.net/vanvugt/compiz/ubuntu oneiric main

    ...then update and upgrade compiz

    (the source is found here: https://launchpad.net/~vanvugt/+archive/compiz)

    #Install Compiz-Setting-Manager:

    (this is found in the Ubuntu software centre)

    #COMPIZ SETTINGS: Open and navigate to:

    ...Composite setting:

    DETECT REFRESH RATE: (UNTICK)

    REFRESH RATE: (DOUBLE YOUR REFRESH RATE)

    ...Mouse Position Polling setting:

    MOUSE POLL POSITION: (1).

    ...Snapping Windows:

    SNAPPING WINDOWS: (UNTICK)

    ...Move Window:

    OPACITY: 30

    LAZY POSITIONING: (UNTICK)

    ...OpenGL

    SYNC TO VBLANK: (UNTICK)

    TEXTURE: (BEST)

    LIGHTING EFFECT: (ON)


    #Configuring The Right Driver

    The next thing to do is to make sure that your machine uses the correct driver. To ensure that, we are going to blacklist the nouveau driver first. Open a terminal and enter the following to do so:

    sudo nano /etc/modprobe.d/blacklist.conf

    ...At the end of the document, add this line:

    [...]

    blacklist nouveau

    ...Afterwards update your initial ram file system by entering this into a terminal:

    sudo update-initramfs -u -v

    ...Then check:

    sudo nano /etc/X11/xorg.conf

    ...Find the Device section and make sure the driver is set to "nvidia". It should look somewhat like this:

    [...]

    Section "Device"

    Driver "nvidia"

    Identifier "Default Device"

    Option "NoLogo" "True"
    EndSection

    [...]

  9. #39
    Join Date
    Mar 2013
    Beans
    3

    Re: Unity Laggy Ubuntu 11.10

    One of the main reasons unity is laggy is because it uses Compiz. The problem with that is, Compiz hasn't been in development for months or maybe even years. Which is why GNOME 3 disabled the ability to swap window managers. Also why KDE created it's own similar compiz effects. Also why XFCE and LXDE don't recommend compiz. And of course why cinnamon and pantheon forbid switching window managers. Since 12.10 removed unity 2d you are stuck with compiz... And installing an AMD or NVidia driver in 12.10 WILL Break the system, because the package linux-kernel-headers was removed which is completely dumb! Considering that steam is out (And steam expects proprietary drivers to work the best.) People who have AMD and NVidia drivers will be F%CKED UP! They'll wanna play steam games so they'll install the proprietary driver and then reboot and well BOOM! Nothing if they're an AMD or NVidia user. Just a wallpaper and only able to use ctr-alt-T to open the terminal remove the fglrx package reboot install linux-kernel-headers and on and on. I mean Canonical just cannot do this to us AMD or NVidia users. Another reason I seriously want to switch to Gentoo.

  10. #40
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Unity Laggy Ubuntu 11.10

    This thread is about Ubuntu 11.10.

    Back to sleep, old thread.

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •