Page 1 of 5 123 ... LastLast
Results 1 to 10 of 48

Thread: problem with asus N55SF

  1. #1
    Join Date
    Oct 2011
    Beans
    1

    problem with asus N55SF

    hi
    i have been using Ubuntu more than 2 years now

    recently i just bought asus N55SF and want to use Ubuntu.
    so i downloaded ubuntu 11.10desktop 64 bit then create start up usb disk. when ubuntu boot and showed me the option how to install ubuntu i chooses "try Ubuntu without installing "and"install ubuntu" but i keep getting this screen .(aa.jpg)
    i tried to install it with cd but ended up with same screen .
    tried 11.04 32 bit also the same screen .
    finally i install ubuntu with 11.10 desktop 64 bit Alternate.
    the installation finished with no problem.
    but when i reboot to start ubuntu another error showed up .(bb.jpg)

    note: windows 7 comes with notebook and i installed ubuntu in D patition .

    thanks
    Attached Images Attached Images
    Last edited by 7m7m; October 14th, 2011 at 09:29 PM.

  2. #2
    Join Date
    Oct 2011
    Beans
    1

    Re: problem with asus N55SF

    Hi,

    Had problems with installing ubuntu on a N55s too, from a usb stick with 11.04. After creating a new boot usb with 11.10 it is able to move past being unable to read disk? cache and/or modprobe errors, but I'm unable to boot Ubuntu afterwards unless chosing recovery mode. I guess it's "asus" though? not much to be done. If I try a normal boot the screen just go black as if it isn't able to support it.

  3. #3
    Join Date
    Oct 2011
    Beans
    1

    Re: problem with asus N55SF

    Hi everyone !

    I had the same problem but I have a solution !

    When you boot on the liveCD/USB and when you see the menu where you have to choose between Live mode or install; try F6 and choose acpi=off ! This should solve your problem

  4. #4
    Join Date
    Apr 2010
    Beans
    2

    Re: problem with asus N55SF

    Recovery Mode works on your laptops due to "nomodeset" option.

    You can edit your GRUB and add "nomodeset" option to your kernel. [HOWTO]

    But this is not the only problem I had. Maybe there are some incompatibilities too with touchpad+wifi.

  5. #5
    Join Date
    Nov 2011
    Beans
    1

    Re: problem with asus N55SF

    I'm running the 64bit version of 11.10 on an n55sf. This is how I got it working...

    1. After installation, reboot and press 'e' at the grub2 menu.
    2. Edit the grub entry prompt for Ubuntu, appending "acpi=off" to the kernel commandline.
    3. When I do this the Touchpad isn't detected so I needed to use a USB mouse here.
    4. Update the system.
    5. Add 'blacklist nouveau' to /etc/modprobe.d/blacklist.conf
    6. Reboot (you'll no longer need to set acpi=off)

    This should disable the Nvidia graphics card and load the integrated Intel graphics chip. You can then explore options such as Bumblebee or Ironhide if you need to get the Nvidia card working.

    Thanks to the Arch Wiki page for the n55sf for help with this (I've got Arch working fine on it too).

  6. #6
    Join Date
    Aug 2011
    Beans
    10

    Re: problem with asus N55SF

    i made a mix of what tachylyte suggest:
    I installed 32-bit Version and during install-boot i set acpi=off

    So after that I was able to install and run it after. Because I set acpi=off during install I don't need to edit grub, it starts. I updated and added
    'blacklist nouveau' to /etc/modprobe.d/blacklist.conf.
    Now I want to disable acpi=off. I found this entry in /etc/default/grub:
    GRUB_CMDLINE_LINUX="acpi=off"
    and commented it out. I reinstalled grub2. Now I cannot reboot in normal mode again. I have to add at least nomodeset to the bootoptions, if I don't want to get black bootscreen. What can I do, to make it work?

  7. #7
    Join Date
    Nov 2011
    Beans
    4

    Re: problem with asus N55SF

    Same issue here.
    I've tried tachylyte's solution but it didn't work, I still have to keep acpi disabled on boot otherwise the system won't load.
    The only thing that worked for me was installing Ubuntu (64bit) with acpi=off from USB, then disabling acpi in the grub config file.
    I've also blacklisted nouveau as you suggested, don't know if it's needed or not.
    Neither setting nouveau.modeset=0 as this post suggested http://ubuntuforums.org/showpost.php...&postcount=242 worked, it became even worse... that setting caused many graphical glitches instead of the harmless yet disappointing blank screen and forced me to turn off my laptop manually.

    I'm quite inexperienced in Ubuntu and I would like to fix this issue since I really need it. Does anybody know why is this happening? Is it the graphics card, Ubuntu or the laptop? Does this affect other distros or is it an Ubuntu-only problem? I'm writing to Asus to see if they can help with this, N5SF is a quite new laptop and this is very unpleasant, I'm not likely to use it like this, especially if I can't use the touch-pad, any graphic application or if my laptop is getting much warmer than it should do.

    EDIT: Installing Ironhide made those glitches happen even with acpi=off, now I can only boot with nomodeset, I hope that uninstalling it will be enough.
    I've also noticed that with nomodeset I'm not forced to set acpi=off so my touchpad works as long as the keys for volume, brightness...
    Last edited by Nephilim91; November 23rd, 2011 at 05:28 PM. Reason: Ironhide doesn't work

  8. #8
    Join Date
    Nov 2011
    Beans
    28

    Re: problem with asus N55SF

    Ubuntu 12.04
    Just install bumblebee and everything should be fine.
    The only issue I'm aware of is the subwoofer not working. This should fix it partially (more info here):
    Code:
    echo 'options snd-hda-intel model=asus-mode4' | sudo tee -a /etc/modprobe.d/alsa-base.conf
    Install the 'GNOME Alsa Mixer' and regulate the volume of the subwoofer with the 'Bass Spe' lever.

    Ubuntu 11.10

    Quick guide:

    • Boot the Ubuntu LIVE-CD with acpi=off option (F6)
    • Partially fix the subwoofer problem:
      Code:
      echo 'options snd-hda-intel model=asus-mode4' | sudo tee -a /etc/modprobe.d/alsa-base.conf
    • Blacklist nouveau driver:
      Code:
      echo 'blacklist nouveau' | sudo tee -a /etc/modprobe.d/blacklist.conf
    • Add video drivers repository and update the system:
      Code:
      sudo add-apt-repository ppa:ubuntu-x-swat/x-updates && sudo apt-get update && sudo apt-get upgrade
    • Install bumblebee:
      Code:
       sudo add-apt-repository ppa:bumblebee/stable && sudo apt-get update && sudo apt-get install bumblebee && sudo usermod -a -G bumblebee $USER
    • Restart and done! (Nvidida drivers will appear as not activated, it's OK)

    Have a look bellow for a workaround to the Fn + F9 issue (on/off touchpad), power saving and suspend problems.

    Full story:
    Hi, everyone. I have the AsusN55SF working perfectly fine with Ubuntu 11.04 and (now) with 11.10. For 11.10 is a little trickier so I'll try to give a detailed explanation. I just formatted and tried this in a new partition to make sure it still works (22/01/2012). The problem is with the video drivers. This laptop has the Intel integrated graphics and a dedicated NVIDIA GT555M. In order to make the latter to work in linux, we will need Bumblebee.

    Follow this steps:
    1 - Install Ubuntu 11.10 as explained above (Press “Esc” when the Asus logo appears to enter boot menu, choose the pendrive or CD/DVD accordingly, then “F6”, choose lenguage, “F6” again and choose nomodeset or acpi=off. With nomodeset the touchpad works, but the resolution of the screen is quite ugly. With acpi=off you need a mouse, but the video looks good.

    2- For the first boot and as explained above, boot with no modeset or acpi=off (on the grub menu, press "e" on the ubuntu line and manually add nomodeset or acpi=off to the linux line, then “Ctrl + x” to boot).

    3- As explained above, blacklist nouveau (from terminal, Ctrl + Alt + t):
    Code:
    sudo gedit /etc/modprobe.d/blacklist.conf
    (remember to paste in a terminal to press Shift + fn + insert/delete)
    And manually add the line "blacklist nouveau".

    4- To have the latest video drivers, add the next repository:
    Code:
    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
    Code:
    sudo apt-get update
    sudo apt-get upgrade
    It will install all updates, so be patient...
    For some reason, there are NO drivers in “Additional Drivers”, yet.

    5- Install bumblebee and add yourself to the bumblebee group :
    Code:
    sudo add-apt-repository ppa:bumblebee/stable
    sudo apt-get update
    sudo apt-get install bumblebee
    sudo usermod -a -G bumblebee $USER
    After a restart, everything will work fine. Any application that has to be run with the dedicated graphics card must be run with 'optirun application'. For example, 'optirun firefox'.Try 'glxspheres' and 'optirun glxspheres' to test the difference between using the integrated card alone or also the GeForce GT 555M. At full screen I'm getting almost the double (~35 frames/sec vs 70). Tip: create custom launchers with the optirun command so you wont have to do it manually again (guide).

    From version 3 of bumblebee, the power managment is working out of the box, so the graphic card is turned off when optirun is not running (saving battery, less heat, etc.). To verify this, use this:
    Code:
    lspci -vnnn | perl -lne 'print if /^\d+\:.+(\[\S+\:\S+\])/' | grep nVidia
    When ON, the output ends with:
    nVidia Corporation Device [10de:1247] (rev a1) (prog-if 00 [VGA controller])
    When OFF, it finishes with:
    nVidia Corporation Device [10de:1247] (rev ff) (prog-if ff)

    Fn + F9 workaround:
    There is a bug and Fn + F9 combination doesn't work (Toggle touchpad). As a workaround (based on this thread), go to System settings / Keyboard / Shortcuts. On the left panel select Custom shortcuts and add a new one with the command: /etc/acpi/asus-touchpad.sh
    Then set a key combination for that command (e.g. Shift + F9, tried Fn + F9 but it doesn't work). That's all, works perfect.

    Power saving (RC6):
    Enabling the RC6 power management will save 40 - 60% of power (RC6).
    To add "i915.i915_enable_rc6=1" to the default kernel options, open this file:
    Code:
    gksu gedit /etc/default/grub
    and add that option to the line "GRUB_CMDLINE_LINUX_DEFAULT". In my case:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.i915_enable_rc6=1"

    Suspend/Hibernate:
    Follow steps 1, 2 (the new) and 3 from this tutorial (thanks to laoneo for bringing it).

    Subwoofer:
    This should fix it partially as the rear right channel only will be in the subwoofer. Add options snd-hda-intel model=asus-mode4 to the file (as root) /etc/modprobe.d/alsa-base.conf and reboot.

    Hope it helps, I was also really frustrated not being able to make it work properly with Ubuntu...
    Last edited by @gu79; May 21st, 2012 at 08:23 AM. Reason: Update Ubuntu 12.04 and subwoofer fix.

  9. #9
    Join Date
    Nov 2011
    Beans
    28

    Re: problem with asus N55SF

    I have also used this in order to turn it off (extends battery life) and I haven't had any issues. Nevertheless, I don't know how to test if it is really off, besides leaving it on battery so see how long it lasts (which I didn't try...). Used the calls for the N55S from here.

  10. #10
    Join Date
    Nov 2011
    Beans
    4

    Re: problem with asus N55SF

    Thank you so much @gu79, it worked well for me
    Everything works fine now (except the touchpad disable fn, no big deal, I guess that's an unrelated problem).
    It took me two days long but I'm quite happy now

Page 1 of 5 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •