Page 1 of 8 123 ... LastLast
Results 1 to 10 of 77

Thread: hp Pavilion g6 with Atheros (AR9485) [168c:0032] doesn't connect in 11.04

  1. #1
    Join Date
    Jul 2011
    Beans
    37

    Angry hp Pavilion g6 with Atheros (AR9485) [168c:0032] doesn't connect in 11.04

    UPDATE: The solution to the problem is in #63
    I recently bought a new computer (hp Pavilion g6) and haven't been able to connect it to my wifi. I've been a user for 2 years and have already installed in a few laptops (with the typical wireless problems - thank you forum gurus), but still I consider myself a noob.

    At first I tried to install 10.04, but that didn't work. Now I installed 11.04, but still cannot fond a solution to my problem.

    I ran this first
    Code:
    lspci -nnk | grep -iA2 net
    The results were:
    Code:
    01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 05)
    	Subsystem: Hewlett-Packard Company Device [103c:1693]
    	Kernel driver in use: r8169
    --
    02:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)
    	Subsystem: Hewlett-Packard Company Device [103c:1785]
    	Kernel modules: ath9k
    Then
    Code:
     rfkill list all
    resulting in:
    Code:
    1: hp-wifi: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    2: hp-bluetooth: Bluetooth
    	Soft blocked: no
    	Hard blocked: no
    4: hci0: Bluetooth
    	Soft blocked: no
    	Hard blocked: no
    But when I tried
    Code:
    iwconfig
    wlan0 was a no-show
    Code:
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    The occured with
    Code:
    ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 78:e3:b5:5a:cd:d7  
              inet addr:192.168.0.102  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::7ae3:b5ff:fe5a:cdd7/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:63833 errors:0 dropped:0 overruns:0 frame:0
              TX packets:43550 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:91705458 (91.7 MB)  TX bytes:3619756 (3.6 MB)
              Interrupt:40 Base address:0xe000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:284 errors:0 dropped:0 overruns:0 frame:0
              TX packets:284 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:23336 (23.3 KB)  TX bytes:23336 (23.3 KB)
    I searched for linux drivers and couldn't find them... but I also tried to use Windows Wireless drivers, I found the driver and applied the .inf but the wireless stayed dead. I rebooted a couple of times and tried to turn on and off the wireless button.

    Thank you in advance.
    Last edited by nelsongo.com; October 15th, 2011 at 03:38 PM. Reason: the solution was found in #63.

  2. #2
    Join Date
    Jul 2011
    Beans
    37

    Re: hp Pavilion g6 with Atheros (AR9485) [168c:0032] doesn't connect in 11.04

    I need help with this... I tried several things since friday... I've been working on this hard, I just don't have the tools to solve it.
    At least tell me you don't know what to do and might just return the computer and buy one that works with Ubuntu.

  3. #3
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,690
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: hp Pavilion g6 with Atheros (AR9485) [168c:0032] doesn't connect in 11.04

    Hi, please post the results of these commands here:
    Code:
    cat /etc/lsb-release; uname -a
    Code:
    lsmod | grep ath
    Code:
    ndiswrapper -l
    Thank you

  4. #4
    Join Date
    Jul 2011
    Beans
    37

    Re: hp Pavilion g6 with Atheros (AR9485) [168c:0032] doesn't connect in 11.04

    Thank you wildmanne39.


    Code:
    nrgomez@nelson-HP-Pavilion-g6-U:~$ cat /etc/lsb-release; uname -a
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=11.04
    DISTRIB_CODENAME=natty
    DISTRIB_DESCRIPTION="Ubuntu 11.04"
    Linux nelson-HP-Pavilion-g6-U 2.6.38-11-generic #50-Ubuntu SMP Mon Sep 12 21:17:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
    The second one came empty
    Code:
    nrgomez@nelson-HP-Pavilion-g6-U:~$ lsmod | grep ath
    Code:
    nrgomez@nelson-HP-Pavilion-g6-U:~$ ndiswrapper -l
    netathrx : driver installed
    	device (168C:0032) present (alternate driver: ath9k)

  5. #5
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,690
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: hp Pavilion g6 with Atheros (AR9485) [168c:0032] doesn't connect in 11.04

    Hi, run these command please:
    Code:
    sudo modprobe -rf ndiswrapper
    sudo apt-get remove --purge ndiswrapper-common ndiswrapper-utils-1.9 ndisgtk
    sudo rm /etc/modprobe.d/ndiswrapper.conf
    sudo rm -r /etc/ndiswrapper/* 
    sudo depmod -a
    One line at a time, then unplug your wired connection.

    Then
    Code:
    sudo modprobe ath9k
    give it a few seconds to see if it comes on if not then post the outcome of:
    Code:
    lsmod
    Thank you

  6. #6
    Join Date
    Jul 2011
    Beans
    37

    Re: hp Pavilion g6 with Atheros (AR9485) [168c:0032] doesn't connect in 11.04

    I'm stuck here
    Code:
    sudo modprobe -rf ndiswrapper
    it "freezes" and doesn't allow me to do anything els

  7. #7
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,690
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: hp Pavilion g6 with Atheros (AR9485) [168c:0032] doesn't connect in 11.04

    Hi, your whole computer locks up? you can restart your computer then try the commands again.
    Thank you

  8. #8
    Join Date
    Jul 2011
    Beans
    37

    Re: hp Pavilion g6 with Atheros (AR9485) [168c:0032] doesn't connect in 11.04

    No, only terminal locks up... but I will make a full restart just in case.

  9. #9
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,690
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: hp Pavilion g6 with Atheros (AR9485) [168c:0032] doesn't connect in 11.04

    Hi, it is probably waiting for you to enter your password, just type your user password, it will not show on the screen so after you are finished typing it hit enter.
    Thank you

  10. #10
    Join Date
    Jul 2011
    Beans
    37

    Re: hp Pavilion g6 with Atheros (AR9485) [168c:0032] doesn't connect in 11.04

    Yes, I wrote my pw but after five minutes nothing happens (but if i write my pw incorrectly it asks for it again)
    Code:
    nrgomez@nelson-HP-Pavilion-g6-U:~$ sudo modprobe -rf ndiswrapper
    [sudo] password for nrgomez:

Page 1 of 8 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •