Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Unity 3D does not work after upgrade

  1. #1
    Join Date
    Feb 2006
    Beans
    216

    Question Unity 3D does not work after upgrade

    I upgraded from 11.04 to 11.10, and when I log in using unity 3D I just get a desktop background with icons. No dashboard or anything else.

    If I create a new user I can log in to unity 3D.

    I guess this means that there is a problem with upgrading from 11.04 to 11.10 with respect to unity configuration files...

    I don't know where this bug should be reported?

    Does anyone know what to try? I don't want to delete my upgraded user...

  2. #2
    Join Date
    Mar 2007
    Location
    Caprica
    Beans
    1,995
    Distro
    Ubuntu Development Release

    Re: Unity 3D does not work after upgrade

    Switch too a VT (Ctrl+Alt+F1 to F6) and run
    unity --reset
    sudo service lightdm stop
    sudo service lightdm start

    If that is not enough, after loggins in swutch again to a VT and run
    DISPLAY=:0.0 /usr/bin/ccsm
    Switch back with Ctrl+Alt+F7 and activate the Unity Plugin in ccsm.

    Regards,
    Effenberg

  3. #3
    Join Date
    Feb 2006
    Beans
    216

    Question Re: Unity 3D does not work after upgrade

    Thanks for the advice!

    It did not work, but I got some interesting results, I think.

    When running the "unity --reset" command in a virtual console the unity segfaults!

    Before it hits the segmentation fault it says:

    Code:
    compiz (unity) - Warn: unsupported internal format
    This is what is printed to stderr:

    Code:
    Backend     : gconf
    Integration : true
    Profile     : unity
    Adding plugins
    Skipping upgrade com.canonical.unity.unity.01.upgrade
    Skipping upgrade com.canonical.unity.unity.02.upgrade
    Initializing core options...done
    Initializing bailer options...done
    Initializing detection options...done
    Initializing composite options...done
    Initializing opengl options...done
    Initializing decor options...done
    Initializing mousepoll options...done
    Initializing vpswitch options...done
    Initializing animation options...done
    Initializing snap options...done
    compiz (expo) - Warn: failed to bind image to texture
    Initializing expo options...done
    Initializing move options...done
    Initializing place options...done
    Initializing grid options...done
    Initializing gnomecompat options...done
    Initializing wall options...done
    Initializing ezoom options...done
    Initializing workarounds options...done
    Initializing resize options...done
    Initializing fade options...done
    Initializing unitymtgrabhandles options...done
    Initializing scale options...done
    Initializing session options...done
    unity-panel-service: ingen process hittades
    Initializing unityshell options...done
    Initializing addhelper options...done
    Initializing animationaddon options...done
    Initializing annotate options...done
    Initializing bench options...done
    Initializing blur options...done
    Initializing clone options...done
    Initializing colorfilter options...done
    Initializing commands options...done
    Initializing crashhandler options...done
    Initializing cube options...done
    Initializing cubeaddon options...done
    Initializing debugspew options...done
    Initializing extrawm options...done
    Initializing fadedesktop options...done
    Initializing firepaint options...done
    Initializing group options...done
    Initializing imgjpeg options...done
    Initializing kdecompat options...done
    Initializing loginout options...done
    Initializing mag options...done
    Initializing maximumize options...done
    Initializing mblur options...done
    Initializing neg options...done
    Initializing notification options...done
    Initializing obs options...done
    Initializing opacify options...done
    Initializing put options...done
    Initializing reflex options...done
    Initializing resizeinfo options...done
    Initializing ring options...done
    Initializing rotate options...done
    Initializing scaleaddon options...done
    Initializing scalefilter options...done
    Initializing screenshot options...done
    Initializing shelf options...done
    Initializing shift options...done
    Initializing showdesktop options...done
    Initializing showmouse options...done
    Initializing splash options...done
    Initializing staticswitcher options...done
    Initializing switcher options...done
    Initializing td options...done
    Initializing thumbnail options...done
    Initializing trailfocus options...done
    Initializing wallpaper options...done
    Initializing water options...done
    Initializing widget options...done
    Initializing winrules options...done
    Initializing wobbly options...done
    Initializing zoom options...done
    compiz (unity) - Warn: unsupported internal format
    Segmentation fault (core dumped)

  4. #4
    Join Date
    Mar 2007
    Location
    Caprica
    Beans
    1,995
    Distro
    Ubuntu Development Release

    Re: Unity 3D does not work after upgrade

    You can reinstall unity and compiz, which will probably fix everything anyway.

    At a VT (Ctrl+Alt+F1 to F6):
    Code:
    sudo service lightdm stop 
    sudo service gdm stop 
    sudo killall -s KILL /usr/bin/X 
    sudo apt-get remove --purge gdm gdm-guest-session 
    sudo apt-get update 
    sudo apt-get install --reinstall unity unity-2d-spread unity-lens-files unity-scope-musicstores unity-2d unity-asset-pool unity-lens-gwibber unity-services unity-2d-launcher unity-common unity-lens-music unity-2d-panel unity-greeter unity-place-applications unity-2d-places unity-lens-applications unity-place-files compiz compiz-dev compiz-kde compiz-plugins-main-default compizconfig-backend-gconf compiz-fusion-bcop compiz-plugins compiz-plugins-main-dev compizconfig-backend-kconfig compiz-fusion-plugins-extra compiz-plugins-default compizconfig-settings-manager compiz-fusion-plugins-main compiz-plugins-extra compiz-core compiz-gnome compiz-plugins-main lightdm lightdm-gtk-greeter lightdm-qt-greeter 
    sudo mv ~/.Xauthority ~/.Xauthority.backup
    sudo apt-get upgrade
    sudo service lightdm start
    Then if you still get nothing at the desktop, try the commands I suggested before.

    Regards,
    Effenberg
    Last edited by effenberg0x0; October 7th, 2011 at 06:22 PM.

  5. #5
    Join Date
    Feb 2006
    Beans
    216

    Re: Unity 3D does not work after upgrade

    I ran all the commands you suggested, but still the same result.

    So I tried to run the commands from comment #2.

    I got the compiz config settings manager on my desktop, and I activated the unity plugin (which was not activated).

    Even so, the problem persists...

    A strange thing is that if I run "unity --reset" from Unity 2D I get both Unity 2D and Unity 3D at the same time.

    I wonder what it is that makes unity (or compiz) segfault?
    I'm afraid that many more people will get similar segfaults when 11.10 is out.
    I have not fiddled with unity in 11.04 so the config settings should not be exotic enough to produce segfaults...

    Is there some way that I can remove all the compiz-related settings? And get the default ones for unity?

  6. #6
    Join Date
    Mar 2007
    Location
    Caprica
    Beans
    1,995
    Distro
    Ubuntu Development Release

    Re: Unity 3D does not work after upgrade

    Code:
    DISPLAY=:0.0 /usr/bin/ccsm
    Switch back with Ctrl+Alt+F7 and activate the Unity Plugin in ccsm.
    Great, so you can Login to Unity 3D and you could open ccsm using the command I posted above. Now, when you setup ccsm, you gotta make sure that the following plugins are activated: Unity Plugin, Composite, OpenGL. ccsm may crash while you're starting / stopping plugins. It is really unstable. In this case, switch back to the VT and launch it again with the DISPLAY command above.

    Once you have ccsm options set, switch to the VT once more and run
    Code:
    sudo service lightdm stop
    sudo service lightdm start
    You *should* have fixed your desktop but the truth is that you might have to start/stop lightdm a couple times before you can see the Unity bar and panel. Or at least that's what I am seeing in a couple test PCs here.

    Now, if your Ubuntu 2D session is running OK and the 3D one simply won't run, I have to wonder if your current setup allows you to run an accelerated desktop (OpenGL). You can test it like this:

    Login to Ubuntu 3D session
    Switch to any VT and run:

    HTML Code:
    /usr/lib/nux/unity_support_test -p
    If you get a yes to everything, your PC supports it. Otherwise, let us know in which item you get a NO.

    Also, in this same VT, run

    Code:
    DISPLAY=:0.0 /usr/bin/glxgears
    Do you see any error in the VT? If you switch to the Ubuntu 3D desktop (Ctrl+Alt+F7), do you see GlxGears running?

    Regards,
    Effenberg
    Last edited by effenberg0x0; October 7th, 2011 at 07:01 PM.

  7. #7
    Join Date
    Mar 2007
    Location
    Caprica
    Beans
    1,995
    Distro
    Ubuntu Development Release

    Re: Unity 3D does not work after upgrade

    Quote Originally Posted by koma77 View Post
    Is there some way that I can remove all the compiz-related settings? And get the default ones for unity?
    Yes, using unity --reset, which I believe you already ran a couple times. Also, the long command I posted to you a few posts above reinstalled compiz packages to defaults. Which is why I am wondering if your PC setup (specially the video driver) supports OpenGL.

    Regards,
    Effenberg

    EDIT: Looking at Unity source code, the error message you mentioned (unsupported format) refers to lack of GLX support. If you Video Card does support OpenGL, we must investigate why it is not working to its specs. A driver reinstall would be a good idea.
    Code:
    switch (status)
    GL_FRAMEBUFFER_UNSUPPORTED:
    compLogMessage ("unity", CompLogLevelWarn, "unsupported internal format");
    EDIT 2: An idea: Run ccsm and click on the Composite plugin. Uncheck the "Unredirect Fullscreen Windows" checkbox. Exit, restart your session. This option may conflict with your Card+Driver capabilities.
    Last edited by effenberg0x0; October 7th, 2011 at 07:13 PM.

  8. #8
    Join Date
    Feb 2006
    Beans
    216

    Re: Unity 3D does not work after upgrade

    Code:
    DISPLAY=:0.0 /usr/bin/ccsm
    Switch back with Ctrl+Alt+F7 and activate the Unity Plugin in ccsm.
    Great, so you can Login to Unity 3D and you could open ccsm using the command I posted above. Now, when you setup ccsm, you gotta make sure that the following plugins are activated: Unity Plugin, Composite, OpenGL. ccsm may crash while you're starting / stopping plugins. It is really unstable. In this case, switch back to the VT and launch it again with the DISPLAY command above.
    I can verify that the three plugins are activated in ccsm.

    Once you have ccsm options set, switch to the VT once more and run
    Code:
    sudo service lightdm stop
    sudo service lightdm start
    You *should* have fixed your desktop but the truth is that you might have to start/stop lightdm a couple times before you can see the Unity bar and panel. Or at least that's what I am seeing in a couple test PCs here.
    Still no luck...

    Now, if your Ubuntu 2D session is running OK and the 3D one simply won't run, I have to wonder if your current setup allows you to run an accelerated desktop (OpenGL). You can test it like this:

    Login to Ubuntu 3D session
    Switch to any VT and run:

    HTML Code:
    /usr/lib/nux/unity_support_test -p
    If you get a yes to everything, your PC supports it. Otherwise, let us know in which item you get a NO.
    Everything says yes. (I have a quite common nVidia card that is not too old.)

    Also, in this same VT, run

    Code:
    DISPLAY=:0.0 /usr/bin/glxgears
    Do you see any error in the VT? If you switch to the Ubuntu 3D desktop (Ctrl+Alt+F7), do you see GlxGears running?

    Regards,
    Effenberg

    I get spinning gears on the desktop and no error messages in the console.
    Frame rate is several thousands FPS.


    You also mentioned that the configuration files should be reset when "unity --reset" is run.

    The problem is that "unity --reset" itself segfaults, probably before it has resetted anything... That way I'm stuck with bad config files that prevent this whole thing from working.

    Also, importantly: If I create a new user and log in to a "Unity 3D" desktop everything works.


    So, to me it seems that there is a bug in the way unity (or something) parses setting files/registry stuff (or something).

    And I ran that apt-get remove + apt-get purge thing as well, but still no luck.

    Is there a simple way to get a core file from the segfault and take a look at what it says?

  9. #9
    Join Date
    Feb 2006
    Beans
    216

    Re: Unity 3D does not work after upgrade

    Quote Originally Posted by effenberg0x0 View Post
    EDIT: Looking at Unity source code, the error message you mentioned (unsupported format) refers to lack of GLX support. If you Video Card does support OpenGL, we must investigate why it is not working to its specs. A driver reinstall would be a good idea.
    Code:
    switch (status)
    GL_FRAMEBUFFER_UNSUPPORTED:
    compLogMessage ("unity", CompLogLevelWarn, "unsupported internal format");
    EDIT 2: An idea: Run ccsm and click on the Composite plugin. Uncheck the "Unredirect Fullscreen Windows" checkbox. Exit, restart your session. This option may conflict with your Card+Driver capabilities.

    I have reinstalled the driver a couple of times (using the "Hardware Driver" dialog).

    In ccsm/composite the "Unredirect Fullscreen Windows" was already unchecked. I checked it, but it did not help. So I unchecked it again.

    Since the 3D unity seems to work flawlessly for a newly created user I don't think that my hardware is to blame.

  10. #10
    Join Date
    Mar 2007
    Location
    Caprica
    Beans
    1,995
    Distro
    Ubuntu Development Release

    Re: Unity 3D does not work after upgrade

    I see... New test:

    sudo service lightdm stop
    sudo gconftool-2 --recursive-unset /apps/compiz
    sudo gconftool-2 --recursive-unset /apps/compiz-1
    sudo gconftool-2 --recursive-unset /apps/compizconfig-1
    sudo unity --reset
    sudo service lightdm start

    Regards,
    Effenberg

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •