Results 1 to 2 of 2

Thread: Festival/aplayer unable to open slave

  1. #1
    Join Date
    Jun 2011
    Beans
    57

    Festival/aplayer unable to open slave

    I am running 10.04 server within VirtualBox. My sound card is a USB dongle.

    **** List of PLAYBACK Hardware Devices ****
    card 0: I82801AAICH [Intel 82801AA-ICH], device 0: Intel ICH [Intel 82801AA-ICH]
    Subdevices: 0/1
    Subdevice #0: subdevice #0

    I have configured mpd and music playback is fine. /etc/mpd.conf:-
    audio_output {
    type "alsa"
    name "My ALSA Device"
    device "hw:0,0" # optional
    format "44100:16:2" # optional
    mixer_device "default" # optional
    mixer_control "PCM" # optional
    mixer_index "0" # optional
    }

    I think that this is correct for mixing. I can hear keyboard event sounds mixed with mpd playback.
    When I try and read text with Festival 1.9.6 though I get:

    ALSA lib pcm_dmix.c:1010snd_pcm_dmix_open) unable to open slave
    aplay: main:608: audio open error: Device or resource busy

    Have I correctly selected dmix? How should I configure the two packages to work together?
    Last edited by Bradburts; October 4th, 2011 at 08:44 AM.

  2. #2
    Join Date
    Jun 2011
    Beans
    57

    Re: Festival/aplayer unable to open slave

    misread instructions.
    My configuration was attempting hardware mixing, fairly obvious when the device was "hw:0,0".
    The setting should be "software".
    Strange that I still got keyboard events mixing, perhaps I do have a two channel hardware mixer as well.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •