Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Gnome 3 - User theme extension not enabled

  1. #1
    Join Date
    Apr 2006
    Beans
    4

    Gnome 3 - User theme extension not enabled

    Today I did a clean install for ubuntu 11.04. Having seen the power of Gnome 3 (with Fedora) I installed it right away. Some minor problem arose and I had to deinstall accessibility themes and install the "standard" gnome themes.

    However there is one more problem and I've added a screen shot to show the problem. As you can see, the gnome desktop seems pretty cool but however the tweak tool doesn't show properly (empathy and other apps neither).



    Besides the fact that the themes don't properly show in this screen I also get the error "User Theme extension not enabled" now I get the feeling these problems are related, but how do I fix it?

    If anyone can give any idea's I'd be very grateful, I've searched everywhere but as far as I know I seem to be the only one with this problem. I would love to take the full advantage of a Gnome 3 desktop but this is getting to be a big "bump" in the road.
    Attached Images Attached Images

  2. #2
    Join Date
    Apr 2011
    Beans
    20

    Re: Gnome 3 - User theme extension not enabled

    I have the same problem!

  3. #3
    Join Date
    Apr 2006
    Beans
    4

    Re: Gnome 3 - User theme extension not enabled

    Great to know I'm not alone^^

    There's also a few things I have done to try and fix it btw:

    - Manually installed the "Adwaita" theme in ~/.themes
    - Search the repos for anything "theme" related to enable shell theme
    - Searched the entire gconf-editor for something enabling the option

    So far no luck.

  4. #4
    Join Date
    Mar 2006
    Location
    Kiruna, Sweden
    Beans
    73
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Gnome 3 - User theme extension not enabled

    I am not sure that is related. Theming is not entirely supported right now. If i remember correct it was the same in Fedora. However.. if you look in "interfaces" instead you can change the metacity and icon-theme.

    For Mutter there is another solution. Just go and get Theme Selector.
    Motherboard: Asus P5W DH Deluxe | Graphic card: Ati Radeon 1950 pro | Wifi: RTL8187

  5. #5
    Join Date
    Apr 2006
    Beans
    4

    Re: Gnome 3 - User theme extension not enabled

    Ok, something weird seems to have fixed it. I was playing around with the GTK+ themes and I selected one of the other option (myst for instance) and trying to change it again also revealed the "Adwaita" theme, I selected it and everything was working properly.

    I do not know whether the fact that I had earlier also installed "Adwaita"by hand or not but here is a link to download it:

    http://ubuntuforums.org/showpost.php...3&postcount=86

    Maybe Drew93 can confirm this working cause in that case it just seems like glitch. Could anyone confirm to us know whether going through the themes might glitch and reveal the right theme (with and without manually installing)?

    Besides that, thanks for your reply revoltism, but I wasn't really looking to change the mutter theme I just wanted the default GTK+/Metacity theme to work

  6. #6
    Join Date
    Apr 2011
    Beans
    20

    Re: Gnome 3 - User theme extension not enabled

    Sorry i'm italian and i don't understand some things xd how can i get the gnome shell extension?? i have an other question...ubuntu doesn't install the gnome-shell-extension-common beacuse i haven't the bar at the right of the desk...maybe for me it's all collegated?

  7. #7
    Join Date
    Jun 2011
    Beans
    3

    Re: Gnome 3 - User theme extension not enabled

    @Mr.Anarchy, the Adwaita download in there worked like a charm. i had to put it in /usr/share/themes though, not in .themes.

    thanks!

  8. #8
    Join Date
    Jun 2010
    Location
    Rockport, TX
    Beans
    2,301
    Distro
    Ubuntu Development Release

    Ricotz ppa

    Temporarily add a ppa, ricotz/testing, update then use synaptic to add the extensions, I think he has all the one's gnome.org git has packaged as .debs.

    Then deactivate the ppa. You may have need for it later but you don't want to use it on a regular basis, at least not for now.

  9. #9
    Join Date
    Sep 2008
    Location
    delhi, India
    Beans
    5
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Gnome 3 - User theme extension not enabled

    Thanks, adding ricotz/testing works. I have user themes enabled now.

  10. #10
    Join Date
    Jan 2008
    Beans
    6

    Re: Gnome 3 - User theme extension not enabled

    Thanks cbowman57!

    So to be more specific with the commands, here's what I did to enable user theme extension:

    Code:
    $ sudo add-apt-repository ppa:ricotz/testing
    $ sudo apt-get update
    $ sudo apt-get install gnome-shell-extensions-user-theme
    
    (if you don't already have ppa-purge installed)
    $ sudo apt-get install ppa-purge
    
    $ sudo ppa-purge ppa:ricotz/testing
    You should now have user extensions enabled (you can verify in the gnome-tweak-tool).

    I expect adding PPAs will be unnecessary in the future.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •