Results 1 to 8 of 8

Thread: Media Players Stop When Entering Power Saving Mode

  1. #1
    Join Date
    Apr 2006
    Beans
    92
    Distro
    Kubuntu 9.10 Karmic Koala

    Media Players Stop When Entering Power Saving Mode

    Hi there,

    Lately I started using KDE 4. I discovered that when my computer enters power saving mode (meaning turning off the display), all my media players actually stop - that includes Amarok, Clementine etc.

    It's important to say that I'm a desktop user, not a laptop. In my Power Management settings (in the KDE System Settings), only the "Screen Energy Saving" option is selected.

    My guess is that Phonon interprets the power saving mode as "shut up" command - and it's quite annoying.

    Anybody has a clue?
    Thanks in advance!

  2. #2
    Join Date
    Apr 2009
    Location
    Serbia
    Beans
    137
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Media Players Stop When Entering Power Saving Mode

    I had a similar problem in Kubuntu Natty while I used opensource ati drivers. I asked for help in many linux forums but I found no help. Then I installed catalyst driver and I am not having problems anymore.

  3. #3
    Join Date
    Jan 2007
    Beans
    13

    Re: Media Players Stop When Entering Power Saving Mode

    Being an ATI Radeon x1950 user I have no Catalyst support and therefore still face the problem. Any solution for people with older ati/amd hardware?

  4. #4
    Join Date
    Apr 2009
    Location
    Serbia
    Beans
    137
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Media Players Stop When Entering Power Saving Mode

    Quote Originally Posted by rat_poison View Post
    Being an ATI Radeon x1950 user I have no Catalyst support and therefore still face the problem. Any solution for people with older ati/amd hardware?
    When I don't use catalyst my workaround is to set "dim display" and "screen energy saving" to 360min.
    Last edited by schnelle; November 2nd, 2011 at 09:15 PM.

  5. #5
    Join Date
    Apr 2009
    Location
    Serbia
    Beans
    137
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Media Players Stop When Entering Power Saving Mode

    Another workaround is to use xfce4-power-manager instead of default powerdevil. With xfce4-power-manager players don't stop playing while monitor is off (but then suspend to ram doesn't work).

    I am going to file bug report to bugs.kde.org about this.

  6. #6
    Join Date
    Apr 2009
    Location
    Serbia
    Beans
    137
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Media Players Stop When Entering Power Saving Mode


  7. #7
    Join Date
    Apr 2009
    Location
    Serbia
    Beans
    137
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Media Players Stop When Entering Power Saving Mode

    This is bug in opensource radeon driver and it is fixed now:
    https://bugs.freedesktop.org/show_bug.cgi?id=49761

    If you are using Kubuntu 12.04 you can install newest (fixed) drivers from oibaf ppa:

    Code:
    sudo apt-add-repository ppa:oibaf/graphics-drivers
    sudo apt-get update
    sudo apt-get dist-upgrade
    and then reboot your system.

  8. #8
    Join Date
    Dec 2010
    Location
    Fukuoka, Japan
    Beans
    1,062
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Media Players Stop When Entering Power Saving Mode

    Run "xset -q" in a terminal to see if DPMS is enabled. In a lot of Kubuntu installs, DPMS turns on whenever it wants, so if its on do "xset -dpms"

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •