Page 8 of 12 FirstFirst ... 678910 ... LastLast
Results 71 to 80 of 119

Thread: Unity panel always displayed on top of fullscreen windows

  1. #71
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    429
    Distro
    Ubuntu

    Re: Solution!

    Quote Originally Posted by Rave2Rave View Post
    as already mentioned:

    this bug (i was also affected) comes up due to a wrong compiz-config, or better, a compiz-config, that doesn't really work correctly with unity/gnome at the moment.

    my solution:

    disable the "put windows" plugin (german: "fenster platzieren")
    just to be on the safe side, i disabled every plugin, i don't really need and
    which literally cries out for bringing up that bug, like
    desktop wall and cube.

    ...so happy i could solve that annoying bug!...for me^^
    I've never used the "put windows" plugin, but I still have this bug.

    Compiz misconfiguration may indeed be a possiblity, as solutions such as "enable/disable plugin x" or "disable and then reenable plugin y" and vice-versa seem to work on a case-by-case basis.

    I haven't had any more luck with a clean install than reconfiguring a used one however...

    --edit--

    just to be on the safe side, i disabled every plugin, i don't really need and which literally cries out for bringing up that bug, like desktop wall and cube.
    Wait, are you saying you diabled both wall and cube as well? No wonder you don't have the bug!
    Last edited by quequotion; June 18th, 2012 at 03:48 PM. Reason: wait... what?

  2. #72
    Join Date
    Aug 2010
    Location
    Olivet, France
    Beans
    60
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unity panel always displayed on top of fullscreen windows

    Try this :
    sudo add-apt-repository ppa:lavie-alexis/compiz-precise+placepluginfixed
    sudo apt-get update
    sudo apt-get upgrade

    Disconnect from your session and reconnect to see the changes, it worked for me under gnome classic.

  3. #73
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    429
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    Quote Originally Posted by Alexislavie View Post
    Try this :
    sudo add-apt-repository ppa:lavie-alexis/compiz-precise+placepluginfixed
    sudo apt-get update
    sudo apt-get upgrade

    Disconnect from your session and reconnect to see the changes, it worked for me under gnome classic.
    No effect for Unity/Cube

  4. #74
    Join Date
    May 2009
    Location
    Alabama
    Beans
    25
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Unity panel always displayed on top of fullscreen windows

    I seemed to have found the solution...at least it is working for me for over a week with no occurrence of the top panel being on top anymore.

    What I did was installed "compiz-plugins-extra" package from the software centre and that seemed to have solved it completely.

    https://apps.ubuntu.com/cat/applicat...plugins-extra/

    Give it a try and let me know if this fixed it or not.
    Twitter | Facebook | Myspace
    Visuex.com - my web-development company

  5. #75
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    429
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    Quote Originally Posted by RottNKorpse View Post
    Give it a try and let me know if this fixed it or not.
    I've almost always had plugins-extra installed, but haven't noticed any difference with or without it.

  6. #76
    Join Date
    Jul 2011
    Beans
    211

    Re: Unity panel always displayed on top of fullscreen windows

    Quote Originally Posted by RottNKorpse View Post
    I seemed to have found the solution...at least it is working for me for over a week with no occurrence of the top panel being on top anymore.

    What I did was installed "compiz-plugins-extra" package from the software centre and that seemed to have solved it completely.

    https://apps.ubuntu.com/cat/applicat...plugins-extra/

    Give it a try and let me know if this fixed it or not.
    I tried this, but it didn't work for me.

  7. #77
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    429
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    It's a rendering bug in Unity.

    Following the bug report, it would seem this is pretty much taken care of in bzr.

    This merge log shows the work that's been done this month.

    Now we wait for testing and for packages to get rolled out.

    I'm going to try compiling unity and nux from bzr for now.

    **edit**
    There are also daily builds available in the bleeding-edge Unity Staging PPA.
    Unfortunately the merge has not yet been approved, so the changes haven't made it in yet.

    If it works, I will be delighted to mark this thread solved.

    Crossing fingers!
    Last edited by quequotion; June 30th, 2012 at 05:35 PM. Reason: hmm...

  8. #78
    Join Date
    Mar 2012
    Location
    /home/ubun2to
    Beans
    356
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Unity panel always displayed on top of fullscreen windows

    Simple solution.
    1. Install MyUnity.
    2. Open MyUnity.
    3. Change behavior from "Fixed" to "Hidden."
    I figured it out myself.
    Anyway, in 11.10, the default action was to hide, and in 12.04, the default action is to stay on top (which is what I like, personally).
    You can also sorta hide the date/time bar at the top by doing this:
    1. Open MyUnity.
    2. Go to the Panel tab.
    3. Set Transparency to 100%.
    4. Make sure "Transparency maximized toggle" is turned off.
    I also figured that out myself.
    Last edited by Ubun2to; June 30th, 2012 at 07:05 PM.
    Backups are amazing. 99% of data loss can be prevented by spending less than $100 on an external drive.
    If you have seen an error, there is a good chance someone else has, too. Google is your friend.

  9. #79
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    429
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    Quote Originally Posted by Ubun2to View Post
    Simple solution.
    1. Install MyUnity.
    2. Open MyUnity.
    3. Change behavior from "Fixed" to "Hidden."
    I figured it out myself.
    This will hide the unity launcher.
    This can also be achieved with ccsm.


    This thread is about what you call the "date time bar".
    You can also sorta hide the date/time bar at the top by doing this:
    1. Open MyUnity.
    2. Go to the Panel tab.
    3. Set Transparency to 100%.
    4. Make sure "Transparency maximized toggle" is turned off.
    I also figured that out myself.
    Unfortunately this is all that can be done about the unity panel for the moment.
    This can also be done in ccsm.

    We've already discussed most of your ideas earlier in this thread (posts #7 and #21), though not in the context of a solution.
    Unfortunately, the issue has been plagued with communication problems, misunderstandings, and misconceptions.

    Luckily, the problem has been identified and a fix is already in the bzr.
    Last edited by quequotion; July 8th, 2012 at 07:06 PM.

  10. #80
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    429
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    Good news / Bad news

    There is a fix released... for quantal (12.10)

    Not yet for precise.

    I don't recommend installing the quantal packages in precise; it didn't go well for me.

    I ran into a new bug, which is apparently not happening in quantal, wherein all of unity blinks on and off constantly.

    Work continues, and precise will get a backported release eventually.

Page 8 of 12 FirstFirst ... 678910 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •