Page 4 of 12 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 119

Thread: Unity panel always displayed on top of fullscreen windows

  1. #31
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    425
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    Yeah... between the two of us we have plenty of information here but no solutions...

  2. #32
    Join Date
    Dec 2006
    Beans
    39
    Distro
    Ubuntu Development Release

    Re: Unity panel always displayed on top of fullscreen windows

    Anyone reported a bug on this? I have the same thing - every fullscreen application appears behind the top panel though behaves as if it is behind it...

    ALSO, with the launcher in its 12.04 default behaviour of never hide, the Launcher does the same and appears on top whilst being unusable.

    I have seen bug reports relating to this behaviour on a multi-monitor setup, but was beginning to wonder if this is not so much a bug as REALLY annoying design?

  3. #33
    Join Date
    Dec 2006
    Beans
    39
    Distro
    Ubuntu Development Release

    Re: Unity panel always displayed on top of fullscreen windows

    Bit of an update...

    I seem to have fixed this by randomly crashing about in ccsm...

    I was using Cube, so in the interests of getting to a 'normal' setup I switched to desktop Wall...with the usual conflicts and disabling then re-enabling Unity. I did have Gnome Compatibility active, which seemed to cause conflicts with Unity at some point so I have disabled it.

    The always-on-top Unity behaviour disappeared when using Desktop Wall...so I figured what the hell and re-enabled Cube. Success! I now have fullscreen applications, Cube, and no Unity appearing on top...

    Slight warning - I did the same thing on a second machine and it didn't work - but since I had exported the profile from ccsm t Ubuntu One I just imported it into the new machine and have got rid of this bug in both machines.

  4. #34
    Join Date
    Feb 2012
    Beans
    4

    Re: Unity panel always displayed on top of fullscreen windows

    Is this along the same lines as your problem? For me everything seems to work except Firefox fullscreen, especially with Youtube fullscreen. This is a screenshot of a Youtube video fullscreened.

    http://dl.dropbox.com/u/4240139/Scre...%3A50%3A13.png

    The only thing is I wasn't even seeing part of the Youtube panels except for the progress bar behind the top and bottom gnome panels.

    P.S. I'm using gnome classic, and Ubuntu 12.04

  5. #35
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    425
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    Quote Originally Posted by chicken159 View Post
    I had exported the profile from ccsm t Ubuntu One I just imported it into the new machine and have got rid of this bug in both machines.
    You may be on to something here.

    Perhaps this is some undocumented setting / feature that's been left enabled by old profile data. Technically that isn't possible, since I saw the same bug on different machines and even in fresh installs, but then again anything's possible.

    Can you zip and upload your compiz profile? I'd love to compare it to mine.

    Quote Originally Posted by Nerdy314159265 View Post
    Is this along the same lines as your problem? For me everything seems to work except Firefox fullscreen, especially with Youtube fullscreen. This is a screenshot of a Youtube video fullscreened.

    http://dl.dropbox.com/u/4240139/Scre...%3A50%3A13.png

    The only thing is I wasn't even seeing part of the Youtube panels except for the progress bar behind the top and bottom gnome panels.

    P.S. I'm using gnome classic, and Ubuntu 12.04
    Yes and no.
    I see the panel showing (partially) over your full-screen application, but you have some additional graphical corruption near the top and bottom of the screen.
    This could be two bugs.

  6. #36
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    425
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    Here's an interesting blog post.

    According to this, it could be an undocumented design flaw.

    Apparently windows in full-screen must have their window type changed to "Popup" to get over the panel in gtk3 (both gnome-shell and unity are gtk3).

    Why then should not windows that are full-screen automatically be designated "Popup" or better yet why not allow the full-screen function to simply make things full-screen?

    Also, bug reports:
    This one was expired. Probably ignored because the description was unclear.
    They say this is a multimonitor-only, and therefore different, bug. I believe they are related bugs, if not the same bug.
    Last edited by quequotion; March 13th, 2012 at 04:00 PM.

  7. #37
    Join Date
    Dec 2006
    Beans
    39
    Distro
    Ubuntu Development Release

    Re: Unity panel always displayed on top of fullscreen windows

    Here's my ccsm profile...in case it helps! I suspect it has some leftover settings lying around from several iterations of update and trying things out (and it does exhibit the ongoing annoying previous-workspace-flash bug - hence the name).

    Also - note that on the original machine it was just the process of going from cube > wall > cube which seemed to clear the problem (which is probably easier - if a bit scary what with it disabling unity in the process).

    Be interesting to know what changed to sort this out...
    Attached Files Attached Files

  8. #38
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    425
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    Quote Originally Posted by chicken159 View Post
    Here's my ccsm profile...in case it helps! I suspect it has some leftover settings lying around from several iterations of update and trying things out (and it does exhibit the ongoing annoying previous-workspace-flash bug - hence the name).

    Also - note that on the original machine it was just the process of going from cube > wall > cube which seemed to clear the problem (which is probably easier - if a bit scary what with it disabling unity in the process).

    Be interesting to know what changed to sort this out...
    Thanks!
    I'll take a look at this tonight.

    In the mean time, maybe you've already heard, some progress is being made on the windows flashing on the wrong workspace issue:

    It's not a fix, but it will do for now. Check out this thread and my small revision.

  9. #39
    Join Date
    Dec 2006
    Beans
    39
    Distro
    Ubuntu Development Release

    Re: Unity panel always displayed on top of fullscreen windows

    Yeah thanks - I'd seen that - I think I've just got used to the flashing such that it doesn't annoy me enough and will wait and see what happens with a durable fix, which just shows that the rotating cube is about usability and productivity, not just looking cool (On the other hand...I was using transparancy to see where everything was on my desktops before...but I'm liking my new pangolin wallpaper so much that its turned off except on rotate now...and thats just about looking good!)

  10. #40
    Join Date
    Feb 2012
    Beans
    4

    Re: Unity panel always displayed on top of fullscreen windows

    Quote Originally Posted by quequotion View Post
    I see the panel showing (partially) over your full-screen application, but you have some additional graphical corruption near the top and bottom of the screen.
    This could be two bugs.
    I forgot to mention, those graphical corruptions were only in the screenshot. Just looking at the screen it didn't show up like that at all. I had the panels covering the Youtube window without any other glitches at all, they were simply overlaid.

Page 4 of 12 FirstFirst ... 23456 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •