Page 5 of 5 FirstFirst ... 345
Results 41 to 47 of 47

Thread: No wireless: atheros AR5001x, ubuntu 11.04

  1. #41
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,554
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: No wireless: atheros AR5001x, ubuntu 11.04

    Golly, we sure have been busy here, haven't we? I think an important clue was given and consistently ignored way back in post #1. Instead of addressing the error, we've installed compat-wireless, madwifi, considered ndiswrapper and done lots of blacklisting and unblacklisting, all to no avail, since the original error remains unresolved:
    [ 15.501196] ath5k 0000:00:06.0: can't find IRQ for PCI INT A; please try using pci=biosirq
    [ 15.501271] ath5k 0000:00:06.0: registered as 'phy0'
    [ 15.501284] ath5k phy0: request_irq failed
    [ 15.501312] ath5k: probe of 0000:00:06.0 failed with error -16
    Before you do the obvious, that is try a boot parameter pci=biosirq, I'd look around in the computer's BIOS to see how the IRQs are assigned. In my several systems, I have the best luck with Auto Select. Please see attached.

    This is a screenshot from an IBM computer, but most brands have a similar selection available.

    If you can make a change, be sure to save your changes and let the computer boot into Ubuntu. Check dmesg for the error again. If it still appears, we'll need to load the suggested boot parameter. If so, please see here: http://ubuntuforums.org/showthread.php?t=1613132

    Scroll down to How to permanently set kernel boot options on an installed OS (not wubi). The boot option you want is, of course, not nomodeset, but pci=biosirq.

    After making your change, be sure to save and close gedit. Reboot and check dmesg for the error. Then we'll unsnarl the driver. Sigh...

    By the way, the "Ethernet Controller" name is a red herring. It's meaningless.
    Attached Images Attached Images
    Last edited by chili555; September 22nd, 2011 at 02:06 PM.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  2. #42
    Join Date
    Sep 2011
    Beans
    24

    Re: No wireless: atheros AR5001x, ubuntu 11.04

    My BIOS is very limited. I can set a password, the time, choose the amount of shared memory and set the boot order. Thats it, nothing about IRQ's.

    I followed the instructions and added pci=biosirq, saved, closed, rebooted, but dmesg doesn't change much:
    Code:
    [    0.328673] device-mapper: multipath: version 1.2.0 loaded
    [    0.328679] device-mapper: multipath round-robin: version 1.0.0 loaded
    [   22.333255] ath5k 0000:00:06.0: enabling device (0000 -> 0002)
    [   22.333269] ath5k 0000:00:06.0: can't find IRQ for PCI INT A
    [   22.333348] ath5k 0000:00:06.0: registered as 'phy0'
    [   22.333357] ath5k phy0: request_irq failed
    [   22.333385] ath5k: probe of 0000:00:06.0 failed with error -16

  3. #43
    Join Date
    Sep 2011
    Beans
    24

    Re: No wireless: atheros AR5001x, ubuntu 11.04

    Quote Originally Posted by praseodym View Post
    This is not a driver problem, obviously sth. with acpi/BIOS. Please do:

    Code:
    dmesg >> dmesg-Ohramgis.txt
    and upload this .txt-file
    I couldn't upload it here since its size exceeds the forum limit, so I put it on paste.org. Here's the link:
    http://paste.org/pastebin/view/38734

  4. #44
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,554
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: No wireless: atheros AR5001x, ubuntu 11.04

    You might check here: http://www.linuxforums.org/forum/wir...ar5001x-5.html
    It's a Packard Bell Easy NoteR. I buy this machine almost 5 years ago for a computer he should be already withdrawn, for a long time.
    Then check here: http://www.linuxforums.org/forum/wir...ar5001x-8.html
    I got it working now adding these options to the kernel boot parameters, as the BIOS really seems screwed about these:
    Code:
    acpi=force irqpoll noapictimer
    after that simply typing
    Code:
    modprobe ath5k
    was enough to have the wifi networks show up in NetworkManager.
    Then the next post says:
    I registered to this site just to say.... THANK YOU!!!
    Sanne's solution worked with me and a Easynote 1010R. I was giving up when I found this post, and your solution!!
    I suggest you change your GRUB boot parameters as shown and try again.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #45
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    5,724
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: No wireless: atheros AR5001x, ubuntu 11.04

    ACPI: BIOS age (520) fails cutoff (2000), acpi=force is required to enable ACPI
    Try this parameter instead.

    I dont know what that is:

    HPET not enabled in BIOS. You might try hpet=force boot option
    and that

    [ 0.154675] PnPBIOS: Warning! Your PnP BIOS caused a fatal error. Attempting to continue
    [ 0.154678] PnPBIOS: You may need to reboot with the "pnpbios=off" option to operate stably
    [ 0.154681] PnPBIOS: Check with your vendor for an updated BIOS
    Looks like you should try several kernel parameters or upgrade your BIOS

  6. #46
    Join Date
    Sep 2011
    Beans
    24

    Re: No wireless: atheros AR5001x, ubuntu 11.04

    OMG IT WORKS!

    For those with a similar problem, this fixed it for me:
    Code:
    gksudo gedit /etc/default/grub
    Changing
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    to
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=biosirq acpi=force"

    Save it, exit it.
    Code:
    sudo update-grub
    Reboot, et voila! Not only does the wireless work, but the battery indicator suddenly works too!

    A MASSIVE thank you to you all for your help.

    edit: to be complete: you don't even need pci=biosirq. By now, my boot time seemed to have quadrupled. So I did a fresh install and only added acpi=force to the grub file.
    Last edited by Ohramgis; September 23rd, 2011 at 10:37 AM.

  7. #47
    Join Date
    Jul 2007
    Location
    Embra
    Beans
    6
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: No wireless: atheros AR5001x, ubuntu 11.04

    Thanks Ohramgis! This worked a treat on my Packard Bell Easynote, and I'd wondered where the battery indicator had disappeared to!

Page 5 of 5 FirstFirst ... 345

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •