Results 1 to 7 of 7

Thread: Possible to disable SpeedStep on battery power?

  1. #1
    Join Date
    Dec 2005
    Beans
    47
    Distro
    Ubuntu 11.04 Natty Narwhal

    Possible to disable SpeedStep on battery power?

    I have Dell Latitude D620 with Ubuntu 11.04. How can I disable the Intel SpeedStep when using the laptop on battery power?

    Now the CPU is constantly running on 1 GHz, when it could do double. In BIOS settings, it says that disabling the SpeedStep will put the CPU to a lower performance mode, and there's no other option...

  2. #2
    Join Date
    Oct 2009
    Beans
    151
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Possible to disable SpeedStep on battery power?

    You can always control manually the frequency. Or do a customized cpufreqd.conf.
    To manually control the frequency, there are a number of interface plugins (for gnome, for unity - needs a ppa).
    I had to make a customized cpufreq configuration so my tablet wouldn't pass 100C idle... languague is a bit confusing at the start, but works like a charm
    (you can, for instance, make the processor stay full power if a given program is running... its quite good)

  3. #3
    Join Date
    Dec 2005
    Beans
    47
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Possible to disable SpeedStep on battery power?

    Thanks for quick response I installed indicator-cpufreq (from http://ubuntuguide.net/change-and-mo...icator-cpufreq), but if I switch it to 2 GHz setting, it immediately falls back to 1 GHz... I wonder if the BIOS is more persistent in saving the battery than full performance?

  4. #4
    Join Date
    Oct 2009
    Beans
    151
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Possible to disable SpeedStep on battery power?

    It's not the bios, it is the deamon...... do a service cpufreqd stop first, then it will work

  5. #5
    Join Date
    Dec 2005
    Beans
    47
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Possible to disable SpeedStep on battery power?

    Uff, stopping the cpufreqd didn't help... I rebooted, and now I can switch between 1.00 and 1.33 GHz...

    I also tried disabling the SpeedStep in BIOS, then the freq really stays at 1 GHz, and the applet fails to load too.
    Last edited by mexp; September 15th, 2011 at 04:11 PM.

  6. #6
    Join Date
    Oct 2009
    Beans
    151
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Possible to disable SpeedStep on battery power?

    Tbh what I don't understand is why would you need that? With an ondemand governor (and a proper cpufreqd.conf) it would go automatically to 100% when you need it and stay low otherwise (not much of a point running NOPs on the max frequency... even less on battery).

    Anyway, I'm sure you can do what you want by editing the configuration of cpufreqd.

  7. #7
    Join Date
    Dec 2005
    Beans
    47
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Possible to disable SpeedStep on battery power?

    Well I have a reason: I use the laptop mostly with 12 V DC adapter (upping it to 18-19 volts). Apparently Dell laptops do not accept any other power sources but their original AC adapter, and the there's a startup message telling that the adapter is not the right one. I can still use it with 12 volts, but it's always on lower performance mode, that is, running on 1 Ghz instead of 2. I'm not sure if it's the Cpu or the Gpu, but even some graphic/flash intensive web sites make some stutter, and this does not happen when I use mains, 220 V DC.

    Hope this makes sense

    What kind of configuration file should I try?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •