Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: HOWTO: easy mplayer for warty.

  1. #1
    Join Date
    Dec 2004
    Location
    Santiago, Chile
    Beans
    311
    Distro
    Ubuntu Breezy 5.10

    HOWTO: easy mplayer for warty.

    Here's a little and easy howto for warty. I got a lot of help from this post: http://www.ubuntuforums.org/showthread.php?t=94 and from http://www.ubuntulinux.org/wiki/RestrictedFormats

    I think this is the best way to get mplayer running easily and fast. The only downside: xmms. I dont know why the hell you must have it, and I hope this gets fixed for hoary. Well, here we go.

    First of all, we're gonna update our whole ubuntu system. We should follow the following steps (Taken from www.ubuntuguide.org):

    First, update your /etc/apt/sources.list:
    Code:
    $ sudo cp /etc/apt/sources.list /etc/apt/sources.list_backup
    $ sudo gedit /etc/apt/sources.list
    Delete the whole thing, and copy-paste this:
    Code:
    deb cdrom:[Ubuntu 4.10 _Warty Warthog_ - Preview i386 Binary-1 (20041020)]/ unstable main restricted 
    
    
    ## Uncomment the following two lines to fetch updated software from the network
    deb http://archive.ubuntu.com/ubuntu/ warty main restricted
    deb-src http://archive.ubuntu.com/ubuntu/ warty main restricted
    
    ## Uncomment the following two lines to add software from the 'universe'
    ## repository.
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## universe WILL NOT receive any review or updates from the Ubuntu security
    ## team.
    deb http://archive.ubuntu.com/ubuntu/ warty universe
    deb-src http://archive.ubuntu.com/ubuntu/ warty universe
    
    deb http://security.ubuntu.com/ubuntu/ warty-security main restricted
    deb-src http://security.ubuntu.com/ubuntu/ warty-security main restricted
    
    deb http://archive.ubuntu.com/ubuntu/ warty multiverse
    deb-src http://archive.ubuntu.com/ubuntu/ warty multiverse
    
    deb ftp://ftp.nerim.net/debian-marillat/ stable main
    deb ftp://ftp.nerim.net/debian-marillat/ unstable main
    deb ftp://ftp.nerim.net/debian-marillat/ testing main
    
    deb http://ubuntu-bp.sourceforge.net/ubuntu/ warty-backports main universe
    Now, we follow these steps:
    Code:
    $sudo apt-get update
    $sudo apt-get upgrade
    Now we are able to install the codecs, mplayer and the plugins.

    Open up a console and do this:
    Code:
    sudo apt-get install manpages-dev autoconf automake libtool flex bison gcc-doc g++ x-window-system-dev libgtk1.2-dev libpng12-dev libgtk2.0-dev libdirectfb-0.9-20 libfaad2-0 libggi2 liblame0 libpostproc0 libsvga1 libxvidcore4 xmms gstreamer0.8-plugins w32codecs
    Then we get our hands dirty .

    Let's create a "work" folder in our home folder so we dont get our folders all messy:
    Code:
    mkdir ~/work
    Now we change into that folder and download the corresponding version of mplayer for our CPU.

    If you use warty, get mplayer from here:
    Code:
    http://sh.nu/~crimsun/mplayer/
    For example, if you have a pentium 4, get the 686 version. For Athlon (XP), get k6 (as k7 is just a dummy package).

    Download it to the recently created "work" folder.

    Next, we will install it:
    Code:
    cd ~/work
    sudo dpkg -i mplayer-*
    Now we have mplayer. You can run the following command to run it:
    Code:
    gmplayer
    Dont worry if it doesnt appear in your Multimedia menu, it will when you reboot your x server (by pressing ctrl+alt+backspace if you dont want to reboot your pc).

    Now that we have mplayer running, close it , we will have to get the plugins. Unfortunately, the mplayer plugins for mozilla that ubuntu has just suck. So we will make our own (dont worry, it too easy).

    First, get these files, and download them to your work directory!:
    Code:
    http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.6/gecko-sdk-i686-pc-linux-gnu-1.6.tar.gz
    http://prdownloads.sourceforge.net/mplayerplug-in/mplayerplug-in-2.70.tar.gz?download
    Now open a console and do this:
    Code:
    cd ~/work
    tar -xzvf gecko-sdk-i686-pc-linux-gnu-1.6.tar.gz
    tar -xzvf mplayerplug-in-2.70.tar.gz
    cd mplayerplug-in
    ./configure --with-gecko-sdk=~/work/gecko-sdk
    make
    Now, if you have firefox, do this:
    Code:
    sudo cp ~/work/mplayerplug-in/mplayerplug-in.so /usr/lib/mozilla-firefox/plugins
    sudo cp ~/work/mplayerplug-in/mplayerplug-in.xpt /usr/lib/mozilla-firefox/components
    And for the mozilla suite, do this:
    Code:
    sudo cp ~/work/mplayerplug-in/mplayerplug-in.so /usr/lib/mozilla/plugins
    sudo cp ~/work/mplayerplug-in/mplayerplug-in.xpt /usr/lib/mozilla/components
    Now close all your firefox/mozilla windows and open a new one. To test the plugin, go here:
    Code:
    http://www.apple.com/trailers/
    And watch a trailer. Have fun!

  2. #2
    Join Date
    Dec 2004
    Location
    In Transition (Moving)
    Beans
    21
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: easy mplayer for warty.

    Thanks for the mplayer tutorial. I had some problmes though.

    When I got to the make command after grabbing the goodies for the plugins. I had srolling errors out the wazoo.
    Here is just a few I grabbed (there where so many I can't get them all). This is just the tail end. Have I neglected in getting something important to make them?

    Code:
    Source/plugin.cpp:1865: error: `embed_height' undeclared (first use this
       function)
    Source/plugin.cpp:1866: error: `embed_width' undeclared (first use this
       function)
    Source/plugin.cpp:1868: error: `window_height' undeclared (first use this
       function)
    Source/plugin.cpp:1869: error: `window_width' undeclared (first use this
       function)
    Source/plugin.cpp:1965: error: `NP_FULL' undeclared (first use this function)
    Source/plugin.cpp:1978: error: `movie_height' undeclared (first use this
       function)
    Source/plugin.cpp:1978: error: `movie_width' undeclared (first use this
       function)
    Source/plugin.cpp: At global scope:
    Source/plugin.cpp:2191: error: `PRBool' was not declared in this scope
    Source/plugin.cpp:2191: error: `_retval' was not declared in this scope
    Source/plugin.cpp:2192: error: variable or field `GetShowlogo' declared void
    Source/plugin.cpp:2192: error: `int nsPluginInstance::GetShowlogo' is not a
       static member of `class nsPluginInstance'
    Source/plugin.cpp:2192: error: syntax error before `{' token
    Source/plugin.cpp:2197: error: parse error before `)' token
    Source/plugin.cpp:2219: error: syntax error before `::' token
    Source/plugin.cpp:2237: error: syntax error before `*' token
    Source/plugin.cpp:2240: error: parse error before `*' token
    Source/plugin.cpp: In member function `nsScriptablePeer*
       nsPluginInstance::getScriptablePeer()':
    Source/plugin.cpp:2265: error: `NS_ADDREF' undeclared (first use this function)
    Source/plugin.cpp: In member function `nsControlsScriptablePeer*
       nsPluginInstance::getControlsScriptablePeer()':
    Source/plugin.cpp:2279: error: `NS_ADDREF' undeclared (first use this function)
    make: *** [plugin.o] Error 1
    Also, probably as a result of the error in make I'm getting these errors when I run....
    Code:
    sudo cp ~/work/mplayerplug-in/mplayerplug-in.so /usr/lib/mozilla-firefox/plugins
    Here is the resulting error.....
    Code:
    cp: cannot stat `/home/tristan/work/mplayerplug-in/mplayerplug-in.so': No such file or directory
    When I run....
    Code:
    sudo cp ~/work/mplayerplug-in/mplayerplug-in.xpt /usr/lib/mozilla-firefox/components
    The result is.....
    Code:
    cp: cannot stat `/home/tristan/work/mplayerplug-in/mplayerplug-in.xpt': No such file or directory
    I have obviously done something wrong or I don't have something important.
    Any ideas?

    Thanks
    Last edited by Phosphoros; March 7th, 2005 at 06:22 AM.

  3. #3
    Join Date
    Mar 2005
    Beans
    5

    Re: HOWTO: easy mplayer for warty.

    The following worked for me to compile the firefox plugin:
    Code:
    cd ~/work
    tar -xzvf gecko-sdk-i686-pc-linux-gnu-1.6.tar.gz
    tar -xzvf mplayerplug-in-2.70.tar.gz
    sudo chown -R username *
    cd mplayerplug-in
    ./configure --with-gecko-sdk=/home/username/work/gecko-sdk
    make
    Note that I first made myself the owner of all the extracted files (replace "username" with your username) and also specified the complete path to gecko.

  4. #4
    Join Date
    Dec 2004
    Location
    In Transition (Moving)
    Beans
    21
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: easy mplayer for warty.

    Yay! Thank you Dethread! That worked like a charm.

  5. #5
    Join Date
    Feb 2005
    Location
    Heverlee, Belgium
    Beans
    139
    Distro
    Ubuntu 6.06

    Re: HOWTO: easy mplayer for warty.

    Quote Originally Posted by Phosphoros
    Yay! Thank you Dethread! That worked like a charm.
    Thanks for the guide,
    Mplayer works fine now in warty.

  6. #6
    Join Date
    Mar 2005
    Location
    Salvador-Bahia-Brazil
    Beans
    5

    Smile How to install mplayer

    Hi, as all newby in linux after many years as windows user I´ve had been some difficult to install some programs. In this moment the program in question is mplayer k7 for semprom2200. I found in some foruns here some explanations what about how to download and install it, but honestely I´ve try nut I couldn´t. Can some one give a step by step help???
    Tks a lot
    Last edited by ldoria; March 22nd, 2005 at 04:59 AM.

  7. #7
    Join Date
    Dec 2004
    Location
    Santiago, Chile
    Beans
    311
    Distro
    Ubuntu Breezy 5.10

    Re: How to install mplayer

    Quote Originally Posted by ldoria
    Hi, as all newby in linux after many years as windows user I´ve had been some difficult to install some programs. In this moment the program in question is mplayer k7 for semprom2200. I found in some foruns here some explanations what about how to download and install it, but honestely I´ve try nut I couldn´t. Can some one give a step by step help???
    Tks a lot
    well, you have the guide there.. and seeing you have a sempron, you should download the k6 version. (as the k7 version is a dummy one),

  8. #8
    Join Date
    Feb 2005
    Beans
    Hidden!

    Re: How to install mplayer

    Quote Originally Posted by RastaMahata
    well, you have the guide there.. and seeing you have a sempron, you should download the k6 version. (as the k7 version is a dummy one),
    I just reinstalled warty ... I just added marillat's repositories and got mplayer. What is wrong with this method ?

  9. #9
    Join Date
    Dec 2004
    Location
    Santiago, Chile
    Beans
    311
    Distro
    Ubuntu Breezy 5.10

    Re: How to install mplayer

    Quote Originally Posted by bored2k
    I just reinstalled warty ... I just added marillat's repositories and got mplayer. What is wrong with this method ?
    err, as far as I know, marillat's mplayer gives you several problems with warty (dependancy problems, non existant packages in warty). I'll do a apt-get update/upgrade and see how it goes :S

    edit:
    It asks for:
    libarts (>= 4:2.2.2-1) or libarts-alsa (>= 4:2.2.2-1), libdvdread2 and libvorbis0 (>= 1.0rc3-1), all are non-existant in warty.
    Last edited by RastaMahata; March 23rd, 2005 at 12:15 PM.

  10. #10
    Join Date
    Mar 2005
    Location
    Providence, RI USA
    Beans
    1

    Re: HOWTO: easy mplayer for warty.

    Quote Originally Posted by RastaMahata
    Here's a little and easy howto for warty. I got a lot of help from this post: http://www.ubuntuforums.org/showthread.php?t=94 and from http://www.ubuntulinux.org/wiki/RestrictedFormats

    I think this is the best way to get mplayer running easily and fast. The only downside: xmms. I dont know why the hell you must have it, and I hope this gets fixed for hoary. Well, here we go.
    Thanks for the great tutorial.

    I'm very new to Linux, and I'm having some dependency problems that are making me feel particularly clueless. I got this:

    dpkg: dependency problems prevent configuration of mplayer-586:
    mplayer-586 depends on libdirectfb-0.9-20; however:
    Package libdirectfb-0.9-20 is not installed.
    mplayer-586 depends on libfaad2-0 (>= 2.0.0-0.1); however:
    Package libfaad2-0 is not installed.
    mplayer-586 depends on libggi2 (>= 1:2.0.4); however:
    Package libggi2 is not installed.
    mplayer-586 depends on liblame0 (>= 3.96.1-1); however:
    Package liblame0 is not installed.
    mplayer-586 depends on libpostproc0 (>= 0.90rc4); however:
    Package libpostproc0 is not installed.
    mplayer-586 depends on libxvidcore4 (>= 1:1.0.0-rc4-0.0); however:
    Package libxvidcore4 is not installed.
    dpkg: error processing mplayer-586 (--install):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of mplayer-686:
    mplayer-686 depends on mplayer-586; however:
    Package mplayer-586 is not configured yet.
    dpkg: error processing mplayer-686 (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    mplayer-586

    I followed every step to the letter. Any idea on what could be wrong?

    Thanks!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •