I've been trying to study various other threads, such as

and http://ubuntuforums.org/showthread.php?t=1838078 in an attempt to set up a newly-purchased Seagate 3TB external USB drive with GPT partitioning and use it to boot Ubuntu Oneiric and, in the future, additional Linux distributions, without perturbing my day-to-day laptop configuration.

My laptop is a 3.5 year old HP dv9000z with 4GB of memory, AMD Turion64 dual core CPU, NVIDIA GeForce 6150 graphics and a relatively vanilla Phoenix BIOS with, apparently, no (U)EFI capabilities. There are TWO 80GB SATA disk drives installed, the primary has Windows XP Media Edition (and its maintenance/re-installation partition), and the other drive has openSUSE 11.4.
GRUB 0.97 was installed by openSUSE, and I can either let it
boot openSUSE 11.4 automatically, or select Windows XP if I
really want to boot that. I have a Western Digital 250GB external
USB drive with standard old-fashioned MBR partitions and GRUB 0.97 (+/-, i.e. NOT GRUB2), and when it's plugged in prior to power-up, I can then boot various other distributions (Fedora, Natty, Mageia, ...) as desired. Yes, the BIOS boot device ordering is set correctly: DVD/CD, USB disk, internal hard disk, USB Floppy, ...

I'm trying to do something like that with the new 3TB. After
some fits and starts, I installed 'gdisk' on my openSUSE 11.4
system and used it to repartition using GPT. This drive has
4096 byte sectors. I've even been able to install Oneiric into a partition, and Fedora 16 to two others (/, /boot) as the latter is rumored to finally being able to cope with GPT and GRUB2.

However, I've not been able to boot either system and, in fact, can't even get a "GRUB>" prompt - the BIOS acts like the drive isn't there and starts the GRUB 0.97 on the first hard drive.
(As an aside, I have an Acer Aspire netbook with an Insyde H2O
EFI BIOS that boots an external 1TB with GPT and Ubuntu/Natty's
GRUB2 beautifully). openSUSE 11.4 comes up smiling, although the drive ordering is different (the 3TB shows up as /dev/sdb, the
Windows disk is /dev/sda, the openSUSE 11.4 disk is /dev/sdc).

My suspicion is that I've messed up the (boot block) and/or other
important partition tables by using gparted, fdisk, and other tools (even if just to look at something). I'm prepared to wipe the drive (dd if=/dev/zero... comes to mind!) as necessary.

Output from gdisk on openSUSE 11.4 as invoked as root, having plugged the 3TB drive in long after booting the system:

linux-9mjd:/home/obfuscated # gdisk /dev/sdc
GPT fdisk (gdisk) version 0.7.2

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.

Command (? for help): print
Disk /dev/sdc: 732566645 sectors, 2.7 TiB
Logical sector size: 4096 bytes
Disk identifier (GUID): D8FDAD5C-8335-46A3-BA1C-D44CF7D2C31E
Partition table holds up to 128 entries
First usable sector is 6, last usable sector is 732566639
Partitions will be aligned on 256-sector boundaries
Total free space is 626529130 sectors (2.3 TiB)
Number  Start (sector)    End (sector)  Size       Code  Name                                                   
   1             256             511   1024.0 KiB  EF02  BIOS boot partition                                    
   2             512          131583   512.0 MiB   EF00  ext4                                                   
   3          131584         1180159   4.0 GiB     8200  Linux swap                                             
   4         1180160        27394559   100.0 GiB   0700  Linux filesystem
   5        27394560        53608959   100.0 GiB   8300  Linux filesystem
   6        53608960        79823359   100.0 GiB   8300  Linux filesystem
   7        79823360       106037759   100.0 GiB   EF00  Ubuntu
I tried to create 1MiB BIOS boot partition (worked nicely on my netbook's 1TB), a 512MB /boot partition for F16 on the second partition, a 4GB swap partition, and then four 100GB partitions, one for each distro of interest. Oneiric is installed on partition 7, Fedora 16 root is on partition 4.

I've tried reinstalling ("grub-install") GRUB2 several times, even after booting the Oneiric Live CD and chrooting to the on-disk installation and using apt-get to update it to ensure that I had the latest-n-greatest bits. I'm assuming that I either don't understand GPT and GRUB2 well enough, or I've made a rash assumption about what can be legally/safely done. Any help would, of course, be greatly appreciated!

Thanks in Advance!