Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Natty 32bit - Help creating iso image from CDrom using Cli

  1. #11
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Natty 32bit - Help creating iso image from CDrom using Cli

    I've only watched the video once as it's very late here, but it seemed as though Brasero was working. Am I correct?

    When you did something like:

    Code:
    sudo if=/dev/cdrom0 of=~/file.iso
    It quickly errored. But when you did:

    Code:
    sudo if=/dev/cdrom0 of=file.iso
    You got an ISO in your home folder. Was it OK? Because if so, it seems that the tilda (~) is upsetting dd.

    Just a thought. I must log off in a few minutes and I'll come back to this thread in the morning (UK time).

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  2. #12
    Join Date
    Sep 2011
    Beans
    180
    Distro
    Ubuntu

    Re: Natty 32bit - Help creating iso image from CDrom using Cli

    Quote Originally Posted by coffeecat View Post
    I've only watched the video once as it's very late here, but it seemed as though Brasero was working. Am I correct?

    When you did something like:

    Code:
    sudo if=/dev/cdrom0 of=~/file.iso
    It quickly errored. But when you did:

    Code:
    sudo if=/dev/cdrom0 of=file.iso
    You got an ISO in your home folder. Was it OK? Because if so, it seems that the tilda (~) is upsetting dd.

    Just a thought. I must log off in a few minutes and I'll come back to this thread in the morning (UK time).
    Both of them gave me errors. I didnt try without the tilda, ill give it a go then update the thread.

    ----------------------------------
    UPDATE 4:02PM 9/13/11
    Here's what I tried
    Code:
    alex@griever:~$ sudo dd if=/dev/cdrom of=/disc1.iso
    [sudo] password for alex: 
    dd: reading `/dev/cdrom': Input/output error
    48+0 records in
    48+0 records out
    24576 bytes (25 kB) copied, 3.45497 s, 7.1 kB/s
    alex@griever:~$ sudo dd if=/dev/sr0 of=/disc1.iso
    dd: reading `/dev/sr0': Input/output error
    48+0 records in
    48+0 records out
    24576 bytes (25 kB) copied, 0.00492048 s, 5.0 MB/s
    alex@griever:~$ dd if=/dev/scd0 of=/cd.iso
    dd: opening `/cd.iso': Permission denied
    alex@griever:~$ sudo dd if=/dev/scd0 of=/cd.iso
    dd: reading `/dev/scd0': Input/output error
    48+0 records in
    48+0 records out
    24576 bytes (25 kB) copied, 0.0064936 s, 3.8 MB/s
    I tried all three of those and for some reason it keeps giving me a reading error of that drive,
    but even with or without the tilda I get the same issue.
    it still creates an image (.iso) file but the file is blank, no data what so ever.
    Last edited by AlexOnVinyl; September 14th, 2011 at 12:04 AM. Reason: Updating

  3. #13
    Join Date
    Sep 2011
    Beans
    180
    Distro
    Ubuntu

    Re: Natty 32bit - Help creating iso image from CDrom using Cli

    Okay. so I found something intriguing - I was looking around and I found out that certain cds are written with multitracks - eg: playstation cds. the data is written to "Playstation-Cd's because the data track is written in mode 2 which dd can't read, and because the Cd's are multitrack (one data-track and several audio-tracks)."(13 September 2011)
    http://linuxreviews.org/howtos/cdrecording/

    according to the article, I'm going to have to do this:

    Code:
    cdrdao read-cd --read-raw --datafile [filename.bin] --device [bus,id,lun] --driver generic-mmc-raw [filename.toc]



  4. #14
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: Natty 32bit - Help creating iso image from CDrom using Cli

    Last post in this thread shows the questions were related to an activity we wont support here.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •