Thanks Hakunka, I went to that site that you suggested. I entered the gconf-editor. I browsed to Browse to /apps/nautilus/preferences/media_automount. It was already checked, indicating a yes. In addition, /apps/nautilus/preferences/media_automount_open is also checked, indicating a yes.

Is it possible that Ubuntu 10.04 does not detect the drive is because maybe the drivers for the external hard drive is corrupt?