Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: Screen Dimming During Inactivity Despite Being Set to Not Do So?

  1. #21
    Join Date
    Sep 2006
    Location
    Central Europe
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Screen Dimming During Inactivity Despite Being Set to Not Do So?

    No, that's the way it currently works. :-/
    The Power User’s Guide to Unity
    Questions about Ubuntu? Ask them at askubuntu.com!

  2. #22
    Join Date
    Mar 2006
    Location
    Denver, CO
    Beans
    392
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Screen Dimming During Inactivity Despite Being Set to Not Do So?

    When I wake up the display after it shuts off, the screen is dimmed to about 10%. I have to adjust the system brightness to get it back.

  3. #23
    Join Date
    Apr 2008
    Beans
    10,772

    Re: Screen Dimming During Inactivity Despite Being Set to Not Do So?

    I only know that I don't get this with Lubuntu, only Ubuntu. And I also get this with Fedora and the default Gnome DE.

    I've not bothered trying LXDE w/Fedora to see what happens but I fail to see the point.

    IMHO this has to be a flaw in gnome 3. I tend to think the gnome devs focused on eye candy and forgot about functions that effect everyday usage

    I'm now so happy with Lubuntu I doubt I'll ever go back to gnome.

  4. #24
    Join Date
    Aug 2007
    Location
    a puddle in Manchester
    Beans
    9,206
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Screen Dimming During Inactivity Despite Being Set to Not Do So?

    Quote Originally Posted by mc4man View Post
    If does so here on 2 setups, around 10 min or so. At least here it has nothing to do with gnome-screensaver, something in the power settings/bios/monitor
    Can take care of here through a blanket section in xorg.conf, noting that this doesn't affect the time to dim in gnome-screensaver, 2 different things

    Code:
    Section "ServerFlags"
            Option	"BlankTime"	"0"
            Option	"StandbyTime"	"0"
            Option	"SuspendTime"	"0"
            Option	"OffTime"	"0"
    EndSection
    Interesting. I just tried that addition to xorg.conf and now it won't boot at all. If I remove quiet splash I get an "OK" half way down the right side of the (black) screen and that's it! No disc activity, no login screen, nothing.
    After a couple more tries I tty'd and removed xorg.conf and rebooted.
    Now it will boot fine.
    I'm confused.
    I'm using gnome-shell on 64 bit. Would that have anything to do with it?
    MacBook Pro 10,1 retina

  5. #25
    Join Date
    Jun 2007
    Beans
    13,070

    Re: Screen Dimming During Inactivity Despite Being Set to Not Do So?

    At least here the screen 'dimming' or blanking was also affected by DPMS (Energy Star)
    So the xorg section was effective in preventing that.
    Just ran across this thread which was informative & has an alt. method I like better - posts 17 & 18
    http://ubuntuforums.org/showthread.php?t=1483345
    ( to check - xset -q
    off - xset -dpms
    back on - xset dpms

  6. #26
    Join Date
    Jan 2005
    Location
    Serbia
    Beans
    11

    Re: Screen Dimming During Inactivity Despite Being Set to Not Do So?

    FWIW, org.gnome.settings-daemon.plugins.power has the relevant keys, as mentioned above: idle-dim-ac, idle-dim-battery and idle-dim-time. However, default values do not seem to be properly respected by the plugin, but if I "force" the setting (i.e. click the checkbox twice: once to change it, another time to restore it back), it starts working properly. I didn't have to restart Ubuntu or log out and back in, but I did try it out from within GNOME Shell. I didn't see this problem on my desktop (but I also run Unity there, though I suspect that has nothing to do with it, and it's more the fact that this is a laptop).

    If this is indeed the case, it sounds like a bug in gnome-settings-daemon that needs to be fixed.

  7. #27
    Join Date
    Mar 2007
    Location
    Caprica
    Beans
    1,995
    Distro
    Ubuntu Development Release

    Re: Screen Dimming During Inactivity Despite Being Set to Not Do So?

    I dealt with it on friday. I had one hour to make the HTPC work right or the wife would file for divorce. I threw in all settings I could find and succeeded to avoid dimming, blanking and screensaver. But it was made on a rush: It works, but I don't know exactly which settings are really necessary.

    ~/quick_fix.sh
    Code:
    #!/bin/bash
    # Work dammit
    
    # Disable screensaver start
    gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t bool /apps/gnome_settings_daemon/screensaver/start_screensaver false
    
    # Disable screensaver locking
    gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t bool /apps/gnome-screensaver/lock_enabled false
    
    # Disable screensaver altogether
    gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t bool /apps/gnome-screensaver/idle_activation_enabled false
    
    # Increase screensaver idle time (max 2h, we set to 10h)
    gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t bool /apps/gnome-screensaver/idle_delay 600
    
    # Disable DPMS screen blank on AC and battery
    gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t string /apps/gnome-power-manager/ac_dpms_sleep_method off 
    
    gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t string /apps/gnome-power-manager/battery_dpms_sleep_method off
    
    # Disable Computer sleep when on AC and battery
    gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t integer /apps/gnome-power-manager/ac_sleep_computer 0 
    
    gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t integer /apps/gnome-power-manager/battery_sleep_computer 0
    
    # Disable Display sleep when on AC and battery
    gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t integer /apps/gnome-power-manager/ac_sleep_display 0 
    
    gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t integer /apps/gnome-power-manager/battery_sleep_display 0
    
    # Disable Dim-on-Idle
    gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t bool /apps/gnome-power-manager/dim_on_idle false
    
    # Setterm
    setterm -powersave off -blank 0
    
    # xset stuff
    xset -dpms
    xset dpms 0 0 0
    xset s noblank
    xset s off
    Regards,
    Effenberg
    Last edited by effenberg0x0; September 26th, 2011 at 11:51 PM.

  8. #28
    Join Date
    Aug 2011
    Beans
    1

    Re: Screen Dimming During Inactivity Despite Being Set to Not Do So?

    Quote Originally Posted by paul_in_london View Post
    I did this too - also installed and ran dconf-editor and went to 'org --> gnome --> desktop --> screensaver and unchecked the box next to 'idle-activation-enabled'.

    See this thread:

    http://ubuntuforums.org/showthread.p...ht=screensaver

    Thanks that worked for me!

    Strange that "Applications -> System Settings -> Display->Dim screen to save power" had no effect though.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •