Page 100 of 137 FirstFirst ... 50909899100101102110 ... LastLast
Results 991 to 1,000 of 1362

Thread: HowTo: Windows (XP) on Ubuntu with VMWare Server

  1. #991
    Join Date
    Apr 2007
    Beans
    27

    Re: HowTo: Windows (XP) on Ubuntu with VMWare Server

    hello.
    it is stated that virtual machine will not work with hardware that is not identified with ubuntu, but what about a printer that works just with windows driver but is identified by ubuntu?

    i have USB lexmark X6170 that ubuntu recognize but without a proper linux driver.
    will my printer work through the virtual machine?

    thank

  2. #992
    Join Date
    Jul 2005
    Location
    2 exits past crazy
    Beans
    4,223
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: HowTo: Windows (XP) on Ubuntu with VMWare Server

    Quote Originally Posted by nivosh View Post
    hello.
    it is stated that virtual machine will not work with hardware that is not identified with ubuntu, but what about a printer that works just with windows driver but is identified by ubuntu?

    i have USB lexmark X6170 that ubuntu recognize but without a proper linux driver.
    will my printer work through the virtual machine?

    thank
    Good question. I would guess that it would work. Since Ubuntu can identify it, it means that there isn't a problem talking to it through the USB connection. It is just that Ubuntu doesn't know how to "speak the printer's native language." As long as the VM can talk to it over the USB bus, it should work. I have a Canon photo printer that is in the same boat. I'll have to setup a VM and see if I can print to it from inside the emulator.

  3. #993
    Join Date
    Sep 2006
    Location
    Stone City - Nanjing
    Beans
    503
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HowTo: Windows (XP) on Ubuntu with VMWare Server

    Veloce, I get the same error message as Cacharreo and the error is 'gcc: error trying to exec 'cc1plus': execvp: (No existe el fichero ó directorio) file or directory don't exist

    I actually had VMWare working on the version of Feisty prior to the official release. Then I played with 'desktop effects' and it killed everything so I reinstalled with the official release and now i can no longer get VMWare working. This cc1plus file seems to have been something to do with Debian from what I can see on google but I don't know where to get it from or, more importantly, why it seems to be no longer a part of Feisty?
    Ubuntu User # 10657
    ATI X600 on Dell 515m 3ghz cpu

  4. #994
    Join Date
    Apr 2007
    Location
    Hungary
    Beans
    1

    Re: HowTo: Windows (XP) on Ubuntu with VMWare Server

    thanks the guide ^^

  5. #995
    Join Date
    Feb 2007
    Location
    New Zealand
    Beans
    826
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HowTo: Windows (XP) on Ubuntu with VMWare Server

    Quote Originally Posted by carloslosgrande View Post
    Veloce, I get the same error message as Cacharreo and the error is 'gcc: error trying to exec 'cc1plus': execvp: (No existe el fichero ó directorio) file or directory don't exist

    I actually had VMWare working on the version of Feisty prior to the official release. Then I played with 'desktop effects' and it killed everything so I reinstalled with the official release and now i can no longer get VMWare working. This cc1plus file seems to have been something to do with Debian from what I can see on google but I don't know where to get it from or, more importantly, why it seems to be no longer a part of Feisty?
    I upgraded to Feisty from Edgy, used the "any to any" patch and config worked perfectly. So maybe something is carrying over from Edgy.

    I found it in folder:

    /usr/lib/gcc/i486-linux-gnu/4.1.2

    Don't know what package it would come in.
    Veloce
    Ubuntu 9.04 64bit on Dell Vostro 1510, Core2 Duo T8100, Nvidia 8400M , Intel 1395 Wireless.
    OK: Wireless, kvm, Canon irc2880, Synergy.

  6. #996
    Join Date
    Sep 2006
    Location
    Stone City - Nanjing
    Beans
    503
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HowTo: Windows (XP) on Ubuntu with VMWare Server

    Yeah, I've got the 'any any' package and with the earlier Feisty i had to use it twice and the 'vmware-server' package twice, ie v-s, a-a, v-s, a-a, and then everything worked. I've tried this more times than i can count now and it always has this error re cc1plus
    I don't have any carryover from Edgy because I haven't had Edgy. I went from Dapper to Feisty.
    Ubuntu User # 10657
    ATI X600 on Dell 515m 3ghz cpu

  7. #997
    Join Date
    Feb 2007
    Location
    New Zealand
    Beans
    826
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HowTo: Windows (XP) on Ubuntu with VMWare Server

    Quote Originally Posted by carloslosgrande View Post
    Yeah, I've got the 'any any' package and with the earlier Feisty i had to use it twice and the 'vmware-server' package twice, ie v-s, a-a, v-s, a-a, and then everything worked. I've tried this more times than i can count now and it always has this error re cc1plus
    I don't have any carryover from Edgy because I haven't had Edgy. I went from Dapper to Feisty.
    I think you need to (re) install the "build-essentials" package. Saw this on a vmware list.
    Veloce
    Ubuntu 9.04 64bit on Dell Vostro 1510, Core2 Duo T8100, Nvidia 8400M , Intel 1395 Wireless.
    OK: Wireless, kvm, Canon irc2880, Synergy.

  8. #998
    Join Date
    Apr 2007
    Beans
    27

    Re: HowTo: Windows (XP) on Ubuntu with VMWare Server

    Quote Originally Posted by yabbadabbadont View Post
    Good question. I would guess that it would work. Since Ubuntu can identify it, it means that there isn't a problem talking to it through the USB connection. It is just that Ubuntu doesn't know how to "speak the printer's native language." As long as the VM can talk to it over the USB bus, it should work. I have a Canon photo printer that is in the same boat. I'll have to setup a VM and see if I can print to it from inside the emulator.
    I SUCCEDED!!! the lexmark X6170 printer now works under ubuntu from within the virtual windows machine.

    this is great news for those with not working printers due to lack of linux driver!

    and now for another quastion.
    would someone please help me with the network and internet connection in vmware player.
    i have one ethernet card in which i connect with cable. the internet is working fine in ubuntu.
    how can i configure networking inorder to ba able to share folders with the host (ubuntu) and to be able to surf the net from the guest (windows XP)?
    the network adaptor is on - nat and VMplayer sayes it's connected, but no internet and no networking available.
    i installed samba and shared the folders i want.
    what next?

  9. #999
    Join Date
    Feb 2007
    Location
    New Zealand
    Beans
    826
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HowTo: Windows (XP) on Ubuntu with VMWare Server

    Quote Originally Posted by nivosh View Post
    I SUCCEDED!!! the lexmark X6170 printer now works under ubuntu from within the virtual windows machine.

    this is great news for those with not working printers due to lack of linux driver!

    and now for another quastion.
    would someone please help me with the network and internet connection in vmware player.
    i have one ethernet card in which i connect with cable. the internet is working fine in ubuntu.
    how can i configure networking inorder to ba able to share folders with the host (ubuntu) and to be able to surf the net from the guest (windows XP)?
    the network adaptor is on - nat and VMplayer sayes it's connected, but no internet and no networking available.
    i installed samba and shared the folders i want.
    what next?
    So your virtual windows machine is printing to an unsupported printer on the host? Cool! I must try this myself.

    Networking: Some questions:
    how are you connected to the internet? Is there a firewall somewhere?
    how is your vm getting an IP address?

    If you have networking working between the vm and host (samba file sharing) then this should be simple.
    Veloce
    Ubuntu 9.04 64bit on Dell Vostro 1510, Core2 Duo T8100, Nvidia 8400M , Intel 1395 Wireless.
    OK: Wireless, kvm, Canon irc2880, Synergy.

  10. #1000
    Join Date
    Apr 2007
    Beans
    27

    Re: HowTo: Windows (XP) on Ubuntu with VMWare Server

    Quote Originally Posted by veloce View Post
    So your virtual windows machine is printing to an unsupported printer on the host? Cool! I must try this myself.

    Networking: Some questions:
    how are you connected to the internet? Is there a firewall somewhere?
    how is your vm getting an IP address?

    If you have networking working between the vm and host (samba file sharing) then this should be simple.
    yes, i was very pleased to find out that my printer is printing...

    regarding the networking.
    i am using cable as my internet provider. i have firewall on my guest system (win xp pro)
    i have installed samba and shrad the folders in my host.
    the virtual network in configured as NAT and is connected.
    but there is no internet through the guest machine and i cant fined the shared folders in the guest.
    maybe i should do reinstalation of vmplayer?

Page 100 of 137 FirstFirst ... 50909899100101102110 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •