I'm having the same problem. Get the error message:
E: /var/cache/apt/archives/digikam2-data_2%3a2.1.1-natty~ppa1_all.deb: trying to overwrite '/usr/share/locale/ro/LC_MESSAGES/libkgeomap.mo', which is also in package libkgeomap-data 2.2.0-natty~ppa3
I think the problem is that the deb calls for libkgeomap-data as a dependency, but the same file is in the new digikam-data 2.2.0.

If that's the case, I either have to get the new install package to stop asking for the dependency or take it out of dgikam2-data 2.2.0.

If I figure it out, I'll let you know.