Page 4 of 4 FirstFirst ... 234
Results 31 to 34 of 34

Thread: No Wireless - Broadcom 4311

  1. #31
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No Wireless - Broadcom 4311

    prosperoa: I'm happy to try to help you, but it would be better if you could please start a new thread. Your issue may or may not stem from the same problem as the one we've been dealing with here; either way, there's already enough here that I think it would make more sense for you to start your own thread. Please do that, let me know the URL and I'll respond there.

    KemKev: thanks for posting all that output, and for going to the trouble of snapping photos of the BIOS screen. I believe you now that you've got no options! That's really terrible. I didn't know they were shipping BIOS programs that dumbed down these days. But I guess I should have assumed they were, since they know better than us what we want our computers to do.

    Unfortunately, I've scoured your dmesg output and I can't see any indication of why the green light would have come on during the session with "pci=rotueirq" enabled. I was hoping there might be some clue to be pulled from this but it appears not. In any case, it looks like the IRQ issue persists as usual regardless of whether the green light is on or not.

    At this point, I think I might have to admit defeat rather than continuing to make you run around in circles posting more and more output. Everything I've read suggests that you should be able to work around IRQ problems either by adding special kernel parameters or trying a different driver, but in your case it seems that nothing is helping.

    Since you didn't have this problem in Ubuntu 10.10, one possible workaround would be to downgrade to the Ubuntu 10.10 kernel, where your IRQ routing should work properly. You should be able to run a 10.10 kernel in 11.04 without trouble--your 11.04 applications will all still be there (and you won't have to reinstall the system), just with a slightly older kernel running in the background. You could easily install the 10.10 kernel using the packages from http://packages.ubuntu.com/search?ke...ck&section=all If you want to go this route and need more specific instructions, let me know.

    Otherwise, the only suggestion I can make is to file a bug report on Launchpad, where you will hopefully get the attention of people more qualified to troubleshoot IRQ problems than I. Again, if you want to file a report and don't know how, just let me know.

    By the way, I hate to tell you this, and I may be wrong (I'm no expert in hard drive issues), but those lines in your dmesg output that start with "ata3..." seem like they may be indicating a problem with your hard disk. You may want to check its health with smartctl (there are some instructions here), and as always, backup your important data! But again, I stress that I'm not an expert in these things and your drive may actually be perfectly fine, so don't panic just yet.
    Last edited by pytheas22; August 19th, 2011 at 03:53 AM.

  2. #32
    Join Date
    Jun 2008
    Beans
    47

    Re: No Wireless - Broadcom 4311

    OK. Thank you for all your help in troubleshooting the issue. Like I mentioned several posts ago, I have concluded that there is a bug in the 11.04 kernel that makes it incompatible with this laptop. I recall seeing a thread with the same topic (i.e. incomaptible laptops and Ubuntu) so at least I am not alone in that regard.

    I am curious as to how I would be able to run the 10.10 kernel in 11.04, so I will go through the linked page you included.

    In the interim, during one of my many reboots, I was cleaning up my basement and found a couple of AirLink 101 USB adapters that a friend gave me years ago because she wasn't using them. Out of curiosity I plugged one in and would you know it, after simply entering my network info, presto, wireless was working like a charm via the adapter. Nothing to install, nothing to fiddle with really. Ubuntu should work like that "out of the box"

    As an aside, regarding the potential hard drive failure, I did Google that particular error and from what I could see in a number of forums around the web, that error is also bug driven. I have done a comprehensive test of the hard drive, the only diagnostic option provided in the BIOS, and it indicated the drive is fine. Good catch though and thanks for the proactive suggestions.

    I have one printing problem (I can add a network printer but get an error printing to it) and will open a separate thread for that.

    Even though we did not get the results we wanted, thanks again for your patience in trying to work this through. Your directions / instructions were always clear and you were a real pro all the way.
    Last edited by KemKev; August 19th, 2011 at 09:51 AM.

  3. #33
    Join Date
    Jun 2008
    Beans
    47

    Re: No Wireless - Broadcom 4311

    Quote Originally Posted by pytheas22
    Since you didn't have this problem in Ubuntu 10.10, one possible workaround would be to downgrade to the Ubuntu 10.10 kernel, where your IRQ routing should work properly. You should be able to run a 10.10 kernel in 11.04 without trouble--your 11.04 applications will all still be there (and you won't have to reinstall the system), just with a slightly older kernel running in the background. You could easily install the 10.10 kernel using the packages from http://packages.ubuntu.com/search?ke...ck&section=all If you want to go this route and need more specific instructions, let me know.
    Specific instructions, please. Thanks much.

  4. #34
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No Wireless - Broadcom 4311

    Sure. To downgrade your kernel, first go to http://packages.ubuntu.com/maverick/....35-22-generic and download the appropriate kernel image for your architecture (i386 for 32-bit or amd64 for 64-bit). Save the .deb file to your desktop. Then run these commands to install it and add the new kernel entry to your grub boot menu:
    Code:
    cd ~/Desktop
    sudo dpkg -i linux*deb
    sudo update-grub
    Now you can boot into the older kernel by selecting it at the boot menu (if the grub menu isn't displayed by default, hold down shift during boot to bring it up). If you want to make the older kernel the default, you can edit the menuentry sections in the /boot/grub/grub.cfg file (the first section is the one that will be booted by default).

    In general all of your applications, etc. should work without issue in this slightly older kernel and shouldn't care which kernel you're running. But let me know if you run into problems.

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •